Problem with Capslock and some Special Characters

Discussion in 'Windows Guest OS Discussion' started by MasonM1, Sep 18, 2018.

  1. MasonM1

    MasonM1 Bit Poster

    Messages:
    2
    Hi,

    I support a user who uses some CAD Software (Revit 2018 & 2019) in a Windows 10 Pro Guest OS (Non-Bootcamp) using Parallels 14 and there's a strange issue where when capslock is activated the special characters on the right of her keyboard alternate as if the shift key is held. For example if capslock is active then the "," key will place a "<", the ". key will place a ">", etc

    This affects the following keys ,./;'[]\ However strangely enough it doesn't alternate the number keys to, for example place a "!" instead of a "1". Now normally I'd suspect the CAD Software running within Windows, but this also affects InDesign running inside the macOS Host and started happening after configuring Parallels with the Windows 10 Guest OS.

    What I've done so far includes:
    • Resetting macOS Keyboard settings
    • Resetting macOS Keyboard modifier settings
    • Changing the keyboard set within macOS from US to AU
    • PRAM reset on the iMac
    • reinstalling the drivers within the guest Windows OS via Device manager
    • Setting the keyboard type within the guest OS
    • Reinstalling the Parallels tools
    • resetting all of the parallels shortcut settings
    • Changing keyboards from a Bluetooth Keyboard (no numpad) to a USB Keyboard (With numpad)(Both Mac Keyboards)
    • Testing the keys without the guest or Parallels running (same result)
    Before using Parallels the user was using boot camp, but would force her computer off anytime windows was doing an update which eventually stopped bootcamp from working. Currently the bootcamp partition exists in case she remembers a vital file that might be needed, but it is not the guest OS that she uses as it is still corrupted and won't boot. While I don't feel it's likely that the bootcamp partition would cause these effects I felt I should mention it just in case.

    At this point I'm tempted to rebuild the entire Mac and then rebuild the virtual machine since my googling of this issue hasn't turned up much but figured I'd reach out and see if there was a solution I had missed
     
  2. RogerH6

    RogerH6 Kilo Poster

    Messages:
    219
    You say you have 'reset Mac OS keyboard modifier settings', but have you explicitly checked what caps lock is set for?.
    On the Mac.
    Settings.
    Keyboard.
    Keyboard tab. Modifier keys.
    Top entry is what the caps lock 'does'. Set to Caps Lock.

    Some programs can program this from the code. Ugh!...

    If you don't use caps lock much, perhaps try changing it to 'No Action'!...

    In 'In design' try resetting the preferences.

    In Revit, you can script changes to the keyboard mapping. Also the KS setting could assign different key operations.
     
  3. MasonM1

    MasonM1 Bit Poster

    Messages:
    2
    Hi Roger,

    I have tried setting the capslock function. It was originally set to the default function to act as a Capslock, but I then changed it to no action, clicked save, tested (and it had no action) then changed it back to it's default as acting like capslock and it returned to it's previous state.

    While it is possible that InDesign and Revit simultaneously had the settings change so that the capslock acts in the same way, It'd be very unlikely. However I had already reset inDesign preferences by holding a key combo when starting up (pressing Shift+Option+Command+Control).

    I haven't reset Revit Preferences yet as I expect the problem that's happening affecting both is going to be happening before the keypress gets to the programs themselves. But I'll have a poke around and see if there's a reset that can be done in Revit

    I have also tried to encourage the user to just not need to use caps any way they can, but she says that most of her work uses uppercase, so switching between is a pain. Also she heavily uses key combos which are broken when the capslock is enabled, eg "command + ," no longer works since it sends "command + <"

    Thanks for your suggestions!

    And if I do figure this one out I'll post the answer here.
     
  4. RogerH6

    RogerH6 Kilo Poster

    Messages:
    219
    Can I suggest you leave caps lock off, and show the user how to use the shift key double tap to get caps lock?. This is a thing that a lot of people don't know exists in the later Apple OS's.
    Not a fix, but at least a 'work round'... :)
     

Share This Page