Problem with Spotlight in Beta5

Discussion in 'Parallels Desktop for Mac' started by supriyo, Apr 27, 2006.

  1. supriyo

    supriyo

    Messages:
    17
    A few hours after I installed Beta5, Spotlight on my Macbook Pro stopped working. Whatever I type in the querry box, there are no results. familiar measures such as reindexing the entire hard drive could not solve the problem. Then I thought, this might be due to the parallels workstation upgrade, and so I placed the directory containing the parallels Hard Drive into the privacy list of Spotlight, and then reindexed and rebooted. The spotlight came back to life.

    I would like to report this problem and also interested to know if other users have found the same issue.

    Thanks
     
  2. RussGJohnson

    RussGJohnson

    Messages:
    11
    I have the same issue after a kernal panic as well.
     
  3. Odedh

    Odedh

    Messages:
    5
    same here

    same for me but with Beta 4, noticed it after a Kernel Panic

    did an Archive and Install because of it, I'm on Boot Camp until more bugs gets kicked off PW
     
  4. nigelhall

    nigelhall

    Messages:
    9
    I had the same problem with Spotlight. Couldn't fix it through the usual method of using MDUTIL to force Spotlight to rebuild the index.

    I was able to get Spotlight back again by downloading Spotless, from FixaMac http://www.fixamacsoftware.com/software/spot/index.php - it's shareware - and deleting the Spotlight database. After a reboot and a forced Spotlight rebuild, through Spotless, everything works again.

    All the best,

    Nigel
     
  5. Odedh

    Odedh

    Messages:
    5
    can you go over the process step by step,
    and anyone else tried this?
     
  6. cyberchucktx

    cyberchucktx

    Messages:
    16
    Disabling Spotlight for Parallels ....

    All:

    I haven't encountered a problem with Spotlight (yet) with beta5.

    But that raises a good point: I would HIGHLY recommend disabling SPOTLIGHT on the
    directories associated with Parallels.

    This can be done from the System Preferences -> Spotlight -> Privacy Tab and selecting
    the parent directory for Parallels (in my case, Home->Library->Parallels).

    It doesn't make ANY sense to let Spotlight try to index the Virtual Machines, eh?

    Charlie
     
  7. nigelhall

    nigelhall

    Messages:
    9
    I'm no expert on Spotlight but I think it will skip over the virtual machines, they're just files anyway. Unless Spotlight knows what is in the files it's unlikely to try and index them.

    Regarding the Spotless process:

    1- download and install Spotless from the url I listed above
    2- start the Spotless app (if you haven't paid for a license you have to wait for 15 seconds before it lets you proceed)
    3- enter your password at the prompt
    4- Spotless will then locate the Spotlight indexes on all attached volumes
    5- Select the Mac hard drive under volume name and then hit either Delete Index Files or Delete Entire Index Directory (I don't remember which I chose, probably the latter)
    6- After Spotless has deleted the Spotlight indexes quit the app and restart OS X
    7- Go back into Spotlight and the Master Indexing Status window should show that Spotlight is reindexing everything,
    8- once Spotlight has finished indexing everything should be working OK again

    Hope this helps,

    Nigel
     
  8. wesley

    wesley

    Messages:
    396
    Here's how I got Spotlight to work again just with Terminal.

    I first disabled indexing of the hard disks by dragging their icons from the desktop into Spotlight Preferences' Privacy section. This stops Spotlight from indexing them.

    Then, open Terminal, go to the root of each disk (for the boot volume, it's / and for other volumes it's /Volumes/name). For example, if my volume name is Quickie, type cd /Volumes/Quickie.

    Type sudo rm -rf .Spotlight-V100 and this will delete the Spotlight indexing folder for that drive.

    After deleting the indexing folders for all your drives, promptly reboot your system. After it finishes rebooting, click on the Spotlight icon on the menu bar. It'll start indexing again and it should work properly again once the indexing is finished.
     
  9. tangential

    tangential Bit Poster

    Messages:
    50
    Try a simple fix

    I tried most of those things listed above, but I discovered that there was nothing wrong with my indexing or searching. You can verify this by using 'mdfind' in a terminal window.

    The very simple solution that worked for me was to open a terminal window and:

    rm -f ~/Library/Preferences/com.apple.systemuiserver.plist

    and then reboot (logging out and back in would probably have also sufficed for a reboot.)
     
  10. wesley

    wesley

    Messages:
    396
    Hmm, that would explain why simply disabling indexing and then re-enabling from Spotlight Preferences would initiate re-indexing of the drives, but still not work.

    Then the question would be... why would we need to delete that preference file to get Spotlight working again? What's PW exactly doing to it that prevents it from working from the GUI, but have no effect under CUI?
     
  11. tangential

    tangential Bit Poster

    Messages:
    50
    I don't know. I am not sure exactly when it happened to me. Could have been after a crash.

    It took me a while to find this solution. I went down the reindexing trail, etc... Then it occurred to me that since mdfind was working it had to be gui issue. I actually found this fix in the apple forums.

    Based on what I read there, this is a general purpose fix when UI things get screwed up.
     
  12. darkyo

    darkyo

    Messages:
    1
    Got the same problem on a brand new MacBook Pro

    Situation, after a kernel panic, no more spotligtht.

    Here is a simple solution I found

    sudo su
    mdutil -E /

    Then in the Preference panel, exclude all Parallels folder, then invoke spotlight.
     

Share This Page