Problems with internet (even with editing the UseKextless key)

Discussion in 'Installation and Configuration' started by JulienH, Jun 2, 2021.

  1. JulienH

    JulienH Bit Poster

    Messages:
    6
    Hi
    I have a problem not getting any internet connection in my windows 10 ARM while using Parallels Desktop 16.5 on my macbook pro M1.

    I tried this command line on the terminal :
    "sudo nano /Library/Preferences/Parallels/network.desktop.xml"
    and searched for <UseKextless>-1</UseKextless>
    I had the "-1" value and changed it to "0" or "1"
    But still no internet connexion.

    I have no netork on the VM while trying the "0" value, and an IP unvalid configuration in the windows ethernet settings while trying the "1" value.

    I registered to this version lately and I need it to work on a daily basis...
    Thanks by advance for your help...
     
  2. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,670
    Hi, could you collect the tech report once the issue reoccurs and reply us back here with the report's ID number please?
     
  3. JulienH

    JulienH Bit Poster

    Messages:
    6
    Hi, I made the tech report with the idea 370753874.
    Every time I run the VM, that blocks all internet connexions.
     
  4. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,670
    Thank you for the provided information.
    Did you check the same issue with antivirus and without it?
     
  5. JulienH

    JulienH Bit Poster

    Messages:
    6
    Yes, I do not have any antivirus installed yet.
    I realized that when I have the VM running, all my internet access (MacOS and Parallels desktop) return a timeout.
     
  6. JulienH

    JulienH Bit Poster

    Messages:
    6
    I still don't have found any solution for having network both on my vm and macos. Did you find something on the tech report ?
     
  7. JulienH

    JulienH Bit Poster

    Messages:
    6
    Someone who has the same problem ? I did reinstall the VHDX insider preview client from microsoft website, but still I have the same problem, no internet connection.
    I think I will ask for refund, parallels desktop doesn't seem to be compatible with windows 10 insider and macOS Big Sur on a macbookpro M1...
     
  8. JulienH

    JulienH Bit Poster

    Messages:
    6
    Ok I found by myself.
    For those who are interested :
    - install BigSur 11.4, this is not working properly under this version
    - in the network preferences in your VM settings, select the adapter by default (bridge connection)
    This will work.
     
  9. JohnB87

    JohnB87 Bit Poster

    Messages:
    2
    Have same problem... now on latest parallels 16.5.1 and as soon as I start parallels, my windows and Mac network connection blocked. If I change to Shared or Bridged (have tried just about every choice) I am still blocked.... making this useless.... they said this was fixed in 16.5.1... it is not.
     
  10. PhilippP3

    PhilippP3 Bit Poster

    Messages:
    2
    same here
     
  11. Elric

    Elric Parallels Developers

    Messages:
    1,713
    Hi
    please go to the menu of Parallels Desktop -> Send Technical Data and send a report. Post here its number.
     
  12. PhilippP3

    PhilippP3 Bit Poster

    Messages:
    2
    Hi Elric,

    i find myself a solution yesterday late night.
    I set the <UseKextless>0</UseKextless> to <UseKextless>1</UseKextless>
    Ty trying to help
     

Share This Page