Problems with transporter after copying to new MacBook Pro

Discussion in 'General Questions' started by lethal, Aug 11, 2007.

  1. lethal

    lethal

    Messages:
    4
    I have problems with .hdd files when I copy them to other drives - or systems.

    I am trying to move the virtual machine to a new MacBook Pro, when I copied the folders over - they changed from 'kind' Parallels virtual hdd to being folders.

    Now Parallels Transporter won't see the files - except they work - well mostly. I need to re-configure them to see the new hardware and Microsoft keeps telling me (every minute or so) that I need to re-activate the software.

    Any thoughts?
     
  2. lethal

    lethal

    Messages:
    4
    Well, I kinda solved this.

    I ended up re-copying the files from my old MacBook by placing it in 'target' mode and using a firewire connection. This way the files retained their normal kind setting.

    However, I think this is still a problem - as I saw similar behaviour early this year when I had to restore the VM from a backup (the backup lost the kind as well.

    Marc
     
  3. rwhiffen

    rwhiffen

    Messages:
    11
    I've got the same problem, I used tar zcvf to tar up a VM to move it and it lost the attributes. I'm skulking around trying to find an answer myself. If I dig up anything I'll let you know.

    As for the windows activation, I suspect Parallels is deliberately letting the OS know the location has changed and therefor invalidating the registration per some kind of agreement with MS. It's the same thing that would happen if you swap out the motherboard of a PC, the install detects the change and forces you to re-register.

    Rich
     
  4. rwhiffen

    rwhiffen

    Messages:
    11
    Not sure if there is an easier way to do this or not but here's what I did:

    From the command line:
    /Developer/Tools/GetFileInfo otherdos.hdd
    directory: "/Users/rwhiffen/Documents/Parallels/FreeDOS/otherdos.hdd"
    attributes: avBstclinmedz
    created: 08/08/2007 13:10:19
    modified: 08/08/2007 13:41:09


    So the attributes for a 'correct' .hdd file are: avBstclinmedz

    /Developer/Tools/GetFileInfo ../solaris10/solaris10.hdd
    directory: "/Users/rwhiffen/Documents/Parallels/solaris10/solaris10.hdd"
    attributes: avbstclinmedz
    created: 06/13/2007 23:33:49
    modified: 08/13/2007 09:43:57


    So the attributes for a 'wrong' .hdd file are: avbstclinmedz

    It's the b/B attribute that's wrong (bundle bit, if you will).

    /Developer/Tools/SetFile -a B solaris10.hdd


    Sets the 'little' b to a 'big' B.

    Now it as the right 'behavior' in the finder, but the icon's still wrong, so I copied the icon from a 'correct' .hdd file and it's all good now. ( there's some instructions here: http://interfacelift.com/icons-mac/articles/using.php)

    I'm sure there's a simpler way to do this, but this is the first hit I came up with in google and it worked.

    Rich
     

Share This Page