Process for Converting from Legacy to UEFI (in prep for Win 11)

Discussion in 'Windows Guest OS Discussion' started by Mark Fine, Sep 25, 2021.

  1. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    362
    So, apparently this is possible using the following procedure:

    1. Back up your VM file in case you screw up [!!!!]

    2. Boot into your Win10 VM as usual.

    3. Check your Win10 virtual hard disk using the administrative tools to see:
    a. If there are no more than 3 partitions. If there are, see if you can whittle it down.
    b. Check the properties to see if it's Master Boot Record (MBR) or GUID. If it's MBR you're legacy. If it's GUID, you're already UEFI and don't have to continue.

    4. Do an advanced reboot into a command prompt:
    a. While holding down Shift key: Start -> Power -> Restart
    b. Select Troubleshoot, then Advanced options
    c. Select Command Prompt

    5. Log in with your account and Microsoft password (not your pin)

    6. Using the command prompt:
    a. Type: "mbr2gpt /validate" without quotes and hit return. This will check your hard disk.
    b. If there's a problem, type: "mbr2gpt /validate /allowFullOS" without quotes and hit return.
    c. If all is well, type "mbr2gpt /convert" without quotes and hit return. It will convert the MBR disk partition scheme to GUID.
    d. If might give your some grief about WinRE or some other thing, but generally, if it says 'conversion was a success' you can just type "exit" and hit return to kill the command prompt and return to the advanced menu.

    7. Choose "Turn off PC" to kill it. You don't want to restart Windows yet.

    8. Find your VM file in the Finder, right click on it, and choose: "Show Package Contents".

    9. Find the config.pvs and carefully open it in TextEdit:
    a. Search for the section <Bios dyn_lists="">
    b. Change <EfiEnabled> from "0" to "1"
    c. Change <EfiSecureBoot> from "0" to "1"
    d. Save the file back.

    10. You should now be able to open the VM Confguration, go to the Hardware tab, click the "+" and add the TPM Chip. If not, restart Parallels first.

    11. Run Win10 as you normally would. It might have an issue at first (mine did), but subsequent restarts seem to be ok.

    12. You then should be able to run the PC Health Check, obtained from https://aka.ms/GetPCHealthCheckApp. Mine came back with a processor error, since it's an older Quad-core i7 (early 2013 MBP), but it's technically sufficient per Win11 required specs. All the other things checked out:
    ❌ The processor isn't currently supported for Windows 11 [Intel Core i7-3740QM CPU @ 2.7GHz]
    ✅ This PC supports Secure Boot
    ✅ TPM 2.0 enabled on this PC [TPM 2.0]
    ✅ There is at least 4 GB of system memory (RAM) [8 GB]
    ✅ The system disk is 64 GB or larger [275 GB]
    ✅ The processor has 2 or more cores [4]
    ✅ The processor clock speed is 1 GHz or faster [2.7 GHz]
    Not real worried about the first thing because this processor isn't listed as being supported for the current version of Win10 (21H1) on Microsoft's site, either.
     
  2. BrianE13

    BrianE13

    Messages:
    1
    Works. I already had Windows 11 installed but since the MS restriction of 9/16/21 it would not update any further without the UEFI and TPM 2.0. Followed the procedure and changed my Windows 11 VM to UEFI with TPM 2.0.

    Thank you.
     
    Mark Fine likes this.
  3. AlanC12

    AlanC12 Bit Poster

    Messages:
    9
    Thank you for sharing this info. I too had an issue on the first boot but after that everything looks good.
     
    Mark Fine likes this.
  4. terryharpold

    terryharpold Bit Poster

    Messages:
    9
    Thanks, Mark. I was completely flummoxed by this and your instructions resolved things very neatly. I, too, had a mysterious forced reboot of Windows after a first start but everything seems fine now.
     
    Mark Fine likes this.
  5. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    362
    I should add that I'm now getting notices in Windows Update saying "This PC doesn't currently meet all the system requirements for Windows 11" Screen Shot 2021-10-05 at 8.58.15 AM.jpg
     
  6. XiangL2

    XiangL2 Bit Poster

    Messages:
    1
    There is only a "Start-up Settings" under "Advanced options", I cannot find the "Command Prompt" setting.
     
  7. GiuseppeS2

    GiuseppeS2 Bit Poster

    Messages:
    3
     
  8. McallenT@Parallels

    McallenT@Parallels Staff Member

    Messages:
    107
    Hello, Please search in the search bar for CMD or command prompt, and you will find it. Thanks, Parallels team.
     
  9. TinoB

    TinoB Bit Poster

    Messages:
    10
    If you don't see Command Prompt in Start-up Settings under Advanced options she your windows recovery partition is deleted / missing and you have to recreate it. For that you have to use / download microsoft windows media creation tool (www.microsoft.com/en-us/software-download/windows10) and make an update with this tool (settings and files are kept). If your windows recovery partition was missing after this update windows recovery partition will be presented / working and missing "Command Prompt) is showing.
     
    XiangL2 likes this.
  10. PaulE8

    PaulE8 Bit Poster

    Messages:
    1
    Perfect, thanks so much for the instructions Mark, worked perfectly first time for me on my MacBook Pro. It's a shame the parallels support team aren't generally aware of this post as they weren't able to offer this as an option .. just a complete reinstall.
     
  11. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    362
    Thanks.
    They must be aware now since I think they sticky'd it.
     
  12. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    362
    Thanks to @BradB7, who passes along a way to trick the registry into thinking your system passes all the tests (note that hacking the registry is not for the squeamish. Always backup your VM when doing things like this):
    • Open the Registry Editor and navigate to HKEY_LOCAL_MACHINE\SYSTEM\Setup\MoSetup
    • Search for AllowUpgradesWithUnsupportedTPMOrCPU
    • Change its value to 1.
    Once you've done that, restart your PC (or VM in this case) and install Windows 11 using your preferred method.
     
  13. SamuelH2

    SamuelH2 Bit Poster

    Messages:
    18
    Dang, wish I read this before I went through a rigamarole to get Windows 11 installed while maintaining my activation. I tried migrating from VMware, it took several tries to get it to activate. But it wouldn't update because of the Legacy boot. So I clean installed Win11. The neat thing: I activated using a Windows 7 Pro upgrade I'd purchased ages ago!
     
  14. Eduardo

    Eduardo Bit Poster

    Messages:
    7
    This is an excellent walk-through explaining how the migration should be performed. If I may, however, and according to my limited experience, I think it should be mentioned that running mbr2gpt /convert [/allowfullos] and the rest of the procedure will only yield valid results on 64-bit versions of Windows 10. I used to have a 32-bit version of Windows 10 Professional and I always ended up with a non-booting UEFI virtual machine. As soon as I upgraded my 32-bit Windows 10 to (64-bit) Windows 11, the problem was finally solved at the first attempt.

    Another issue is how to carry out the upgrade operation. First, I needed to Windows 10 installer for Windows 11 Professional and put that on a USB thumb drive. There's at least one YouTube video explaining how to achieve all that. Then, you need to boot your virtual machine using the thumb drive. The Windows 10 installer will install Windows 11 on top of the 32-version of Windows 10, without losing your files, but you'll need to reinstall ALL the non-system applications that were in Windows 10. Once that is accomplished, you can run mbr2gpt /convert /allowfullos from an elevated Command prompt (no need to boot from Windows recovery). Then turn off or stop your new Windows 11 vm, edit config.pvs as indicated in point 9 above. Finally, add a virtual TPM chip to the virtual machine and start it. It should boot perfectly.
     
    Mark Fine likes this.
  15. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    362
    So, after doing everything in post#1, then doing the Registry hack in post#12, I downloaded the .iso file from Download Windows 11.
    Right clicked on Win11_English_x64.iso in File Explorer and selected Mount, then ran setup.exe.

    Other than giving you a screen that alerts you to the evils that you may naturally run into with any Microsoft product and make you accept the consequences, the install went very well. It also provided an option to keep your apps and files, which I did. Only thing needed post-install was to run Windows Update, and ensure all apps were properly updated in the Microsoft Store. Other apps (like Steam) updated on startup. Office needed no update at all. I'll check the rest of the apps in due time.

    All-in-all this went much more smoothly than I expected and now I'm questioning if all the drama around this install is even warranted...
     
  16. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    362
    Forgot to add (but it was pretty obvious) to choose the Upgrade option.

    Also, just checked some oddball radio-related apps and other things that use USB and digital audio manipulation, and they all seem to work just fine... Perhaps even a bit smoother than they did in Win10.
     
  17. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    362
    One more thing: If you've lost your Win10 product code, this VB script will wrench it from your registry and display it for you (remove the .txt extension first).
    Taken from this site.
     

    Attached Files:

  18. DanielV12

    DanielV12 Bit Poster

    Messages:
    3
    Seems to me Parallels needs to come up with an easier solution than doing all that mess to be able to upgrade Windows 10 to Windows 11 if you're on a legacy bios.
     
  19. JoelH1

    JoelH1 Bit Poster

    Messages:
    24
    DIdn't work for me. Should I do it as a folder and set the Default value to 1?
     
  20. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    362
    No. Should be an item under Computer\HKEY_LOCAL_MACHINE\SYSTEM\Setup\MoSetup, just like this: Screen Shot 2021-10-24 at 3.37.11 PM.jpg
     

Share This Page