Pv5 - prl_disp_service consuming 99% cpu

Discussion in 'Installation and Configuration' started by Parallels User, Dec 7, 2009.

  1. sjsherratt

    sjsherratt

    Messages:
    12
    Really getting tired of Parallels and this 99% prl_disp_service issue and *SILENCE* on this forum or any sign that anyone is doing anything about it. And trying to even get support via the traditional means is met with demands for funds.

    30-days free support period has expired and there are no registered support package or available incidents left. Please buy Support package to receive Support

    I have been a strong proponent of Parallels in my company's forums, but in fairness will be sharing this experience.

    PLEASE ADDRESS THIS ISSUE!
     
  2. sjsherratt

    sjsherratt

    Messages:
    12
    Really getting tired of Parallels and this 99% prl_disp_service issue and *SILENCE* on this forum or any sign that anyone is doing anything about it. And trying to even get support via the traditional means is met with demands for funds.

    30-days free support period has expired and there are no registered support package or available incidents left. Please buy Support package to receive Support

    I have been a strong proponent of Parallels in my company's forums, but in fairness will be sharing this experience.

    PLEASE ADDRESS THIS ISSUE!
     
  3. Ryan North

    Ryan North Bit Poster

    Messages:
    1
    I just had the same problem with prl_disp_service using 100% of one of my cores. I ran the terminal commands above and this was the response.

    Operation progress 100%
    The problem report was successfully sent with id: 9950890
     
  4. sjsherratt

    sjsherratt

    Messages:
    12
    I received a response from Parallels Support. I followed these instructions to the letter. It took about 40 minutes to complete. So far, so good ...

    Hello Scott,

    Thank you for contacting Parallels Technical Support.

    As I understand the issue you are experiencing is regarding the prl_disp_service is consuming 99% CPU in Mac.

    To fix the issue we have to uninstall Paralles Desktop completely and reinstall it back.

    Please follow the steps given below:

    1. Shut down Windows

    2. Quit Parallels Desktop

    3. Back up your Windows virtual machine by copying the Windows 7.pvm file from Documents=> Parallels folder and pasting it on the Mac desktop screen(or in an external hard drive if you do not have enough available space in Mac HD)

    4. Follow the steps suggested in the following article:
    http://kb.parallels.com/en/9087

    Note: After you enter the first command, it will prompt you to type in the Mac password. So, just type the password and press 'Enter', you will not be able to see the cursor moving or anything getting typed.

    5. Once all commands are typed, Quit all applications running in Mac

    6. Restart Mac

    7. Launch Safari/Firefox

    8. Copy and paste the following web link in it:
    http://www.parallels.com/download/desktop/

    9. Click on 'Download Trial'
    Note: the installation file for the trial and the full version is exactly the same

    10. Enter your email address and click on 'Proceed to Download'
    Note: You will receive a trial activation key in this email address, please ignore it, we do not need it.

    11. Click on 'Download your trial software'

    12. It will start downloading now

    13. Once done, click on the downloaded file, you will get options- 'Install' and 'Uninstall' and 'Getting Started'

    14. Click on 'Install'

    15. Proceed with the Install wizard

    16. Once it is installed successfully, click on 'Close'

    17. After this, do not start your Parallels Desktop

    18. Go to Finder(first icon on your Dock) => Documents => Parallels => Windows 7.pvm => Double click on it, that will start your Windows.

    19. Once the Windows starts for the first time, installation of Parallel Tools will start automatically and your Windows will again restart after it's installation. Sometimes Parallels Tools gets installed along with the Windows installation, so you might not be able to see the Parallels Tools installation.

    20. Right click(Ctrl+Click) on the Windows 7 .pvm that you have just backed up on the desktop screen => Click on 'Move to Trash'

    Please let us know if the above mentioned steps does not resolve the issue.
     
  5. sjsherratt

    sjsherratt

    Messages:
    12
    After yesterday's complete deletion and re-install of Parallels, the 99+% CPU usage by prl_disp_service happened again. ...
     
  6. TomWats

    TomWats

    Messages:
    22
    My take on the problem...

    I first noticed this problem a day or two after installing OSX 10.6.8 and fixing the resulting Dock process problem. For me, the problem happens most often if I go two or three days without rebooting my Mac. It seems to happen fairly soon after bringing the computer out of sleep mode. It could be coincidence, but I've always had a browser open at the time, usually with a media plug-in like Java active.

    My theory is this: one of the problems that 10.6.8 was supposed to fix was NVIDIA driver issues that my 10.5-era MacBook Pro had with all previous versions of 10.6. The outward symptom of these driver issues was that the screen would occasionally blank out for less than a second. It was a slightly irritating but harmless symptom, but I know a lot of people complained about it. After attempting to fix the problem with 10.6.6 and 10.6.7, Apple finally succeeded with 10.6.8--my screen has not blinked once since then.

    However, I suspect those driver issues may be at work here, possibly triggered by the many media plugins that browsers require. An acquaintance of mine with a newer MacBook Pro that uses integrated Intel graphics has not noticed this problem with prl_disp_service--further supporting my theory. (Of course, he may just not be noticing the problem if it is happening.)

    If my theory is correct, removing and reinstalling Parallels is not going to fix the problem. Only revised compatibility between Parallels, Snow Leopard 10.6.8, and the NVIDIA drivers will fix it. Perhaps that is why Parallels has released version 7? But before I buy version 7, I want to be TOTALLY sure that it fixes this prl_disp_service issue on 2009-era MacBook Pros.
     
  7. sjsherratt

    sjsherratt

    Messages:
    12
    I experimented this week and had the Screensaver setting at "Never" ... no problems. I changed it to "15 minutes", and today noticed the problem again. So it is back to "Never". The only other change I have made to the system was on 8/12 I added Nova's Marine Aquarium 3 screen saver. Parallels support is recommending removing it. So it seems to have some connection with the Screen Saver in my case ...

    Likewise, I do not want to gamble on Parallels 7 until I know this has been fixed.
     
  8. TomWats

    TomWats

    Messages:
    22
    My screensaver has been set to "never" since before I started having the problem.
     
  9. Nick78

    Nick78

    Messages:
    4
    I also have this problem on a 2009 MBP with OS X 10.6.8 and Parallels 6, build 12094.
    Attempts to send a problem report result in the VM hanging. Attempts to log an issue results in a request for cash just so I can spend my time reporting a clear problem with the Parallels software.

    I have a screen saver enabled, but this prl_disp_service issue is a new feature.

    Im not upgrading until this is fixed, especially with the no-support-without-cash policy.
     
  10. sandro

    sandro Parallels Developers

    Messages:
    520
    if you still face with this problem could you please do follow:

    1. open Terminal application (/Application/Utilities/Terminal)
    2. at Terminal perform follow command:

    sudo killall -ABRT prl_disp_service

    3. reboot your host
    4. send us problem report (http://kb.parallels.com/en/9058) and post here it id

     
  11. cepheid

    cepheid Bit Poster

    Messages:
    18
    This problem still occurs. OS X 10.6.8, Parallels build 6.0.11994 (from the poster before me, it appears that the latest update doesn't resolve this issue either, so upgrading won't help), on a 2010 MacBook Pro.

    Problem reported, ID 10102241.
     
  12. sandro

    sandro Parallels Developers

    Messages:
    520
    Hi.

    Could you please follow above instructions (wait for reproduction, kill via command line with -ABRT key and send problem report after host reboot) - unfortunately at your problem report there is no necessary info for investigation.

     
  13. Roman Fattakhov

    Roman Fattakhov Parallels Team

    Messages:
    62
    Do you guys have Marine Aquarium installed on your Mac?
     
  14. cepheid

    cepheid Bit Poster

    Messages:
    18
    Is rebooting absolutely necessary? I have lots of other things that I use besides Parallels and I would really prefer not to reboot just to send a bug report.
     
  15. sandro

    sandro Parallels Developers

    Messages:
    520
    ok, follow way is possible:

    1. wait until pro_disp_service disappears from Activity Monitor after kill -ABRT sent
    2. send problem report with command perform from Terminal:

    prlsrvctl problem-report --send --stand-alone

    3. restore Parallels environment (if necessary):

    sudo launchctl stop com.parallels.desktop.launchdaemon

    wait a minute and perform:

    sudo launchctl start com.parallels.desktop.launchdaemon
     
  16. SteveS7

    SteveS7

    Messages:
    1
    Another sufferer

    I too have this problem.

    For the record, I'm on a 15" 2011 i7 MacBook Pro, 8GB RAM, 1GB VRAM, running Mac OS X 10.6.8. Since that's an ATI/AMD graphics chip that seems to nix any ideas that it's down to dodgy NVidia drivers.

    I've run the CLI-based problem reporter, which reported back:
    The problem report was successfully sent with id: 10175840

    My Parallels is:
    Build 6.0.12094
    (Revision 676494; July 13, 2011)

    This is very frustrating. I don't use Parallels very often, but I do occasionally need it. Frankly, since reports of this problem have been around for years, I hold out little hope that it will ever be fixed.
     
  17. cepheid

    cepheid Bit Poster

    Messages:
    18
    I will try this the next time I have this issue. Note, however, that stopping and starting the launchdaemon is NOT sufficient to restart the prl_disp_service... even after restarting the launchdaemon, Parallels will complain that prl_disp_service is not active. I must manually re-launch prl_disp_service to resolve this problem after killing prl_disp_service when it misbehaves.
     
  18. TomWats

    TomWats

    Messages:
    22
    I could be wrong, SteveS7, but I don't think the revised Nvidia drivers have to be active to have an effect. They would have been sent with 10.6.8 regardless of your hardware, but not activated unless your hardware matches. If I'm wrong on this, please forgive me. After all, you would think even more people would be complaining if it affected every hardware platform.
     
  19. tarkay01

    tarkay01

    Messages:
    2
    For what it's worth, I have a 2011 15 inch MBP with Core I7 and 4GB ram and SL 10.6.8. Prl_disp_service decides to start sporadically one or twice per week or so and takes 100 percent CPU. I have tried everything mentioned so far except the screen saver. Was set to 2hrs - now at never. I don't use Parallels that often so if it happens again, I will try removing it from /Library/StartupItems and only put it back in only if I need to use Parallels. Will require a reboot but that's OK. I think that should keep the Parallels daemons from starting at boot.
     
  20. adiggle

    adiggle Bit Poster

    Messages:
    2
    I'd like to add my name to the list of people with this problem. I've followed the most recent set of instructions in terminal. Presumably I'll have to reboot to cause Parallels to restart, and like everyone else I await a solution.
     

Share This Page