Pv5 - prl_disp_service consuming 99% cpu

Discussion in 'Installation and Configuration' started by Parallels User, Dec 7, 2009.

  1. cepheid

    cepheid Bit Poster

    Messages:
    18
    Hanna, you must include --stand-alone in the call to prlsrvctl, or it will simply hang and never complete.
     
  2. Jose222

    Jose222 Bit Poster

    Messages:
    17
    No wonder the one I was trying to report yesterday wasn't getting past 55% at the best of times. In any case, worth reading the temporary workaround offered in this other thread (http://forum.parallels.com/showthread.php?t=113752), namely, put the computer to sleep and wake up again, and the CPU usage goes back down to normal levels (4-6%). It worked for me today after having tried everything said in any forum. I hope it helps.
     
  3. LalitB

    LalitB

    Messages:
    1
    Have seen the same issue several times and submitted problem reports.

    Hesitant to upgrade to PD7 if there's no guaranteed fix.

    What's the deal Parallels staff? This is one of the most viewed threads in your PD for Mac forums?
     
  4. TomWats

    TomWats

    Messages:
    22
    How many Lion users have this problem?

    I scanned this thread again today for references to Lion 10.7.x and found two. Are there any other Lion users out there who either have this problem for have had it in the past? I worry that Parallels is simply patiently waiting for us Snow Leopard users to upgrade. Some of us have very good reasons for not upgrading. Others of us may simply believe that the problem will continue even if we do upgrade. Please do something about this, Parallels!
     
  5. Om_Prakash

    Om_Prakash

    Messages:
    9
    Resolution..

    -->Un-install Parallels using http://kb.parallels.com/en/112189

    -->Perform repair disk permission

    -->Restart the Mac

    -->Re-install Parallels

    This will fix the issue.
     
  6. TomWats

    TomWats

    Messages:
    22
    So, Parallels asked why I haven't upgraded...

    As most of you have probably noticed (if you're still using Parallels 6), when you log in it asks you to take a survey for a free iPad. I didn't care about the iPad nearly as much as complaining once more about this problem. And I chose just the right day to do it, too.

    Yesterday I shut down the Mac for the night (which I often do to prevent the prl_disp_service from going crazy, and it usually works). When I turned it back on this morning, I ran checks for updates. Mac OSX, check. Office:mac, none. Parallels, none. Windows, check. That is also when I took the "why I don't upgrade" survey.

    Before putting the computer back to sleep, I turned off Windows. When I woke up the computer later, Temperature Monitor Lite soon reported 92 degrees Celsius and activity monitor showed 95% from prl_disp_service (Wow! Something less than 99%. I'm impressed.... NOT!) This happened after putting it to sleep once. And that was after two reboots!

    So just to make sure I am heard, I'm posting it here again. I haven't upgraded because I'm not convinced the problem is fixed. If I knew for sure that the problem has been solved with Parallels 7, I might upgrade. But I'm not going to risk my money on something that may not work, especially when VirtualBox is now stable enough for me to switch to if I want.

    And yes, I know the problem is less common with Lion (though some still have it!) and completely absent from 10.6.7, but I cannot downgrade and have no desire to upgrade. I spent a lot of time researching Lion last week and decided I still don't want it (though I won't get into why here).

    Also, I remembered after running the terminal commands to reset prl_disp_service to send an error snapshot. I've done so, but I may have sent it too late. But seriously: by now Parallels has probably received dozens of reports from those of us with the problem. My report has an ID of 15620918 and I can't figure out how to find or open the /tmp/samples.txt file.

    Anyway, sorry for the big old long post, but I want to make it completely clear why I'm not upgrading. But if Parallels staff can provide proof that they have fixed the problem by June 25th (when the discount they offered me expires), I'll reconsider.
     
  7. TomWats

    TomWats

    Messages:
    22
    Question for Om_Prakash

    I'm almost to the point where I'm willing to try this. But do I have to completely reinstall the Windows VM in the process? Also, how do I perform a "disk repair permission?" And does it fix the problem permanently or just make it rarer?

    By the way, my Mac is a mid-2009 MBP 13" with the Snow Leopard upgrade (shipped with Leopard) and fully upgraded RAM from Crucial (8GB). I lack a Mac-formatted external HD for Time Machine, so I'm very nervous about this sort of thing.
     
  8. YanaYana

    YanaYana

    Messages:
    1,666
    comment about troubleshoot guidance:
    In order to reinstall Parallels Desktop you don't have to reinstall Windows - just download the latest PD6 build from KB http://kb.parallels.com/en/5802 and Click - Uninstall. Than open it once again and click Install.
    In order to repar permissions - please open Disk Utility on Mac, click on Mac HD in the left panel of application and click on Repair Disk Permissions option.

    Comment about PD upgrade - you still can download the free trial PD7 version and run it for up to 14 days in order to check if it fixes the issue
     
    Last edited: Jun 24, 2012
  9. Nien-PoC

    Nien-PoC

    Messages:
    6
    prl_disp_service consuming 99% cpu

    My configuration is MacBook Pro (early 2011), Mac OS X 10.6.8, Parallels 6. I've closely watched this thread because I encountered the problem several times. About three weeks ago, I decided to follow this new "remedy"--- un-install, repair disk permission, restart mac, re-install.

    I thought this might cure the problem until today. prl_disp_service comes up again at 99% in the activity monitor. So, I can here announce that this tip does not work!

    By the way, I follow the typical work-around posted a while ago:
    ------- >>>>>>>
    1. open Terminal app (/Applications/Utilities/Terminal)

    2. perform follow command:
    sudo killall -ABRT prl_disp_service

    3. wait for a minute and perform next command (record the ID number):
    prlsrvctl problem-report --send --stand-alone

    4. command to dump the file
    sudo spindump -notarget 1 10 -file /tmp/samples.txt

    5. restore Parallels environment (if necessary):
    sudo launchctl stop com.parallels.desktop.launchdaemon

    6. wait a minute and perform:
    sudo launchctl start com.parallels.desktop.launchdaemon
    <<<<<<<--------
    After step #6, I am supposed to be able to launch parallel desktop, right? My result is opposite. Parallel Desktop will complain that the prl_disp_service is not there, cannot connect to it and fail to launch. I can only re-start the Mac to be able to use Parallel Desktop again.

    So, this time ID is 16004832.
    Where should I send the report to?
     
  10. daharrin

    daharrin

    Messages:
    2
    prl_disp_service consuming CPU PD6

    Hanna,
    I am also encountering high CPU usage by prl_disp_service, when I haven't even opened Parallels after a reboot. I'm using PD6 6.0.12106.692267, on MacOS X 10.6.8.

    I followed the directions below, plus cepheid's additional help in a subsequent post. My issue ID is 16434350. Hanna, can you please instruct on how to send the samples.txt file? I'm not willing to post it publicly as an attachment here, but I don't see a way to attach it to a PM.

    Thanks --

     
  11. TomWats

    TomWats

    Messages:
    22
    Daharrin,

    Where did you find a 12106 build? The latest I was aware of is 12094, and I have checked for updates ALL the time in hopes they would release one that fixes this stupid runaway prl_disp_service problem. Did you get it through your product updater or download it manually?

    Also, I think Hanna was someone asking for help, not a Parallels employee. But in case she is and you got a reply from her off this forum, could you post it? I still don't know how to find, let alone send, the samples.txt file.

    Thanks,
    Thomas
     
  12. TomWats

    TomWats

    Messages:
    22
    Confused about the 12106 build

    After seeing Daharrin mention a 12106 build, I started looking around for it. In all the time I've had 12094, the updater has never seen an update, even when I run it manually.

    Even more oddly, the "latest build" link on the Parallels 6 landing page goes to a 12094 page: http://www.parallels.com/support/pdfm6/

    I had to go through a backdoor link in one of their blogs to even get to the 12106 build page: http://kb.parallels.com/en/112239

    The blog I used to get there seemed to indicate that build 12106 was intended solely for Lion. In fact, it sounded like 12106 might mess up 10.6.8 users even more. Like most of you, I'm using 10.6.8 so is that why my updater never saw the 12106 build? (blog link: http://forum.parallels.com/showthread.php?t=114525) And do I dare give it a try?
     
  13. TomWats

    TomWats

    Messages:
    22
    Resetting prl_disp_service

    It seems to me like the first sudo command listed here might permanently kill the prl_disp_service until you reboot... though I'm no expert in sudo commands. I always ran just the last two commands to reset the service, but of course that didn't create an error report for Parallels to see.

    This website added one more command just to make sure the prl_disp_service process is running correctly: http://applehelpwriter.wordpress.com/tag/prl_disp_service/

    Hoping this helps,
    Thomas
     
  14. carlosrodzbotet

    carlosrodzbotet Kilo Poster

    Messages:
    126
    I don't even remember this thread but I got an email about it. After reading a little bit could this be the reason my Mac Air fans at some times comes on for a long time even though I'm not really doing anything on it?

    I'm going to go back and read the entire thread to see if I can figure it out.
     
  15. daharrin

    daharrin

    Messages:
    2
    I have never installed a Parallels update by downloading manually, so it must have come through the regular product updates.

    Hanna is a Parallels rep (the user "juzci" who has posted in this thread). I PM'd her to ask where to send the samples.txt file, and she responded with her full email address. Try that.

    Dan


     
  16. carlosrodzbotet

    carlosrodzbotet Kilo Poster

    Messages:
    126
    Yep, I opened Task Manager in Windows 7 and also Activity monitor on Mac side. The Activity monitor on the Mac just reflects what the CPU usage on the windows side is doing. Windows goes to 100% so Mac goes to 100% and the fan starts. Windows slows down to 0% and Mac slows down to about 5% and the fan shuts down.
     
  17. TomWats

    TomWats

    Messages:
    22
    Same problem?

    Many of us Snow Leopard 10.6.8 users will experience the runaway prl_disp_service (a process on the Mac side) even when Parallels and Windows are off. I'd usually experience the problem shortly after waking the Mac from sleep. (I've since uninstalled Parallels 6 b/c I got tired of it.)

    The problem you have described sounds different. You're saying that a Windows process consumes 100% of the CPU in your case, is that right? Can you tell if it's a process related to the Parallels tools in Windows?
     
  18. carlosrodzbotet

    carlosrodzbotet Kilo Poster

    Messages:
    126
    I just saw that when I opened Outlook in Windows 7 the CPU went to 100% in Task Manager in Windows 7 and also on Activity Monitor on the Mac side. As soon as it opened completely and downloaded my emails, it went to 0% in Task Manager in Windows 7 and to about 5% on Activity monitor on the Mac.

    I'm sure now that Apple released Mountain Lion many companies will stop worrying about older OS like Snow Leopard the same way as soon as the next OS after Mountain Lion comes out they'll stop worrying about Lion.

    If I were getting so many issues with Snow Leopard I'd upgrade to at least Lion because my PD7 works fine in Lion and most likely will get a little more support from Parallels. This issue has been around since 2009 with no fix, do you think it's a priority now with Mountain Lion out?
     
  19. TomWats

    TomWats

    Messages:
    22
    Yeah, I suspect Parallels is no longer trying to fix the problem with 10.6.8 and just trying to make certain the same problem is absent in Lion and ML. However, I have reasons for not upgrading, and I'll give just a few of them below. I apologize in advance for the length of my list--it's intended mostly for any Parallels employees who may read this:

    1. My MacBook Pro was designed for Leopard. Can it run Mountain Lion? Theoretically, yes. But when I put Snow Leopard on it, it slowed down. And from what I've read on product forums, Lion and Mountain Lion will probably slow it down even more.

    2. Lion has some UI changes that I dislike. For example, the "Save As" feature is gone, and I use that a lot at work. Lion's version history feature simply won't cut it there (not enough direct user control over it).

    3. I've heard that Lion has some bugs. I know that Mountain Lion fixes those bugs (just as SL fixed Leopard bugs), but I'd rather avoid OS's with any bugs. I switched from Windows to get away from bugs.

    4. The newer OSX versions don't support things like Java (ML) and Rosetta (L and ML). For those who need these, Snow Leopard needs to remain an option.
     
  20. carlosrodzbotet

    carlosrodzbotet Kilo Poster

    Messages:
    126
    I wouldn't know about Java or Rosetta but regarding slowing the system down I'm sure there are ways around that to make it faster.

    About the SAVE AS, my current Mac had Lion so I never used it however I did find it a little annoying until I figured all you have to do it close the page with the "right corner X" and it'll ask you where do you want to save it and with what name, just like it would do with the SAVE AS command. Why they took it out I don't know.
     

Share This Page