Pv5 - prl_disp_service consuming 99% cpu

Discussion in 'Installation and Configuration' started by Parallels User, Dec 7, 2009.

  1. TomWats

    TomWats

    Messages:
    22
    Problem absent in Parallels 8

    There is light at the end of the tunnel, even for OSX 10.6.8 users!

    After installing the Parallels 6.0.12106 build and still having the problem, I found the error reporting instructions in this thread and tried them. You have to start with the sudo killall -ABRT prl_disp_service command or the error report will fail to complete. After that, you have to find the samples.txt file in a hidden folder using Finder's Go To Folder.

    Once I had done those things, I sent the samples.txt file off to Hanna (Juzci), who has been most helpful. She got me a great deal on Parallels 8, which has completely eliminated the problem. In PD8, prl_disp_service doesn't even run when Parallels is off, so there is no chance of it going haywire. And I've spent a bunch of time playing around with Windows 8 without the process going haywire on me. I'll install XP on it soon.

    Although I have only been using PD8 for a few days, I feel confident that the prl_disp_service problem is solved. Thank you, Parallels!
     
  2. jonathan_david

    jonathan_david Kilo Poster

    Messages:
    181
    hi tom.

    interesting news.

    is it possible to get some idea of what the specifics of this good deal are?

    maybe it is possible for me to get contacted directly by Parallels on a complimentary upgrade to V8?

    i have been debating my next move here after updating religiously almost immediately upon new releases and it would be super to get some help in keeping on the parallels train on my two computers. the laptop has not been so happy with this and i even went so far as to do TWO fresh OS installs on my machines to make sure i did not have old issues like this lagging around.

    - jon
     
  3. YanaYana

    YanaYana

    Messages:
    1,666
    I suggest everybody here who has this issue to download the PD8 trial and check if the issue is still there:

    http://trial.parallels.com
     
  4. carlosrodzbotet

    carlosrodzbotet Kilo Poster

    Messages:
    126
    I agree 100%. This way if it the problem is not there with PD8 then they'll know what it is and can fix it on PD7.
     
  5. carlosrodzbotet

    carlosrodzbotet Kilo Poster

    Messages:
    126
    If I install PD8 to try this fix, when the trial period ends if I don't want to keep it, how easy is it to revert back to PD7?
     
  6. TraneF

    TraneF Bit Poster

    Messages:
    25
    You should be able to just drag PD8 to the Trash from the Applications folder and then run the PD7 installer. Note that if you want to do a clean install of PD8 first, you'll need to run the PD7 uninstaller.
     
  7. carlosrodzbotet

    carlosrodzbotet Kilo Poster

    Messages:
    126
    I don't think I want to do a clean install because that would entail having to setup Windows 7 again right? I have it working the way I want it and don't want to mess with Windows. I just want to fix the PD7 problem.

    If I trash PD8 and then run PD7 will this keep my Windows 7 programs and everything the same or do I have to install everything again??
     
    Last edited: Sep 25, 2012
  8. TraneF

    TraneF Bit Poster

    Messages:
    25
    I'm not sure in that case. It might be possible to do an in-place upgrade from PD7 to PD8, but I would copy your VMs to a separate location in case you want to downgrade. There might be unwanted side effects on the VMs themselves trying to move from one that has been used in the newer version. If you were do downgrade from 8 to 7, replacing your VMs is the safest way to carry on where you left off.
     
  9. carlosrodzbotet

    carlosrodzbotet Kilo Poster

    Messages:
    126
    I think I'm going to just backup the hard drive with CCC like I do every week then upgrade. If I don't like it or it doesn't fix anything then I'll just CCC the backup onto the hard drive and everything is back to normal. This is what I've done when an update doesn't work.
     
  10. YanaYana

    YanaYana

    Messages:
    1,666
    All your WIndows installations will stay in place and won't be affected at all. They are separate files (like word documents - they are not being removed when you reinstall MS Word)
     
  11. carlosrodzbotet

    carlosrodzbotet Kilo Poster

    Messages:
    126
    Thank you.

    What I find interesting is that since I upgraded to Mountain Lion I can't find that "Pv5 - prl_disp_service" anymore when I open the Activity Monitor like I used to see it. Where can I find it again?


    My biggest process regarding Parallels is prl_vm_app. It usually roams from 18% to 19% of CPU but sometimes the fans go on and it goes all the way up to 170%. Is that normal?
     
  12. madscientist01

    madscientist01

    Messages:
    1
    Also having prl_disp_service issues in OSX

    Wanted to add my woes to the discussion. I have had this issue on and off since installing Parallels (v6). It routinely happens even if I've rebooted my computer and never started Parallels at all. Then suddenly, the fans are spinning like crazy and I find prl_disp_service at 99%-100% of CPU.

    I followed the instructions to abort the process via Terminal and produce a report:
    The problem report was successfully sent with id: 21569844

    I have a MacBook Pro running OSX 10.6.8 and Parallels Desktop 6.

    I think it is disappointing that Parallels is very aware of this issue and instead of fixing it, is simply asking for people to pay for Parallels 8. The software I originally paid for should work as it was expected to work.
     
  13. carlosrodzbotet

    carlosrodzbotet Kilo Poster

    Messages:
    126
    I asked a question back on Sep 30, 2012 and as you can see it hasn't been answered so good luck.
     
  14. JeromeJ

    JeromeJ

    Messages:
    3
    Hi Everybody,

    I have installed the Parallels 8 Trial Version (before buying it !!),
    And I have a similar problem :

    Parallels VM in the tasks manager runs at something like 101 / 102 %, and my windows XP takes 20 minutes to load, than is really sloooooooooow... (Impossible to work with my XP.)

    Before buying Parallels 8, I have to resolve this problem !!

    Thanks for your help...

    [​IMG]
     

    Attached Files:

  15. carlosrodzbotet

    carlosrodzbotet Kilo Poster

    Messages:
    126
    Hopefully someone at Parallels will answer in the next few months. I keep getting the emails to upgrade but until I get an answer I just keep deleting them.
     
  16. JeromeJ

    JeromeJ

    Messages:
    3
    I hope so...

    Of Course, I will never Buy Parallels if that's not working...

    Just for information, I have the last OSX Mountain Lion with All Upgrades...

    Parallels Staff, Please, HELP US !!
     
  17. ANSARM

    ANSARM

    Messages:
    1
    have a very nice article
     
  18. JeromeJ

    JeromeJ

    Messages:
    3
    No, That's not working, I have done a Trial Version Fresh install, Problem is still there, see my precedent post with a screen capture...

    Help !
     
  19. TomWats

    TomWats

    Messages:
    22
    Today is the first time I've checked this thread since I posted my last message back in September. Looks like some of you are having problems even under P8. I haven't so far, though I have noticed that prl_disp_service is not active when P8 is not on (it was active all the time in P6).

    I must apologize to Jonathan for not answering earlier. I hesitate to reveal the exact details of the deal Parallels gave me in a public forum. Suffice it to say that I emailed an agent, said I would have to switch to VirtualBox unless they resolved the problem for me, and they hooked me up with P8 (I was running P6 at the time) at a price I could afford. The agent exercised discretionary authority to grant me the deal, so I do not want to risk getting the agent in trouble... or make it impossible for others with this problem to get similar service.

    Since getting P8, I have been running Windows 8 Release Candidate until today, when it expired. I have had no problems with prl_disp_service consuming the entire processor, though the Win8 Metro apps would sometimes run the Parallels VM process up to 100%.

    Today, I put XP on and deleted Win8. We'll see if I continue to have no problems under Windows 8. I'll try to remember to report back on this thread whether I have problems or not.
     
  20. hemantg

    hemantg

    Messages:
    1
    The CopyPasteTool.dll crash is known bug and it has been already fixed. This fix will be available in the next update of PD. The problem with 99% CPU consumed by prl_disp_service isn't connected with the CopyPasteTool crash and this bug will be investigated by our development team.
    Sorry for inconvenience.
     

Share This Page