RAM Issues

Discussion in 'Installation and Configuration' started by Adi_Kerr, Dec 18, 2007.

  1. Adi_Kerr

    Adi_Kerr

    Messages:
    1
    Hi All,

    This morning I replaced my 2 x 256MB chips with 2 x 1GB chips, and my laptop recognises them and everything is running fine apart from Parallels.

    When I open it up and click 'Play' to start my VM it drops an error menu down saying;

    "Parallels Desktop failed to allocate the specified amount of memory.

    Please restart Parallels and try again.

    To avoid this problem in the future choose from the menu: Parallels Desktop > Preferences. On the Memory Tab select the "Enable Virtual Memory preallocation" option."


    I've tried this but still getting the same error.

    I'm running a 1.83 Ghz Core 2 Duo MacBook with (now) 2GB RAM.

    Hope somebody can help!

    Cheers,

    Adi
     
  2. JackCooley

    JackCooley

    Messages:
    3
    Also having RAM issues

    I am also having the same issue. I have used Parallels for some time now, but after fixing some Hard Drive issues on the mac side, I can not start my virtualization. I get the error:


    Parallels Desktop failed to allocate the specified amount of memory.
    Please restart Parallels Desktop and try again.
    To avoid this problem in the future choose from the menu: Parallels Desktop > Preferences. On the Memory tab select the "Enable virtual memory preallocation" option.

    right from the start. The ""Enable virtual memory preallocation" option is already checked. I have re-booted, restarted, etc. I have seen some traffic on older versions of Parallels with this error, but not with this build 5582. I am looking for any help. In the meantime, I guess it's back to the routine, repair disk permissions, etc. Thanks in advance for any help on the matter.

    I am running a MBPro w/ 4 GB of memory (don't think that's the problem,) and have the maximum set to 2 GB (2048 MB.) Occasionally, if I change the allocation to manual, it will say the maximum is 1968 MB, when I change it to that, then the maximum is 1848 MB, etc. It keeps going down.
     
  3. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    Hello Adi_Kerr and JackCooley,

    Parallels allocates a Virtual Machine’s RAM as one file. When your Mac’s RAM is too fragmented (when too many applications are open), there may not be enough space in one sector for this file.

    Did you try rebooting your Mac and launching Parallels when no other applications are opened?

    Please decrease the amount of virtual RAM for your VM if the problem still occurs.

    Best regards,
    Xenos
     
  4. JackCooley

    JackCooley

    Messages:
    3
    Yes, I've rebooted ...

    Xenos,
    Thanks for the suggestion. Yes, I have rebooted and I've minimized the number of apps running (can you really have no other apps running.) I have been able to launch Parallels with just 1 GB (out of 4GB) memory, which functions adequately. I just don't understand why I could run with 2 GB before and suddenly I'm only able to launch with 1 GB. I have also repaired the disk, fixed permissions, etc. Don't know what else to do. I guess I'll just run on 1 GB. Any further suggestions would be greatly appreciated.
    MacDaddy
     
  5. abatie

    abatie

    Messages:
    3
    Getting it as well

    My imac has been in the shop for a week and I've been running parallels on my macbook pro, using the vm on an external drive. I get the imac back, and parallels starts up the internal vm just fine. I suspend it and go to the external drive to fire up that one to decide which way to sync them, and it starts popping up this error. This is basically a fresh boot and there's 1.6G free memory. The vm is configured for 512M, but stopping it, changing the mem down to 256 or up to 768, preallocating, nothing matters. It's clearly a bogus error from some other problem, but I'll be very disappointed if it's corrupted just from suspending it on one machine and resuming it on another. Kinda defeats one of the key advantages of a vm.
     
  6. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    Hello all,

    JackCooley, I am sorry to say there is a known issue concerning memory allocation on Macintosh computers with large amount of RAM (4+ GB). It is considered to be a current technological design limitation that is to be changed in future Parallels Desktop versions.

    The possible workarounds are:

    - lower the total Parallels Desktop reserved memory limit (under Preferences - Memory).
    - lower the amount of memory allocated to the particular VM.
    - start Parallels Desktop right after the Mac restart (thus we put our main drivers in the first 4 GB address space of the system).

    Abatie, suspending the VM on one machine and resuming it on another does not cause the memory allocation problem. In your case the iMac memory has been defragmented by numerous tasks and Parallels could not find a one-piece memory space big enough to let it run. You should reboot the iMac and start Parallels before any other application to let it take the needed amount of memory just from the beginning.

    Best regards,
    Xenos
     
  7. abatie

    abatie

    Messages:
    3
    Except that when the instance on the external failed to start, I switched back to the internal instance, and it started and has been running just fine.

    Also, as it happens, I just upgraded my Mac Pro at home to 6G last night, and the Parallels instance there restarted afterwards with no problem. Perhaps because I started it just after booting, it got memory in the first 4G and is happy as a result...I'm hoping that problem gets fixed soon, as one of the reasons for upgrading the memory is so I can have more virtual machines running...
     
  8. demenas

    demenas

    Messages:
    13
    I have a C2D MacBook Pro with 3GB of RAM and I can't get any memory over 1024 MB to work.

    No matter what setting I do in preferences, Automatic or Manual, or pre-allocate, rebooting with nothing set to load. If its at 1024 MB it loads Windows Vista fine. If I move it to 1028 MB it gives me the failed to allocate memory error.
     
  9. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    Hello,

    Abatie, thank you for the feedback. We are working to eliminate these memory issues.

    Demenas, what amount of memory is allocated to Parallels in your Mac? Please check in Parallels Desktop -> Preferences -> Memory.

    Best regards,
    Xenos
     
  10. demenas

    demenas

    Messages:
    13
    1548 MB and "Adjust memory limit" is set to "Automatically".
    Enable Virtual Memory Preallocation is unchecked.

    It doesn't matter what I change these too, I have tried many combinations and reboots. It can't be an accident that "1024" is the absolute maximum I can set. It must be hard coded somewhere. Even "1028" fails.

    OS X 10.5.1
    MacBook Pro Core 2 Duo 2.33 Ghz
    3 GB RAM
    Parallels Desktop 3.0 Build 5584

    Thanks,

    Steve
     
  11. klinquist

    klinquist

    Messages:
    6
    Same here.
     
  12. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    Hello Demenas and Klinquist,

    Please check if your Mac can see the VM RAM. Could you send a screenshot:
    About This Mac - More Info - Hardware - Memory ?

    Best regards,
    Xenos
     
  13. klinquist

    klinquist

    Messages:
    6
    Here you go, Parallels running in the background with only 1024mb ram.

    [​IMG]
     
  14. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    Hello Klinquist,

    Thank you for the screenshot. I've sent the request to our developers. Will let you know as soon as they answer.

    Best regards,
    Xenos
     
  15. demenas

    demenas

    Messages:
    13
    NOTE: With the Leopard 10.5.2 update this afternoon, I was able to slide the memory allocation for my Vista Guest OS over to about 1450 and it started with NO ERRORS. (Previously I couldn't go 1 MB over 1024).

    SO...knock on wood...so far so good!

    Steve
     
  16. gialom

    gialom

    Messages:
    1
    Possible problem: Formatting under Leopard

    Dear All,

    I am also experiencing the same problem over an IMac 2,8 GHz 4 GB RAM. My Vista virtual machine is now limited to 1 GB RAM in order to work.

    The previous version I had was working on a Hard Disk formatted as MAC OS Extended, Journaled and Case Sensitive. In that case I had not problems at all: I could give 2 GB RAM without any consequence.

    Due to use of old Mac OS program, I switched back the disk formatting to Mac OS Extended Journaled. And the problem, after restoring the virtual machine appeared, with the 1 GB limitation workaround.

    Dear Xenos, I suggest to inform your developers to work on machines formatted Mac OS Extended, at most Journaled, but not Case Sensitive, as Leopard seems to foresee.

    I hope I helped you.

    Cheers,

    Giancarlo
     
  17. TucsonTom

    TucsonTom

    Messages:
    56
    Let me add my voice to this chorus. Here's a screen shot of my issue. Strange thing is that is was working ok yesterday and even this morning. The problem began after I rebooted my Mac I have 7GB of RAM.
     

    Attached Files:

  18. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    Hello all,

    Our recent investigation has shown that the memory allocation issue on Parallels Desktop 5584 and Mac OS X 10.5.2 is caused by the last major Apple security update. Right now the only way to overcome the issue is to downgrade Mac OS X 10.5.2 to 10.5. Please have a look at this article.

    Best regards,
    Xenos
     
  19. TucsonTom

    TucsonTom

    Messages:
    56
    Of course, downgrading would be a disaster in more ways than one.

    I was able to use Parallels after reconfiguring the memory allocation in the VM from 2048 to 512MB. Not using the Parallels menu, as recommended by the error message, but from the VM windows configuration. Don't know if it will last, but for the time being Parallels is working fine.
     
  20. Mark Simpson

    Mark Simpson

    Messages:
    8
    I have been using Parallels on my new MacBookPro with 4 GB of RAM very successfully for three months but after installing an automatic update from Apple this morning (unrelated?) got:

    Parallels Desktop failed to allocate the specified amount of memory.
    Please restart Parallels Desktop and try again.
    To avoid this problem in the future choose from the menu: Parallels Desktop > Preferences. On the Memory tab select the "Enable virtual memory preallocation" option.

    I checked the "enable virtual memory preallocationm" under parallels desktop preferences with no result. the memory allocation in the VM windows config is already set at 512.

    Any suggestions would be greatly appreciated.
     

Share This Page