RAS Universal Printing - Failed to add printer

Discussion in 'Parallels Remote Application Server' started by PatrickD8, May 18, 2021.

  1. PatrickD8

    PatrickD8 Bit Poster

    Messages:
    26
    Hi,

    since the upgrade to version 18.0.x, RAS Universal Printing no longer works on multiple servers. It seems the problem occurs after reboot. I'm not sure whether the problem is related to the latest Windows updates. Easy Microsoft printer redirection works without any problems.

    First I tried to reinstall the Printing Module according to KB:
    https://kb.parallels.com/123690

    That didn't work. Then I uninstalled the RDSH agent on the servers and reinstalled it via the RAS console. That didn't work either.

    So far only this has worked:
    1) Uninstall RDSH Agent
    2) Restart the server
    3) Reinstall the RDSH agent manually

    I noticed the following entries in the controller.log:
    [E 04/00000064 / T0DDC / P060C] <SomeDate> <SomeTime> - TS Agent <SomeServerName>: [E 04 / 0001000C] Failed to add printer '<printer> from <username>' (original name = '<printer> ') for user' <domain>\<username> 'in session 6

    The error code looks like the agent is corrupted. Is this assumption correct?

    Best regards
    Patrick
     

Share This Page