Re-enable Intel VT-x warning message

Discussion in 'General Questions' started by Parallels User, Jan 17, 2008.

  1. Hi, This is a FYI only, a problem that I had, and solved:

    Im running Parallels Desktop 3.0 Build 5582 on Mac, and my guest OS is CheckPoint SecurePlatform (a Linux 2.6 derivative). The guest OS would kernel panic with the Intel VT-x enabled, so I disabled it, and it ran fine no problems.

    The only thing is every time you start the Guest you get a warning message:

    Intel VT-x is disabled. Enabling VT-x will enhance your virtual machine performance. Do you wish to enable VT-x automatically? Yes No
    [] Do not show this message again

    I was clicking no, until I decided to click [] Do not show this message again.

    After clicking that, the VT-x was enabled, and would stay on enabled, I couldn't disable it, and my guest would not boot.

    The fix:

    Run the Property List Editor:
    /Developer/Applications/Utilities/Property List Editor

    Open the Parallels plist file:

    Change the setting from 1 to 0:

    Save the plist file, and restart Parallels.

    Is there a doc somewhere which documents all the settings in the parallels plist file?


Share This Page