Reclaim Disk Space in Parallels Desktop 9 failed.

Discussion in 'Windows Guest OS Discussion' started by JJohnston, Sep 4, 2013.

  1. JJohnston


    I had a Windows 8 virtual machine that I originally created in Parallels Desktop 8. Today, when I tried to reclaim disk space, it just spun for a while with no progress indication. I finally gave up, closed Parallels (not with Force-Quit, mind you, just normal Quit). When I came back, naturally, the hard drive was corrupted beyond repair. The parallels disk utility was unable to repair it as well (it just stuck at 0% forever).

    I'm pretty disappointed with Parallels 9. I just rolled back to 8. Luckily, I backed up this VM before upgrading to 9.

    I should note that I also had to deal with the Human Input Device problem so many others are dealing with.
  2. I've had the same problem. Even after all the updates. I just upgraded to Windows 8.1 today and have 15 GB of disk space to reclaim. Foolishly thought Parallels had fixed this by now. I'm now stuck at the "Reclaiming disk space..." stage, with no progress on the progress bar, and the spinning indicator. My upgrade took the good part of the afternoon. Now I'm sure it'll be all for naught as I'll have to kill Parallels and thus corrupt my disk image.

    I am very, very sorry I upgraded to Parallels 9. I've been a loyal customer ever since they came into the market just after Apple switched to Intel, but it appears with every release they get progressively more corrupted by the junior programmers that don't test for error conditions. I'm pretty sure my next "upgrade" will be to VMWare.

    Yes, I'm pretty upset. Perhaps they'd get a clue if I sent them a bill for all the time I've wasted on restoring corrupted virtual machines from their broken utility.
  3. OmarSultan


    Hello, anyupdates with this issue I've been having the same problem and they said it would be fixed in the latest update but the update came and nothing happened :(

    I am thinking of downgrading to Parallels 8
  4. I can confirm that this is still a problem. As a short-term remedy, I restored my Parallels 8 application bundle from a Time Machine backup (made prior to my upgrade to Parallels 9) to a "Restored" folder, and then I use Terminal to navigate into the application bundle to use the old "prl_disk_tool" utility to compress my Windows 8 disk image.

    The problem seems to be with Windows 8 disk images that were created under Parallels 8 or earlier. Creating a new Windows 8 or Windows 8.1 VM with Parallels 9 itself seems to work and the disk space can be reclaimed.

    But, as of this writing, I still cannot reclaim disk space on my Windows 8(8.1) VM using Parallels 9, either from the app itself or by directly using the prl_disk_tool utility.
  5. I was finally able to get things to work by performing "Resolution step #3" of :

    3. Go to Virtual Machine menu > Configure... > Hardware > Hard Disk 1 > Edit and check on Split the disk image into 2 GB files option option. Once splitting is complete, check off Split the disk image into 2 GB files option

    It can take a while for a large VM, but, at least for me, the process regenerated a disk image that Parallels 9 was able to properly compact. Granted, there's still a bug in the Parallels 9 prl_disk_tool, since the one from Parallels 8 still works correctly. But this at least got my VM working with Parallels 9 (so far ...).
  6. WaltM


    i'm also having numerous problems since "upgrading" to version 9. Just about anything I try to do now corrupts the virtual hard drive. So sick and tired of this piece of shit software from this piece of shit company. I want my money back for the upgrade, due to lost time and lost data from your piece of shit software.
  7. OmarSultan


    Any updates with the November Build? I am still facing the some problem and I am starting to get really pissed
  8. OmarSultan


    Great Idea, will definetly give it a go :) I really hope it works I've got around 6GB of unused space and my mac is running low on disk space
  9. TCPNotability


    Yep.. Feeling the same way

    Why do I bother.

    Dear Parellels,

    Recently there was a customer survey done by you, and in it there was a question that went something like:
    How Likely are you to recommend Parelles 9 to others​
    I put 0 (Not likely) as there was no option for 'No where in hell"

    Last weekend (29/11/2013 - 1/12/2013) I updated to the latest build of Parellels 9 Build 9.0.23350 that was released on the 11th of November 2013. I mistakenly believed that you had actually fixed your software. Since then I gave been getting constant reminders that I should compress my mail VMs' HDD (160+ GB). I have ignored it up until two hours ago.

    I safely shut down the VM, and proceeded to compress the HDD. On the VM list screen it displayed a progress spinner where the OS icon used to be. After about 30 minutes it attempted to boot up. Parallels Picture 1.png . (Thinking, oh CRAP!! When was my last backup?).

    Shut down the VM and go to VM --> Configure --> Hardware Tab --> Hard Disk 1 clicked edit.
    I get "Unable to resize the last volume. The file system on that volume might be corrupted or not supported.."
  10. Lambda

    Lambda Bit Poster

    Breathtaking hubris: "Hey, let's modify a critical file IN PLACE."

    Just got bit in the @$$ with this one as well. Unbelievable.

    Parallels 9 has been nagging the piss out of me to "reclaim unused space" for weeks. I finally have a few minutes this morning, so I caved in. What a mistake!

    I have exactly the same error as TCPNotability above.

    I work in software, and I know how easy it to sit from afar and "armchair program", but for the love of God...

    The FIRST thing this piece of crap should have done is check to make sure I had enough disk space for a complete copy of the hard disk file. (I didn't, and it should have said "Sorry, there's not enough free space to SAFELY compress your HDD file.") The second thing it should have done was verify the integrity of the existing hard disk file. The third thing it should have done is compress the hard disk TO A SEPARATE FILE. When that was complete, it should have verified that the new file was NOT CORRUPT. Then AND ONLY then, it should have deleted the old file and renamed the copy.

    This is how every damned utility that modifies a file works that I've ever seen, except this one.

    So now, I'm dead in the water, I'm restoring from a backup, and have lost a day's worth of work. I'm so tempted to pop open QuickBooks and invoice these knuckleheads for the lost time.

    Congratulations Parallels team! Your incompetence has not only cost you a customer, but you now have a former customer that regularly dispenses advice to people looking for virtual machine solutions. Guess whose product I will be recommending people stay far away from?

    Last edited: Jan 30, 2014
  11. Bloomk

    Bloomk Bit Poster

    so this issue has gone on for 4-5 months and nobody from parallels has offered a solution?
  12. Greg.S


    Bump. I'm now facing this problem after upgrading to 9 and trying to reclaim disk space. I'm 45 minutes in to reclaiming disk space of an 80gb Win 8.1 Pro installation and it doesn't seem to be progressing.


    Screen Shot 2014-04-04 at 15.35.44.png

    Last edited: Apr 4, 2014
  13. ChuckM416


    Awesome! unbelievable really.
  14. ChuckM416


    oops wrong thread.
  15. Specimen

    Specimen Product Expert

    Is this just a way so that you can post the link in your signature?
  16. AaronW123


    Of all the posts in this thread... THIS is the one you respond to?
  17. Specimen

    Specimen Product Expert

    Yes, as a user just like yourself I can choose what posts to answer and even to read.
  18. Brett_Conlon

    Brett_Conlon Bit Poster

    It's many years since the last post was added to this thread but I wanted to let you know that I'm having this exact issue under PD v14. My windows virtual is completely hosed and I'm in desperation mode trying to get back on track. Summary of what happened (for anyone experiencing something similar in the future):
    * Ran "Free Up Disk Space..."
    * Progress bar stopped at art 25% and sat the for hours.
    * There's no STOP or CLOSE button so all I could do was close the window.
    * Mac OS did constant 40MBps reads for hours and them stopped.
    *Tried running PD and got the "Starting up..." window for hours.
    *Support finally responded and said to upgrade to the latest version, which I did.
    *Booted new PD (v14.1.2-45479) and got a Windows Boot Manager error saying my Windows startup is corrupted.
    *Checked Disk First Aid on the laptop drive and it shows a corruption. I don't know if the corruption was there in the first place or if the DW recovery routine caused it during my various reboots (while the drive was heavily churning).
    *Windows 7 Install disc "Recovery" routine fails to fix the issue
    ***Wasted 4 working days trying to get my VM back!!!
    *Sadly my Time Machine backup is 60 days old and I don't trust it anyway.
    *Luckily, I placed all of my working files on the Mac side and shared it to the VM so I haven't lost any of my really important stuff.

    My next step will be to build a new VM. My I.S. team tried to install a new Win10 OEM but that also failed part way through. I need to repair my directory issue but I just found out that the tool I bought (Diak Warrior) doesn't fix AFPS volumes (which is what I have) so my nose is bleeding from all the walls I've been running into :(

    I also agree that there's NO protection for users around this feature. There should be the following warnings:
    * This process may take an extended period of time to complete (minutes to hours).
    * You cannot stop this process, once started, or you may corrupt your VM system.
    * Ensure your device is connected to mains power and will not go to sleep.
    * You should check the integrity of your drive (eg. Disk First Aid) prior to running this to avoid causing possible corruptions.

    Chz, Brett
  19. Johannav

    Johannav Bit Poster

    Geez, I am running version 14 or so in 2020 and this process got totally stuck, whether it's Windows or Parallels. This feature should be removed immediately or you should get a warning before starting it that this may take 5 days to complete for a 200GB virtual machine. Really really bad!!

Share This Page