Red Hat 8 parallels tools fails due to error

Discussion in 'Linux Guest OS Discussion' started by rhoekstra, Apr 6, 2019.

  1. rhoekstra

    rhoekstra Bit Poster

    Messages:
    6
    Hi, Somehow it seems the error hasn't been reported yet, or I'm unable to find the right thread.
    I installed rhel8 (beta) and tried to install the parallel tools, but it failed.

    excerpt from the installer
    Code:
    2019-04-06T01:39:27+0200: Started installation of Parallels Guest Tools version '14.1.3.45485'
    Error during report about start installation of parallels tools.
    Sat Apr 6 01:39:25 CEST 2019
    Start installation or upgrade of Guest Tools
    /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/pvmnet.c:420:3: error: 'const struct net_device_ops' has no member named 'extended'
      .extended.ndo_change_mtu = eth_change_mtu,
       ^~~~~~~~
    /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/pvmnet.c:420:29: error: initialization of 'int (*)(struct net_device *, void *)' from incompatible pointer type 'int (*)(struct net_device *, int)' [-Werror=incompatible-pointer-types]
      .extended.ndo_change_mtu = eth_change_mtu,
                                 ^~~~~~~~~~~~~~
    /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/pvmnet.c:420:29: note: (near initialization for 'pvmnet_netdev_ops.ndo_set_mac_address')
    cc1: some warnings being treated as errors
    make[3]: *** [scripts/Makefile.build:318: /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/pvmnet.o] Error 1
    make[2]: *** [Makefile:1522: _module_/usr/lib/parallels-tools/kmods/prl_eth/pvmnet] Error 2
    make[1]: *** [/usr/lib/parallels-tools/kmods/prl_eth/pvmnet/Makefile.v26:11: all] Error 2
    make: *** [Makefile.kmods:49: compile] Error 2
    Error: could not build kernel modules
    Error during report about failed installation of parallels tools.
    Error: failed to install Parallels Guest Tools!
    2019-04-06T01:39:27+0200: execCmd: ./install --install [167]
    2019-04-06T01:39:27+0200: Error: An error occurred when installing Parallels Tools. Please go to /var/log/parallels-tools-install.log for more information.
    2019-04-06T01:39:37+0200: Exiting with code 1
    
    I'm running the most recent version of Parallels Desktop (with tools v 14.1.3.45485)
    . as the output states, it's about kernel 4.18.

    If some workaround is available (which I haven't found), can one please point me to it? otherwise, if others encounter the same issue, it might be the tools aren't ready yet for the 4.18 kernel.

    Thanks for any pointers to the solution, greatly appreciated.
     
  2. (GalaxyMaster)

    (GalaxyMaster) Bit Poster

    Messages:
    14
    No, I think it is the other way around -- with 14.1.3 Parallels tried to address the kernel 5.x support and changed the source code to be kernel 4.20+ friendly. You fell a victim of that change :). If I were you, I would compare the sources of prl_vmnet.c between, say, 14.0 (where old kernels were supported properly) and 14.1.13 and would make the adjustments accordingly.
     
  3. mikel16

    mikel16 Bit Poster

    Messages:
    1
    Consequently, translation to a machine address fails, and an error log occurs.
     
    Last edited by a moderator: May 2, 2019

Share This Page