Redhat ES 5 + Nvidia driver problem

Discussion in 'Linux Guest OS Discussion' started by nicecuppa, Jul 3, 2007.

  1. nicecuppa

    nicecuppa

    Messages:
    10
    I have a Redhat ES 5 instance running fine on a MacPro through Parralels Desktop 3.0 for Mac, but I can't get the nvidia driver installed properly to get the the right resolution.

    The MacPro has an NVIDIA GeForce 7300 GT card in it.

    When I run the nvidia installer, since I have the kernel source installed, it builds the kernel module but the I get the following message:

    "Unable to load kernel module 'nvidia.ko' this happens when this kernel module was built against wrong or improperly configured kernel sources with a version of gcc that differs from the one used to build target kernel or if a driver such as rivafb/nvidiafb is present and prevents the nvidia kernel module from obtaining ownership of the nvidia graphics device(s)"

    /var/log/nvidia-installer.log contains the following line:

    Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko'

    I have it working at 1280x1024 but I would really want it to work at 1920x1200 which is the native resolution of my HP LP2465 display.

    Any help greatly appreciated.
     
  2. itsdapead

    itsdapead

    Messages:
    177
    That won't work - the virtual machine cannot access the MacPro video card directly - Parallels will emulate a generic video card, initially.

    Installing Parallels Tools for Linux (Read The Fine Manual) should fix the resolution - works fine on Ubuntu and Fedora, don't know about RedHat. The Linux screen will then dynamically re-size to fit the Parallels window (I was dead impressed that they persuaded X to do that!)
     
  3. nicecuppa

    nicecuppa

    Messages:
    10
    Thanks for the advice.

    I installed the linux tools on RHEL 5 by using the parallels "connect image" option that you get when you click on the CD icon at the bottom right of the screen, and then connecting the linux-tools.iso and running the install tool. I know this is slightly different to the method described by the manual (going through the "Actions" menu) but I only came accross the relevant part in the manual too late.

    After restarting the VM it still doesn't dynamically resize the resoltion of the screen as I change the parallels window.

    Do I need to change the display settings using the system-config-display tool?

    I have tried using the default "LCD 1920x1200" monitor setting and several different video drivers including the VMWare one in the system-config-display tool.

    I was going to try to un-install then re-install the linux tools but now when I connect an iso, a CD-ROM Disk appears on the desk top but there doesn't appear to be anyway to access it, i.e. nothing in /media

    Not quite sure how to proceed...
     
  4. nicecuppa

    nicecuppa

    Messages:
    10
    I ended up getting it working for RHEL WS 4.5 by installing linux-tools from the iso in the download, setting the monitor type to Generic "LCD Panel 1920x1200" using system-config-display tool, left everything else as is.

    When I restarted X the display was set to 1920x1440 for some reason, which meant in full screen mode it looked good but in non-full screen mode I couldn't get hold of the bottom of the window.

    Anyway I edited the /etc/X11/xorg.conf file and added "1920x1200" to the mode line in the "Screen" Section. Restart X and all is well.

    OSX, RHEL4, XP all running hapilly together now. Very cool!
     

Share This Page