Reducing the Size of your Solaris 10 Disk

Discussion in 'Other Guest OS Types Discussion' started by Artagel, May 3, 2012.

  1. Artagel


    I had an issue with my Solaris 10 VM, my image size had gotten to over 100GB, and there was no way to reduce the size inside parallels. First, I tried to use the compress disk tool in parallels, but it told me I had snapshots, so that wasn't possible. I copied the VM and removed all the snapshots, after which it tells me that it's not possible on Solaris(thanks for telling me before I deleted the snapshots!!! Luckily this was a backup). Then I tried something someone suggested with mirrored disks, but that didn't work well.

    Finally, my solution was pretty simple.
    I added another drive in the configuration window and assigned it to the second IDE.
    Rebooted the VM, started in failsafe(single user).
    Logged in and did: format
    This verified the second drive was visible. If its not, do the command: devfsadm and then try format again, it should be showing now.
    Type 1 and hit enter for the new drive
    then type fdisk and yes
    Quit and quit
    Next, assuming you have your backup slice on slice 2 like normal, all you need to do it:
    dd if=/dev/dsk/c0d0s2 of=/dev/dsk/c1d0s2 bs=1024k
    Wait for a bit, this command will clone your disk to the new one. Once it's finished you can shut down.
    Go into configuration and click on your primary drive and hit the minus button at the bottom. You can move to trash, but don't empty it yet.
    Now click on your other hard drive and change the position to the first IDE
    Now boot up your VM. It should start normally with the new drive.
    The new drive will only be as big as the actual data utilized on your VM, not overgrown like before.
    You can see the actual size of the hard drive in the GUI or by right clicking on the virtual machine in finder and clicking on show package contents.
    Hope this helps someone out.
    Last edited: Jun 22, 2012
  2. Rishi Chopra

    Rishi Chopra Bit Poster

    Perhaps it makes more sense to report the problem to Parallels Support? Assuming properly designed (and functioning) software you really shouldn't need to go through all of those steps just so the disk files utilize the amount of space that you originally specified (especially since you didn't have to do that with Parallels Desktop 3); maybe you can reference incident #1563780?
  3. Artagel


    Granted this was a year ago when I wrote that, I rechecked, and it still doesn't allow resizing. They do allow you to clear up some old files now in the newest version, but that only cleans up a few MB. At the time I did contact parallels support, who essentially told me it wasn't possible and they might develop it in the future.

Share This Page