Remote Desktop connection to Windows 7 VM

Discussion in 'Windows Guest OS Discussion' started by WallyR, Jan 2, 2012.

  1. WallyR

    WallyR

    Messages:
    1
    I've seen related questions in this forum and elsewhere but do not see a clear solution...hopefully someone can help me.

    I'm running Parallels Desktop 7 on a Mac mini running Lion. It has a Windows 7 Ultimate sp1 client VM running under it, using Bridged Networking on an Ethernet connection. The host Mac has a fixed IP of 192.168.0.10; the client is correctly receiving a dynamic IP address from my router--it's currently set to 192.168.0.12. Under Windows 7, I've enabled remote desktop connections using Control Panel > System and Security > System > Remote Settings and tried both "Allow connections only from computers running Remote Desktop with Network Level Authentication" and "Allow connections from computers running any version of Remote Desktop"--this choice of settings appears to have no effect.

    I would like to access the Win7 VM from another computer using Remote Desktop Connection. I've tried to access it using Microsoft's Remote Desktop Connection for Mac (RDC) v2.1.0 on a MacBook Pro running Snow Leopard and v2.0.0 on an iMac running Leopard. The RDC apps have worked to other Windows computers, so I don't believe that's the problem.

    In RDC, when I attempt to connect to 192.168.0.12, I get a dialog saying "The credentials that were used to connect to 192.168.0.12 are incorrect. Please enter your credentials again." Though I'm correctly entering my Windows username and password, I can never log in.

    I doubt I'm actually accessing the VM, as I can't reach it via ping. The client Win7 VM can ping and access every computer on my network, including the host Mac mini. No computer on my network, including the host Mac mini, can ping the Win7 VM. (Yes, other computers on the network can ping each other--just not the Win7 VM.)

    Since I can't get to the VM, even from the host computer, it makes me think there's a setting in Parallels Desktop that I'm missing. Again, networking is set to Bridged, so there are no Parallels preferences for port forwarding--as I understand it, all ports are supposed to be going through--that the VM is supposed to look like a separate computer on the network.

    Thanks in advance for your help!
     
  2. Mr. C.

    Mr. C. Bit Poster

    Messages:
    63
    It works.

    I'm using RDC 2.1.1 (there's an update, but the updater in RDC doesn't work). Go to http://www.microsoft.com/mac/downloads .

    Have you configured the username / password in Preferences in RDC? Perhaps they are incorrect.

    If you're getting a Credentials incorrect dialog, this would appear to indicate you're connecting to the Windows VM. Try disabling Windows Firewall temporarily while you're trying to get the connection to work.
     
  3. shanjoyb

    shanjoyb

    Messages:
    48
  4. Monster_Munch

    Monster_Munch

    Messages:
    1
    Remote Desktop Connection to Windows Server 2008R2 VM

    I am having similar problems trying to connect to a Windows Server 2008R2 virtual machine. I am running Parallels Desktop for Mac on a mac mini server running Lion Server, which has an IP address of 192.168.0.9. The virtual machine is configured to use a bridged network so it has it's own IP address (192.168.0.4). I have done the following:

    1
    Allowed remote connections on the Windows 2008 machine using the 'Allow connections from computers running any version of Remote Desktop' option. I have also added Administrator account to the list of users even though it is supposed to have remote access already.

    2
    Configure Windows Firewall to allow remote desktop to communicate through it. I also turned it off completely to see if this was the issue.

    3
    Set up port forwarding on my router to forward connections to port 3389 to the VM IP address. I have also tried changing the port to and the RDC listener to port 80 in case 3389 is blocked by my company firewall.

    When I try to connect to my VM from my Windows PC at work, I am getting a 'This computer can't connect to the remote computer' message. I also cannot ping the virtual machine IP address from the host so I am suspecting a setting in Parallels somewhere.

    In the preferences --> network settings there is an option 'Enable IPv4 DHCP with a start address of 10.211.55.1, and end address of 10.211.55.254 and subnet mask of 255.255.255.0, which are all configurable and a subnet of 10.211.5.0 that is not.

    Is there anything that I could be missing here? Do I need to configure anything on the host machine to allow connections through?

    I would appreciate any help.
     
  5. DeanJon

    DeanJon

    Messages:
    1
    Try to establish remote connection between MAC and Windows 7 computer using remote support tools such as logmeinrescue, gosupportnow, GoToMyPC etc. and check whether it works or no.
     
  6. kerryk

    kerryk

    Messages:
    1
    I have the same problem as #1&#4 anyone can help us?
     

Share This Page