Remove the list of Mac applications in Windows

Discussion in 'Windows Guest OS Discussion' started by SebastjanZ, Jan 28, 2012.

  1. SebastjanZ

    SebastjanZ

    Messages:
    1
    When I installed Windows 7 in Parallels 7 I chose the setting "Share Mac application with Windows". Later I decided to stop sharing applications and unchecked this option in menu (Virtual machine, Configure, Applications). Now applications are not shared (which is OK) but I still see the list of Mac applications in Windows. How do I remove the list of Mac applications? I found shortcuts to Mac applications in folder "C:\Users\username\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Parallels Shared Applications" but deleting them does not help.

    To make it clear, here is an example: In Windows I right click on a file and choose "Open with". Among the programs offered there are Mac applications as well. I would like to remove those from any list in Windows.
     
    Last edited: Jan 28, 2012
  2. Geesu

    Geesu

    Messages:
    76
    Is this possible? Anyone figure this out? It's horribly annoying.
     
  3. Kentor

    Kentor

    Messages:
    2
    Here's how.

    Control click on the start menu, select the Customize button. Click "Advanced" and you'll get a browser window with an item called "Start Menu". Open it. Delete the Parallels Shared Applications folder.

    If you have multiple users on the VM, select them and find their corresponding Start Menu folder to see if they have a Parallels Shared Applications folder as well.
     
    Last edited: Apr 27, 2012
  4. stevek1977

    stevek1977 Bit Poster

    Messages:
    3
    I have this same exact problem and cannot get the list of MAC applications removed from the VM (Windows 7).

    I've tried the following:

    - unchecking "Share Mac Applications with Windows" in the Options/Applications tab

    - checking the Integration: Isolate Mac from Windows" button in Options/Security.

    - removing the parallels tools from the windows 7 vm (they have been reinstalled)

    - deleting the directory from my start menu

    These changes have NOT removed the Mac applications from my Windows 7 VM and every time I attempt to use the right-click open with functionality I have to scroll through tons of MAC applications to find the windows application that I wish to use. There has to be a way to get these options removed.

    Additionally, when I go to the Set Associations option in the Windows 7 (VM) I see all of the MAC applications listed in there as defaults for certain file types.

    Any help/suggestions are greatly appreciated.
     
  5. speedster

    speedster

    Messages:
    1
    I have this same problem (on Windows 8 though). Help would be much appreciated...
     
  6. AdityaM

    AdityaM

    Messages:
    3
    On Windows 8 desktop RIGHT-click on any of the Mac apps. A view will appear at the bottom of the screen, where one of the options is "Open file location." Click on that and the folder appears with all app shortcuts. Delete all the Mac ones.
    That did the trick for me.
     
    Last edited: Sep 4, 2012
  7. macwin

    macwin Bit Poster

    Messages:
    1
    Thanks AdityaM, I was looking for a solution for this.
     
  8. CalvinC

    CalvinC

    Messages:
    1
    this solution works for me!

    here it is
    click start on windows 7
    type in/search -- (mac)--
    Right click on any of the (mac) apps
    click ( open file location )
    delete all of the share apps
    you are welcome and enjoy!
     
  9. YoeunP

    YoeunP

    Messages:
    2
    Finally resolved this damn issue today after HOURS wasted on it.

    Since I deleted my "Parallels Shared Applications" folder in the Start Menu without FIRST deleting the apps themselves, I couldn't follow the instructions above to delete the apps themselves. The Start Menu only stores shortcuts. The actual .exe files are located here:

    C:\Users\${USERNAME}\AppData\Roaming\Parallels\Shared Applications

    Just delete all the items in that folder. Your OpenWith list will magically update and the (Mac) options will disappear. For some reason, the forum is breaking up the "Shared" text above to "Sha red". It should be "Shared", no space.
     
    Last edited: Dec 15, 2012
    YongfanM likes this.
  10. Mike Boreham

    Mike Boreham Kilo Poster

    Messages:
    205
    This worked...thanks!
     
  11. Ajith@Parallels

    Ajith@Parallels Parallels Support

    Messages:
    1,783
    We are glad to see that your issue with shared applications got resolved. Feel free to reach us anytime for support.
     

Share This Page