RES Workspace Manager 2012 & 2X Application Server XG

Discussion in 'Parallels Remote Application Server' started by schotje86, Aug 19, 2012.

  1. schotje86

    schotje86 Guest

    Hello,

    I'm trying to get RES Workspace manager tot work with the 2x AS XG.
    We use RES on our Microsoft 2008 R2 TS servers instead of GPO's.

    RES provides Printer- and Drive Mappings. Also we use RES for anything u normally also could do with GPO's. We use for this because it's really faster loading the session then when using GPO.

    Here's my problem:
    When I launch an application such as office on a 2x Client, 2x doesn't load all the RES settings, but only some..

    The biggest problem is that the network mappings are not made.

    Is there anyone who has RES Workspace manager working with 2x AS XG?
     
  2. woqz

    woqz

    Messages:
    180
    I did a quick search on the forums and couldnt find any relevant info on this. Since it is a 3rd party application for 2X, it may very well be they do not integrate fully.
     
  3. jpc

    jpc Kilo Poster

    Messages:
    155
    As woqz said, it may not be fully supported (as it seems to be doing quite a few things under hood). However, I suggest that you contact support as they may be able to assist you in finding the issue.
     
  4. sbcpro.de

    sbcpro.de

    Messages:
    53
    Hi there,

    we do not have the use case that both products are in the same farm, but we do support some farms with RES Workspace Manager 2012 and 3rd party add ons for terminal services like 2X Software's AS XG. From my point of view there arn't any big issues with using the RES Workspace Manager 2012 with solutions from other vendors and 2X mainly using the build in Microsoft features.

    Does the issue always appear or only in some cases? E.g. everything works well when you launch a full desktop and does not work when you only starting a published application.

    Does the issue appear only when you are using the 2X client to connect to your target systems or also when you are using the MS RDP client?
     
  5. schotje86

    schotje86 Guest

    Hi,

    When I connect to the full desktop either by using 2x Client or using MS RDP, the settings are all applied. Including the settings for drive mappings en hiding te local drives.

    When I use 2x client drive mappings are never made.
     
  6. woqz

    woqz

    Messages:
    180
    the 2X client has drive redirection enabled by default which may be conflicting in anyway?

    Try disabling it from the Connection Properties > Local resources tab and see if it makes any difference.
     
  7. schotje86

    schotje86 Guest

    I tried to disable the client drive redirection, but that isn't helping as well..
    Still the settings made by RES aren't applied.

    I think there's something conflicting in the she RES shell and the 2x Shell. But i don't know what...
     
  8. sbcpro.de

    sbcpro.de

    Messages:
    53
    Hi there,

    I think I understood right that you do only have the issue when starting a published application. As 2X Software operates similar to Microsoft RemoteApps your issue should be that the PWRGATE.EXE, that is needed for RES WM, is not getting executed.

    To have RES WM configure anything you need it have to be started in front of the application. Please try to replace the target of the published application with %RESPFDIR%\PWRGATE.EXE and the needed application. This will make sure that RES WM starts, configures the user's session and then launches the required application.

    E.g. if you have published the NOTEPAD.EXE then
    1.) Define the application in RES WM (note the application ID that points to it)
    2.) Create the 2X published application with the target %RESPFDIR%PWRGATE.EXE <application ID> (ID as a parameter)
    3.) Publish it on all the required servers

    You'll know when you get it running as soon as will see the RES WM splash screen when launching a published application. The integration in RES WM (> Express Edition) with RemoteApp will configure the above for you automatically in conjunction with the Microsoft features and publish the application to the required servers. If you didn't get it working with 2X AS right away I would advise to configure the MS RemoteApp integration and copy the details of the targets to the 2X AS installation ;)

    Good speed!
     
  9. schotje86

    schotje86 Guest

    Thank you.

    That seems to be the answer. When I launch an application I get the RES screen and then starting the choosen application.

    The only thing I know experience is that after the RES screen, the session is immediatly logged off.

    I see in the event viewer this error:
    "the desktop window manager was unable to start because a composited theme is not in use"

    I think it has something to do with all the things i've tried. So now I'm building a testlab from scratch and try it again.
     
  10. schotje86

    schotje86 Guest

    I've found the solution for the above problem.

    I needed to install the Desktop Experience Feature and to enable the themes service.
    After this I was able to start applications from the 2x Client by launching %respfdir%\pwrgate.exe {application ID}.

    All the RES settings are made now, including drive mappings.

    Thanks for all the help offered.
     
  11. sbcpro.de

    sbcpro.de

    Messages:
    53
    Thanks for your feedback and solution. That's good to know!
     

Share This Page