[Resolved] Cannot add TPM chip on Intel Mac

Discussion in 'Windows Guest OS Discussion' started by Bubbles55, Mar 29, 2022.

  1. Bubbles55

    Bubbles55 Bit Poster

    I am trying to update Windows 10 to 11 and Windows does not recognize the TPM.
    I originally had a legacy partition and have already changed that to a UEFI partition. When I look at the guest OS configuration hardware, I do not see "TPM" listed there. So I modified the config.pvs and added <enable>1</enable> to the Tpmchip section. I also changed EFI*** to 1. Then, the TPMs are found in the configuration.
    Every time I start Windows 10, Parallels warns me about TPM and asks if I want to force start or stop. And I am able to force start Windows with no problems. I run the tpm.msc command and it says "no compatible TPM". When I run the MS-provided verification application, it points out that you need TPM 2.0.
    How do I get Windows to recognize the TPM?

    Parallels Desktop for Mac 17.1.2, macOS 12.3
  2. Bubbles55

    Bubbles55 Bit Poster

    Is the reason why I can't view it in tpm.msc because I am currently on Windows 10?
    If I update to Windows 11 from the ISO file, will the TPM be recognized?
  3. JohnW70

    JohnW70 Bit Poster

    I don't know enough to give a proper answer, but I suspect the answer is in the affirmative. I have never used Windows 10 with Parallels, starting with Windows 11 on both M1 and Intel. It seems that TPM2 is somehow emulated by Parallels. From tpm.msc, I see:
    Then, from Privacy & Security, Device security, Security Processor:
  4. Bubbles55

    Bubbles55 Bit Poster

    The odd thing is that my Parallels(17.1.2) does not allow me to add a TPM chip using the normal configuration procedure. I have enabled the TPM chip by editing config.pvs, but I can't even do a fresh install of Windows 11 this way.

    I often see information that upgrades are difficult but new installations are not a problem. However, that does not seem to be the case for me.
  5. Bubbles55

    Bubbles55 Bit Poster

    OK. I was able to solve the problem myself.
    1. Open the Virtual Machine's configuration.(Of course, Windows is shut down.)
    2. Hardware > Boot Order > Advanced Settings
      In Boot Flags, type this command: vm.efi.secureboot=1
    3. Start and shut down Windows.
    4. (I had already added the TPM chip manually by editing config.pvs.)
      Once the "TPM chip" is removed from the configuration hardware.
    5. Add "TPM chip" from the hardware of the same configuration from the + icon.
      -> Parallels now displays a dialog that officially adds the TPM chip.
    6. Start Windows.
    7. Open tmc.msc command.
      -> It was successfully recognized.

Share This Page