run a website, hosting in the Mac Side, with IIS of the the Guest Os

Discussion in 'Windows Guest OS Discussion' started by filojoy, Oct 13, 2007.

  1. filojoy

    filojoy

    Messages:
    3
    Hi
    I'm a newbie of Mac OS and Parallels.

    I'm trying, without success, to understand how to make run a website, hosting in the Mac Side, with IIS of the the Guest Os (WinxpPro).

    Connecting URL http://localhost:80 - Internet Explorer displays:
    This error (HTTP 500 Internal Server Error) means that the website you are visiting had a server problem which prevented the webpage from displaying.

    IIS config:
    tab "WebSite"
    > TCP Port: 80
    tab "Home Directory"
    > check on "A share located on another computer"
    >Network Directory:" \\.Psf\.Home\..." the UNC path of sharing folder
    >Connect as "Administrator" pass: ""
    tab "Directory Security"
    >"Anonymus access and authentication control"
    >>"Edit"
    >> check on "Anonymous access"
    >> User name:" Administrator pass:""

    -------
    Thanks in advance
    FiloJoy
     
  2. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    Are you trying to set-up Windows to access a share to the OS X side? That is point IIS to a shared folder.

    Sorry, but I am confuzzled.
     
  3. filojoy

    filojoy

    Messages:
    3
    FlashBack:

    I have allready setup a virtual machine (GuestOS winxp pro) using an image file inside Parallels (no Boot Camp).
    Starting my virtual machine I have on my WinXp desktop just a link to Os X side, with all the structure of my Os X HD root.
    As you know, we can use windows' programs to open files that are in the Os X side. What I wanna do right now, is the same thing with the IIS service. Why? Because I'm developing a dinamic website and it would be faster working without mooving (=copy) every times files from Mac Side to the Win Side to test it. Do u understand?

    So, if I set IIS to a local folder (one in my winXP Desktop) and I copy my website's folder on winXp desktop, I don't have any problems and everything goes right.....

    but what I can't is setting IIS directly in the folder of my Os X side. Can u help me to find IIS right setups?

    Thanks in advance
    FiloJoy
     
  4. sandro

    sandro Parallels Developers

    Messages:
    512
    hi,
    whether you try to get access to remote directory that you configured for IIS through explorer for example? Can you exploring files necessary for IIS work through it?
     
  5. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    filojoy,

    I think I understand things now. My question would be the same as sandro's, can you access the files via Windows explorer?
     
  6. filojoy

    filojoy

    Messages:
    3
    Sorry for the late,
    the answer is "yes I can" what I can't is let it run my local website (on Internet Explorer)

    thanks
     
  7. rcherny

    rcherny

    Messages:
    6
    I am having a similar problem. I have a OS X shared folder. I have pointed to it has the home directory in IIS via a ".PSF" mount point. IIS always returns a 500 error. In IIS I specified it should connect as my OS X account credentials.

    No joy. 500 error, even though from Windows Explorer I can get to the files just fine.
     
  8. helmishariff

    helmishariff

    Messages:
    33
    I think it can't be work. Windows recognize shared folder as network folder and for the security reason, IIS not allow this. I might be wrong. or... you can right click paralles shared folder and add permission to allow IIS read the folder in shared folder.
     
  9. rcherny

    rcherny

    Messages:
    6
    I got it working. I haven't tested everything, such as write permissions (like file uploads) but the Classic ASP app I'm trying to use is currently running off the Mac OS X disc via IIS in parallels.

    1. Enable Personal File Sharing in Mac OS X
    2. In IIS, set your home folder to be a "Share located on another computer" and set the "Connect As..." to be your Mac OS X user credentials.
    3. Finally, set the network directory to be \\[your mac ip]\[whatever share folder]

    So far, working like a charm!

    I'm psyched. Now I can store my data on the Mac disc and run it from Parallels so I don't have to worry about backing up Parallels data, I just get to use it's services. Sweet.
     
  10. rcherny

    rcherny

    Messages:
    6
    I am however periodically getting 401 Access Denied Errors. I have everything set to 777 permissions on the Mac side, so I'm not sure what's up. It looks like two requests though, so I'm not sure what's up there...

    HTTP/1.1 200 OK Server: Microsoft-IIS/5.1 Date: Fri, 11 Jan 2008 13:49:23 GMT X-Powered-By: ASP.NET Connection: close Content-Length: 73 Content-Type: text/html Cache-control: private

    HTTP/1.1 401 Error: Access is Denied.
     
  11. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    If IIS can access the file as the former error seems to say, it sounds like the issue might be IIS, no?
     
  12. bmav

    bmav

    Messages:
    1
    Help?

    I would like to know if anyone has got this working...

    Within IIS I can set up my application correctly. I'm specifying the 'connect as' setting as application user (pass-through authentication). I'm unable to select anything when I try and set a specific user. I'm not sure on the format for the OSX user.

    I have setup the appropriate permissions on the shared folder in OSX, and I'm able to open the website from within Visual Studio 2008.

    However, I'm unable to browse using Internet Explorer, I keep getting the following errors:

    HTTP Error 500.19 - Internal Server Error
    The requested page cannot be accessed because the related configuration data for the page is invalid.

    Module IIS Web Core
    Notification BeginRequest
    Handler Not yet determined
    Error Code 0x80070003
    Config Error Cannot read configuration file
    Config File \\?\F:\Projects\www_xxx\web.config
    Requested URL http://localhost:80/xxx/test.htm
    Physical Path F:\Projects\www_xxx\test.htm
    Logon Method Not yet determined
    Logon User Not yet determined

    To me it would seem like there is still a permissions issue, however I'm not sure how to resolve it. Within Windows, I'm unable to add the IIS_IUSRS or IUSR account in permissions, its keeps giving me a permissions denied error.

    Any help would be appreciated.
     
  13. abfield

    abfield

    Messages:
    10
    I know that this thread is a little old. I started a new one because I was having similar but different issues with IIS and Parallels. If anyone on this thread figured out how to get it working or has ideas would you be kind enough to point me in the right direction?

    Thank you. Link to thread:

    http://forum.parallels.com/showthread.php?t=257823
     
  14. abfield

    abfield

    Messages:
    10
    I posted a solution in the thread mentioned in my last post should anyone find it useful.
     

Share This Page