Running Bootcamp from an external HD in Parallels 13

Discussion in 'Installation and Configuration of Parallels Desktop' started by Parallels User, Aug 22, 2017.

  1. This used to work fine with Parallels 12 but seems to be broken in Parallels 13.

    What I did:
    1 - I was prompted that there was a new version of parallels available.
    2 - I did shut down my Bootcamp Windows 10 running on an external SSD.
    3 - I let the update run through.
    4 - I tried to start my Bootcamp Windows but now, Parallels does not seems to be able locate the Bootcamp partition.
    5 - I get 3 successive error messages attached as Error1, Error2 and Error3.
    6 - Stopped the Virtual machine
    7 - When I access my HD configuration, I see my HD selected. If I select it again in the drop down menu I get Error4. More details... gives this:
    Error: PRL_ERR_DISK_PARTITION_NOT_FOUND (0x80021053)
    Path: '/Users/<user>/Documents/Parallels/Bootcamp.pvm/OTG V2 OTG V2 (disk2).hdd'

    8 - I decided to inspect the content of the my Bootcamp VM and discovered that the .hdd file is missing in the VM. Having done a backup of my VM before updating, I still had a copy of the .hdd file so I copied it back un the VM content. I discovered that as soon as I start the VM or try to configure the HD, the .hdd file now gets deleted in Parallels 13.

    9 - I then tried to create the Bootcamp VM anew but at the moment of binding the HD, it failed with the same error (Error4) above.

    10 - I uninstalled Parallels 13 and installed Parallels 12 back. Restored my Bootcamp VM which I previously made a copy of. Everything went back to working perfectly fine.

    Having read on the forums that some people experienced issues when updating to Parallels 13 from Parallels 12 without restarting the application or the Mac. (As Parallels 13 update process never prompts the user to.) I decided to uninstall Parallels 12 manually and install Parallels 13 manually. That time, I was prompted to restart my Mac. After restarting, I tried to launch my Bootcamp VM which was just working with Parallels 12 and got the same errors as mentioned at step 5.

    So I reverted to Parallels 12 again and got on with my workday. For the sake of getting the best error report, I did installed Parallels 13 a third time tonight so I can grab screenshots and get the exact error messages. This is not an issue related with a bad manipulation of the HD since it remained connected all the time and did worked perfectly with Parallels 12. Nor is bogus issue related to the installation context since I've reproduced the problem three time in three tries.

    For now I will keep working under Parallels 12 since all seems to be working fine, but as a paying customer, I'd like to get the new goodies like everyone.

    Attached Files:

  2. SeekRay

    SeekRay Bit poster

    I am having problems with you. :(
    Upgrade to v13 after the problem:
    1 - VM Windows 10 error, (Error4, me,too) but can enter the Windows desktop.
    2 - Can not load 2 NTFS HDs. (Error4)
    3 - Created new VM Windows 10, still can not load HDs. (Error4) :(
    So I had to give up using v13. :(
  3. It's now been more than a week and no one from Parallels bothered replying to this thread or to me directly.
    You know guys, the subscription model may seem very nice since it gets you influx of cash on a regular basis and get your users updating.
    The downside to this is that those clients actually intend to get what they paid for. By that I mean is the ability to upgrade.
    Now, this issue is clearly a regression in version 13.0.0.

    I just saw 13.0.1 has been release but I can't find any bug fix release note anywhere.

    I am not very happy with the customer service I got on this issue as it is a major blocking issue preventing me to upgrade to the latest version, which I expect as a Parallels Pro subscriber.

    I expect someone from Parallels to get in touch VERY SOON and do some explaining about the issue and what they are doing about it.
  4. Two weeks in and still no news from anyone at Parallels...
    Is there some other way to get support? I tried to locate customer support on your support site, but it is like the crazy house in there!
  5. GordonS4

    GordonS4 Bit poster


    I experience the same problems. Win10 on external USB3 SSD. Worked with Parallels 12 but refused to work with 13.
    Tried the same things as the guy in the first thread. Rebuild the pvm from scratch and tried to set boot to external hard drive but nothing worked for me.

    Revert to 12 and think of an alternative to Bootcamp because it sux everytime you really need it.
  6. IlterC

    IlterC Bit poster

    I ran into the same problem and posted a reply to a similar topic here.
    I'll also post my reply as a quote here.

  7. As my friend IlterC writes, it seems that Parallels 13 has indeed a hard time booting from MBR disks. (I tried booting from several MBR windows using Parallels 13 with the same failing result.) I guess those Parallels guys just forgot to say anything about this nice little regression in Parallels 13. Not wanting to recreate my Windows setup that is less than 3 month old, I embarked on the task of changing the partition table, creating an EFI partition and filling it with Windows boot files. This took me the better of two days, but in the end I managed to get my Windows 10 to boot in Parallels and natively.

    After creating a thread on Parallels forums, creating a support ticket to Parallels support and waiting about 2 months, I can report that I got no help whatsoever from Parallels. The only reply I got was early September telling me they escalated my support ticket to engineering, but no word from the since.

    I figured that by paying 100 USD a year for the service, I was entitled for... well... what i paid for. That being support and continued updates. The only problem is that I was only able to take advantage of version 13 due to support from the community which is very active and helpful, NOT because of the help I received from Parallels.

    Considering all this, I think I will be looking at alternatives before my subscription expires...

    Thanks again to all of you who took the time to try and help! You guys are awesome!

    P.S. If any of you want the recipe to turn a MBR installation of Windows into an UEFI installation, I can help. Know that this is not without risk and i would definitely recommend a clean install if you have the option.

Share This Page