Running Games Like Medal of Honor on PD16

Discussion in 'General Questions' started by AnthonyM20, Feb 7, 2021.

  1. AnthonyM20

    AnthonyM20 Bit Poster

    Messages:
    3
    Hi
    I've used Parallels in the past for a multitude of different things in the past:
    • running a decent MSN / Live Messenger at the time;
    • running Outlook before Mac Mail became decent enough to switch;
    • running a programming environment, eg Delphi or using something like Power BI / SQL Server
    One thing I'd LOVE to use it for is for old PC games with a big hit of nostalgia. I used to play MOH:AA and Spearhead a great deal back in 2001 - 2004, and did manage in the past to create a Boot Camp Windows installation with Parallels to run it. But that was about 6 years ago, and I don't want to have to reboot my machine just to be able to play these old games.

    I recently saw a Twitch stream of someone playing MOH online (using the Revival patch, of course) and I'm desperate to have it working again. However, I still get the same old problems where as soon as the game launches, it crashes. Has ANYONE managed to get this game running in a normal Parallels environment? Ie, not a boot camp? If so, please can you tell me what I need to do so. AFAIK, I have everything installed that I should to play the game. The MOH console seems to indicate that OpenGL has just been loaded, but then talks about some bits being missing - though I doubt this is the reason for the crash. I even tried to skip the intro and get straight to the game by editing the autoexec.cfg, and have tried to run it in Windowed mode by putting a "-w" on the shortcut. All have no effect, and if anything the skipping of the intro just makes it crash quicker. I run my Windows env in Windowed mode, but even if I run it in fullscreen, there's no difference. I'd like, finally, to be able to sort this and I can't believe that 20yrs after a game was released, Parallels cannot make this work...there must be something I'm missing?

    Thanks
    Ant
     

    Attached Files:

  2. AnthonyM20

    AnthonyM20 Bit Poster

    Messages:
    3
    Never mind, I got it working in the end.
     

Share This Page