Running Parallels Desktop 8 for Mac on Mac OS X Mavericks 10.9

Discussion in 'Installation and Configuration' started by luke666s, Jun 11, 2013.

  1. SylvainP

    SylvainP

    Messages:
    12
    Little addendum to help others

    Here is an important instruction to re-enable Parallels networking services:

    File > Preferences > Network > Select an Adapter and Edit > Restore Defaults

    Found elsewhere on these forums. Along with your helpful insights, I'm back in business!

    Regards,

    Dr Sly
     
  2. Andrew@Parallels

    Andrew@Parallels Parallels Team

    Messages:
    633
    Hi folks,

    Apple has released Mac OS X Maverick 10.9 Developer Preview on June 10 and Parallels Team is currently testing its compatibility with Parallels Desktop for Mac.
    We do not recommend to use any of the suggested "hacks" to get it to work and suggest to hold on till you hear more news from us.
    Stay tuned – we will update this forum thread as soon as we have some news!
     
  3. Andrew@Parallels

    Andrew@Parallels Parallels Team

    Messages:
    633
    Hi everyone,

    Please use the script at http://kb.parallels.com/116259 to start Parallels Desktop 8 for Mac on Mac OS X Mavericks 10.9 Developers Preview!
     
  4. Caesium

    Caesium Bit Poster

    Messages:
    16
    Although this gets Parallels started (even 7, once the path is corrected) I'm having odd mouse/keyboard issues. Mouse clicks seem to work about 1/10th of the time, and keyboard input doesn't work at all.

    I can't reinstall the parallels tools because I can't even login to the VM (be it Ubuntu, or Windows, or whatever).

    Is this only happening on 7? I'm quite reluctant to upgrade to 8 now in case 9 is released in a couple of weeks and I'm left behind again..
     
  5. JimmyB

    JimmyB

    Messages:
    1
    You. Are. Awesome.

    This worked for me. Thank you!

     
  6. SylvainP

    SylvainP

    Messages:
    12
    Hello Caesium,

    I followed the instructions from Matt, and I made Parallels Desktop 8 work on Mavericks beta 1. I have no performance problems running either a Windows 7 virtual machine, nor my Windows 8 Boot Camp as a vm either.

    I don't know if hardware resources might impact this, since I have an insane amount of CPU and RAM (I have the top-end rMBP, so...)

    Cheers,

    Sylvain
     
  7. chiragm

    chiragm

    Messages:
    1
    Pls help me how to do this.i am using parallels 8
    I found in finder "Applications/Parallels Desktop/Contents/Library/Extensions/10.6" ? then what to do?
    Pls advice me i am newbie here.....I do not understand these steps...

    "Load them manually via kextutil:
    Terminal - go to Applications/Parallels Desktop/Contents/Library/Extensions/10.6

    sudo kextutil prl_hypervisor.kext/
    sudo kextutil prl_vnic.kext/
    sudo kextutil prl_hid_hook.kext/
    sudo kextutil -d ./prl_hypervisor.kext prl_netbridge.kext/
    sudo kextutil prl_usb_connect.kext
    "
    thanks for help
     
  8. AlexMBento

    AlexMBento

    Messages:
    6

    Still doesn't work for me.

    The PVM begin starting, show the usual screen with mem info, etc... and then stopping the VM.
     
  9. MatJones

    MatJones

    Messages:
    5
    Thanks to the advice on this thread I've now managed to get PD7 to run with 10.9. I tried using the PD8 script, but changing the path. While this allowed the VM's to start, I experienced the erratic mouse/keyboard behaviour as pointed out in an earlier post.

    The script I'm using is :

    #!/bin/sh

    ExtensionsPath="/Library/Parallels/Parallels Service.app/Contents/Kexts/10.6/"
    cd "$ExtensionsPath"

    sudo kextutil prl_hypervisor.kext/
    sudo kextutil prl_vnic.kext/
    sudo kextutil prl_hid_hook.kext/
    sudo kextutil -d ./prl_hypervisor.kext prl_netbridge.kext/
    sudo kextutil prl_usb_connect.kext

    open /Applications/Parallels\ Desktop.app

    I've had to reset the network settings in PD7 preferences, but all seems well. It doesn't appear to persist on restarts, but I rarely restart my MBP so it's not that much of an issue. I can certainly wait until an official fix is released.

    I hope that PD7 will be updated to support 10.9, I will be very disappointed if Parallels leave out PD7 users, it's not like the version is that old.
     
  10. Wojda J

    Wojda J Bit Poster

    Messages:
    4
    I'm still having problems, I can start the VM with the script, but I don't get a display. I can see in the Parallels icon shows that the VM is started, but i tried coherence, modality, and full screen. can't get a display.

    I'm using 2 external monitors (One via MiniDP and the other via HDMI--> DVI) + the internal retina but nothing shows on any of them.


    EDIT:
    I went to the Window drop down menu and Zoom and it opened up.
     
    Last edited: Jun 12, 2013
  11. Caesium

    Caesium Bit Poster

    Messages:
    16
    Did you manage to get this mouse/keyboard behaviour resolved Mat? I don't see anything in the post to indicate that - the script you're using looks pretty similar to the ones already posted, maybe just with the kexts in a different order?
     
  12. MatJones

    MatJones

    Messages:
    5
    Yes, I restarted my MBP to make sure nothing existing was loaded. I then used the script as in my last post to launch PD7 and it's been happy since.
     
  13. Michael66

    Michael66

    Messages:
    3

    MatJones, "thank you." This does allow P7 to open under 10.9, BUT, and this is a big one, my keyboard will not connect. So I can not type to logon to Windows. The Keyboard menu does work to issue ctrl-alt-del and my mouse works but not the keyboard.

    Anyone got a clue?

    Thank you.
     
  14. Wolf_Racer

    Wolf_Racer

    Messages:
    2
    I have set to 64mb of video and 4gb, load the dmg file, and it says press start in OS Mavericks screen. I press start and it shows black screen with words (like 4 gig, etc) and then goes back to the same screen. Wont install basically.

    Ideas?
     
    Last edited: Jun 12, 2013
  15. MatJones

    MatJones

    Messages:
    5
    Try reinstalling the integration tools in the VM. You don't need KB access to the VM to install them. The option is the Virtual Machine Menu. The reboot is automatic after 2 minutes.
     
  16. Michael66

    Michael66

    Messages:
    3
    Thanks for the reply.

    However, I can not reinstall the tools without being logged into the Windows. The menu item is there and I can selected it and the dialog box comes up and i can click yes, but the VM never reboots or comes back and of course I can type NOTHING as the keyboard input is disabled.
     
  17. KevinU

    KevinU

    Messages:
    3
    You can use the virtual keyboard to enter your password (lower left corner). but reinstalling the tools didn't work for me :( (PD7 & windows 7)
     
  18. Michael66

    Michael66

    Messages:
    3
    The only way I could overcome the problem was to install PD8. Then run the startPD script and all was good again. Never could get PD7 to let me login.
     
  19. KevinU

    KevinU

    Messages:
    3
    With the virtual keyboard i can login and use windows. but my macbook keyboard won't work. there is also a problem with the clipboard between mac and parallels. i hope the problems are resolved till osx 10.9 final.
     
  20. KevinU

    KevinU

    Messages:
    3
    Yeah!!! I worked it out. In order to use the Mac keyboard/mouse, access for assistive devices has to be enabled. In Mavericks the location of this option was moved. Now you can find it under:
    System Preferences > Security & Privacy > Privacy Tab > Accessibility section
    There you can enable the option for each app. Everything just works fine! :)
     

Share This Page