Screen starts flickering on new Macbook Pro 13 (with touch bar)

Discussion in 'Windows Guest OS Discussion' started by Kennethd2, Nov 23, 2016.

  1. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Hi DerekL1, the integrated graphic cards is to send appropriate parameters when creating an OpenGL context (and react to switching events by recreating contexts) So "Better Performance" options is not applicable for this kind of integrated cards. As a result, screen flickers with lesser Video RAM compare to Discrete video cards. Please note that this technology has no similarities with SLI/Crossfire whatsoever. Please set 'Longer battery life' under Optimization of your virtual machine and let us know how it works.
  2. DerekL1

    DerekL1 Bit Poster

    Hi Paul,
    I tried the longer battery life and same issue. I also had the logic board replaced and same issue so this is my second mbp13 and third logic board with the same flickering issue. Any other ideas? my 2016 MBP15 is working fine.

  3. DenisS3

    DenisS3 Bit Poster

    I have a 2016 MBP13 w/ TB 8GB I5.
    Running the LG UltraFine 5K display. Previously I was using the 4K one as well.
    I had very many issues originally with Explorer freezing, black screen flickering, no logins, slowness etc. Some of these issues were resolved with a reinstall of the OS but then they came back. Lately I've been using the Apple Hypervisor setting, 4GB ram, 1 full gigabyte of VRAM and there are no black screen / flicker / windows explorer issues.

    What I can tell you with certainty is that the parallels video driver scales atrociously. I can run both screens (MBP internal + 5K) in coherence and it's fine as long as your windows 10 applications do not use up a lot of screen real estate. (I am running in "best for retina mode") If however, you full screen something on the 5K display it can take forever to redraw itself. I have operations that take milliseconds natively (such as switching a tab on my complex Windows Forms application .NET 4.6.2) but this same operation can take over a minute when my application is full screen (in coherence) on the 5K display.

    This is reproducible even without using full screen (in coherence), just by covering up more of the screen with windows 10 windows or by enlarging some of them. The scaling is definitely not linear.

    I'm hoping the parallels team will buy a couple of these high res displays and re-write the graphics drivers. Full screen without coherence is also not good performance wise. A windowed (non-fullscreen) approach works really well, but that's obviously because it's not pushing this many pixels.

    In a nutshell, try 1GB of VRAM.
  4. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Hi @DerekL1,
    If there's a possibility of this, please download and run a test environment to check if the issue occurs there.
  5. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Hi @DerekL1, you may also try switch between graphic cards available on your Mac by following the instructions:
    1. Launch the System Preferences app on your Mac and open the Energy Saver preference pane.
    2.Locate the Automatic Graphics Switching checkbox at the top of the preferences pan you see and add a check mark to toggle it on, or remove the check mark to toggle it off.
    Note: The changes are going to take effect immediately after you make your choice. You don't need to restart your computer.

Share This Page