Screenshot tool not working

Discussion in 'Parallels Toolbox for Mac' started by AlessandroM3, Aug 29, 2018.

  1. AlessandroM3

    AlessandroM3 Bit Poster

    Messages:
    4
    Hi there,

    just installed (removed and reinstalled) the latest version of Parallels Toolbox 2.6.1 but the Screenshot tool doesn't work. The screenshots taken are actually blank.

    I select the Screenshot tool for Capturing an area, I select the area, I click on the Area, the file gets saved on the HD, when I open the file it's actually blank even though the file size is not 0. I tried to open it with different apps, but none is able to show anything.

    how can I fix the issue? the tool is useless this way...

    Thanks,
    Alex
     
  2. Dmitry@Parallels

    Dmitry@Parallels Parallels Support

    Messages:
    461
    Hi @AlessandroM3, sorry to hear that. Can you please send us a technical report via Parallels Toolbox menu > cogwheel > Help > Send Technical Data...
    Please post the report ID here. Also please answer the questions below:
    1. Is there a particular application that you are trying to take screenshot of? Or the tools doesn't work anywhere?
    2. Have the tool been working previously on your Mac?
    Thank you in advance.
     
  3. AlessandroM3

    AlessandroM3 Bit Poster

    Messages:
    4
    Hi Dmitry,

    this is the report iD:273175112
    no particular application, but randomly it works... I couldn't spot any pattern by the way.
    the tool was working since I upgraded to the latest version. I removed and reinstalled but no luck.

    Thanks for looking into this
     
  4. Dmitry@Parallels

    Dmitry@Parallels Parallels Support

    Messages:
    461
    Thanks a lot! I have reported this issue to Engineering Team, once I have any updates I will reply you back.
     
  5. Dmitry@Parallels

    Dmitry@Parallels Parallels Support

    Messages:
    461
    Few more questions:
    1. If you press native macOS keyboard shortcut Command+Shift+4 > then select an area to take screenshot, is the saved image displayed correctly?
    2. Are you using any external displays? If yes, does the tool work without them being connected?
     
  6. AlessandroM3

    AlessandroM3 Bit Poster

    Messages:
    4
    1. yes, the images (took few of them) were taken correctly (tried again in the same time with Parallels Toolbox and again randomly not working)
    2. yes I'm using external display. same behaviour on internal display

    Thanks
     
  7. AlessandroM3

    AlessandroM3 Bit Poster

    Messages:
    4
    I did more tests... it appears that if I disconnect the external display it works fine but if I reconnect the external display, even if I take screenshots on the internal one, it doesn't (pictures randomly blank).
    Sometimes the screenshots are taken but they have the bluish highlighted color on the whole area as if the screenshot took the selected area as well.
     
  8. MarkH4

    MarkH4 Bit Poster

    Messages:
    2
    I am also having this problem. I can narrow it down as follows:
    1. I have two external monitors. Any screen capture (area, window, or full) on the 2nd external monitor always returns blank image file.
      1. File has size and content, 5k, 7k ,or 16k depending (apparently) on captured area size. But opening file shows only a grey background. (File in png).
    2. Screen capture does not work for any application or window on 2nd external monitor.
    3. Screen capture works on Macbook display or 1st external monitor.
    4. 2018 Macbook Pro 15", 2.6 GhzIntel Core i7, 16gb ram.
    5. External monitors connected through Kensington SD5200T Thunderbolt 3 Docking Station.
      1. 1st external monitor is LG Ultra HD, 6720x3780, connected with Thunderbolt3 cable to DisplayPort.
      2. 2nd external monitor is Auria 2560x1440, connected with DisplayPort cable to DisplayPort. 2nd external monitor is rotated 90°.
    I can work around by using one of the other two monitors, but perhaps info may help.
     
  9. Jonas3

    Jonas3 Bit Poster

    Messages:
    1
    I have the same issue.
    One additional Monitor connected via Belkin Dock, MacBook Pro (15 Zoll, 2016)
    The internal Tool of the Mac works, Parallel's tool for cutting an area works randomly, without any visible pattern. The tool that takes complete screen seems to work fine though.
     

Share This Page