Serial ports

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by maxw11, Apr 28, 2021.

  1. SergeyS20

    SergeyS20 Bit Poster

    Messages:
    1
    I have a device on the FT232 chip. When installing the driver 2.12.36.4a on Windows 11 the Virtual Machine Parallels Desktop for Macbook M1, there is no additional port settings tab. Can this be fixed somehow?
     
  2. RichardG17

    RichardG17 Bit Poster

    Messages:
    23
    Yes, I'm afraid that's true. I've been in contact with FDTI support about it, and they gave me yet another workaround that's less drastic than the registry patches described in my December 1, 2021 post to this thread, but still not ideal.

    Go into Device Manager and select Devices and Printers. You should see your device or the USB Serial Adapter for it. Right-click and select Properties. You'll get a dialog box with two tabs. Select Hardware and you should see your COM port in the list. Right click on that and select Properties. That should bring up the familiar Properties dialog that has the Port Settings tab.

    *However*, while this works great for changing the top-level items like baud rate, parity, stop bits, etc., you have to use the Advanced tab to change the COM port name or advances settings like buffer sizes, etc. But when you click on Advanced, you get an error dialog saying you don't have permission to access.

    Poking around in the registry, I found that this is caused by a registry key for the COM port not having an owner, hence no one has permission to use the Advanced tab. Adding an owner fixes this. Here's how I did it: I went into the registry and searched for the COM port name. I had to go past several single-key items with the COM port name until I found one that had two keys, one of which was Properties. I right-clicked on that and selected Permissions. There I saw that there was no owner for the key. Using the Advanced tab, I changed the owner to Administrators and made sure Administrators have Full Control.

    That did the trick. I was able to click on the Advanced tab for the COM port and change the COM port name and other parameters.

    I told FTDI that while this workaround is effective, as is the other one I described earlier for changing COM port names, it shouldn't require patching the registry. Seems to me that the least they can do is make sure that Properties key is owned by Administrators, and really they should fix the absence of the Port Settings tab in Device Manager. At first they pushed back, saying people really shouldn't need to change COM port settings, but I quickly disabused them of that notion, based on my decades of coding communications software and working with serial ports. The support tech agreed with my arguments and said he would take up the issue with the Development team. Keep your fingers crossed. They did eventually respond to my request for signed drivers.
     
  3. JordanD4

    JordanD4 Bit Poster

    Messages:
    4
    Hi there,

    Could you share your process for installation? When I try to manually install the driver it just keeps giving me "Windows was unable to install". I verified that my VID and PID match in the .inf file as mentioned in this document on page 25. Any direction or help would be greatly appreciated! Setup is an M1 Pro Macbook Pro running Windows 11 in Parallels.
     
  4. JordanD4

    JordanD4 Bit Poster

    Messages:
    4
    Hey there, I'm trying to install the driver manually and keep getting this error. Any ideas why this might happen? I checked the inf files and my VID and PID are listed. Thank you.


    upload_2022-3-24_15-53-20.png
     
  5. RichardG17

    RichardG17 Bit Poster

    Messages:
    23
    1) Download the official drivers for Windows ARM64 on FTDI's VCP drivers page: CDM-v2.12.36.4A. Don't use the beta drivers. They require disabling the driver signature security check.
    2) Unzip the driver file. Plug in the USB device.
    3) Right-click on the device in Device Manager and select Update Driver, then select "Browse my computer for drivers"
    4. Browse to the folder to which the driver files were extracted. The folder you want is <path to folder containing unzipped files>\CDM-v2.12.36.4-for-ARM64-Signed-Distributable\ARM64\Release"
    5. Click on Next. That should do it.
     
  6. JordanD4

    JordanD4 Bit Poster

    Messages:
    4
    Ok I feel like I'm crazy but no matter what I do I can't get it to recognize the driver. I've reinstalled Parallels and Windows multiple times. I've tried multiple different types of FTDI cables(all with the VID 0402 and PID 6001). I followed the instructions above after a clean install of Windows. Only thing I can think of is if I have the wrong version of Windows or if they changed something recently? I am using the "Trial" version of Parallels for now because I was hoping to get this to work before I bought it. It's acting like the folder isn't there. Any other ideas? Thanks for the help!
     
  7. JordanD4

    JordanD4 Bit Poster

    Messages:
    4
    Ok I got it working! Apparently the driver has to be on the C drive of the Windows partition and it cannot live in a Mac folder. Thank you for your help!
     
  8. gteague

    gteague Bit Poster

    Messages:
    2
    i can't find where the driver files are. i searched for FTDI in file explorer and nothing. obviously i only use windows for my radio configs and am thrashing around. tks! /guy
     
  9. gteague

    gteague Bit Poster

    Messages:
    2
    nevermind. i downloaded the setup pkg. i went back and found what i think are the loose files zipped up and hopefully i can put 'em where i know where they are! <ggeeeesh>
     

Share This Page