Setting up a stable Win98SE VM in Parallels 6

Discussion in 'Windows Guest OS Discussion' started by ronaande, Dec 25, 2010.

  1. Mick536

    Mick536 Bit Poster

    Messages:
    16
    Hello Ron -

    Thank you for your remarkable expertise.

    I am failing at Phase 1, Step 5. During the setup, an alert came up to remove the floppy disk. I disconnected my B drive, and I presume that is the problem. (Did if mean the A, and how would I have done that?) During the last of the setup the video was jumbled, and I suspected an adverse result was coming. Correctly so.

    What should I have done? And having gone through all the waiting to get to the Control Panel step, is there a way to shortcut the previous, or am I right back at square zero?

    Thank you,
    Mick
     
  2. ronaande

    ronaande

    Messages:
    33
    Hi Mick,

    I am at a conference right now, so it will be a few days before I can look into your issue further. A few questions whose answers may hekp shed light on the problem are: 1) Are you installing from a bootable CD or are you using a bootable floppy? 2) Is the floppy drive you are "disconnecting" a real USB floppy or is it a virtual floppy drive? 3) Is this Win98FE or Win98SE? 4) When the graphics became jumbled and the system froze, did you restart the VM and allow install to recover? Mine froze in a similar way and I needed to restart the VM so install could proceed. Notice that, by recover I mean boot from the HDD, not the bootable CD or floppy. IE, when the system starts, remove the windows boot floppy from the system and, if the system asks if you want to boot from CD, choose "boot from HDD". Install should reload and proceed where it left off if it is killed during the configuration steps.

    Try the notes in #4 abve if you have not done so already. Also note that while 98 is installed, graphics will be jumbled! This will be fixed when you install the Parallels Video Driver in Phase 2.

    Please reply with answers to my questions above if #4 above does not fix your issues. I will then try to hunt down the issue. Maybe we can get it working for you.
     
  3. Mick536

    Mick536 Bit Poster

    Messages:
    16
    Hi Ron -

    Thank you.
    1. I start booting with CD-ROM support.
    2. Virtual floppy drive using freedos.fdd
    3. Since nothing I see says "SE" I'm assuming FE.
    4. I attempt to restart via the HDD. When I look at the "If the network adaptor card is not working with an error that it can't find a free Interrupt Request to use, Windows probably did not install in APM mode as it was suppose to in STEP 4. Check the steps again. " This is where I fail. I've done it several times. Painfully so, as I have to wait out the hard drive checks. I do have to use the B:\ drive as the holder of APMINST.INF since A:\ gets created in the process.

    I've never gotten to the step where I attempt the fix of the garbled video.

    ...Mick
     
  4. ronaande

    ronaande

    Messages:
    33
    Mick: I have tried to duplicate your issues on my system and can't get that behavior. I suspect the system is not seeing the apm setup file on the floppy drive. The only idea I have, which I suspect you have already ensured was done correctly, is to change the "a:\" drive letter to whatever floppy drive letter contains the APM file. In your case it will probably be the "b:\" drive since you are booting from CD. As you have seen, windows 98 creates a virtual drive "a:\" with a dos boot disk.

    If you have done this, I really don't know what the issue is. If you have any updates, feel free to post them. If I notice this behavior in the future, I will let you know. Sorry for your issues with Windows 98.
     
  5. TonnyC

    TonnyC

    Messages:
    3
    Thanks for your instructions. What I did to work around it was to copy the .inf to a Windows boot floppy (image). Then use that floppy to boot Parallels with the CD inserted Pandora Beads Sale.
     
  6. Jrh68uk

    Jrh68uk

    Messages:
    31
    I finally have sound! And semi-reasonable video. This is Win98SE under Parallels 6.

    Firstly, the video problems. I'm using the driver from prl.tools.other as mentioned in several places, which is fine apart from the fact that, once a DOS session is opened (including the video bug workaround as documented by Parallels themselves), video and mouse performance take an unacceptable hit. This has been mentioned previously in this thread, with the suggestion that the workaround .bat file is run manually, just before shutdown in order to avoid the hang. This is fine, as long as no other DOS sessions are run. I have found, though, that the workaround .bat link can be placed in the startup folder and the resulting performance lag can then be fixed by opening a window such as My Computer or My Documents. Crucially, this only works up to a colour depth of 16 bit: 24 bit colour depth does not respond to this.

    Now, sound. I found some old drivers for AC97 which can be found by searching on K9YT01A. Driver version is 10th December 2001. When installing you are presented with three versions; I chose the first Intel one. result: sound works with no apparent problems.

    Now, all I need to do is figure out how to free resource for the network card to work without using the APM vs. ACPI method as described earlier. I basically need to free IRQ7 which is held by the LPT port, which I don't even need. I have tried disabling the port in Parallels but it won't release the IRQ.
     
  7. Jrh68uk

    Jrh68uk

    Messages:
    31
    OK, I have the network card working fine now. All I did was to remove (not just disable) the LPT port in the configuration for the VM. That is, select the port and click the "-" at the bottom to totally remove it.

    So, after updating IE to v6 SP1 from an old PC Pro disc, I was able to get all the security updates and some others (DirectX 9c, Media Player 9...) from Windows update. Just to be on the safe side, I've disconnected networking now from the config.

    The video driver bug is unfortunate as I don't see any way to correct it fully. The documented workaround is all very well, but it's still annoying every time a DOS session is started for whatever reason as everything slows to a crawl. Making the DOS session itself full screen fixes that for the session itself but when returning to Windows a window such as My Computer needs to be opened again to fix the crawling speed.
     
  8. ronaande

    ronaande

    Messages:
    33
    Jrh68uk:

    Thank you for posting your fixes, as they seem a lot simpler than the original methods I pointed out. Since my system is working as I need it, I have not tried them myself.
     
  9. Jrh68uk

    Jrh68uk

    Messages:
    31
    Update: After migration from v6 to v7 I see that the choppy performance part of the video bug I mentioned earlier has now gone!

    The main video bug workaround still needs to be done (i.e., opening a DOS session full-screen at some point, otherwise Windows will hang on shutdown) but the performance hit no longer occurs. Much better.
     
  10. Todd Banister

    Todd Banister

    Messages:
    7
    Just wanted to say thanks a TON for all of the assistance in this thread. It was invaluable to me in getting my Win98SE VM working. Everything is working (audio, video, networking, etc) except for the hanging on shutdown. Did anyone find a way to cure this?

    I've done this install a couple of times on my own and the disk scan takes upwards of 1.5 to 2 hours to complete. This is a crazy waste of time. So I started poking around and found a way to skip this part of the Win98 install.

    In the step where you drop out to Dos and issue the setup command, I simply used the following instead:
    Setup /is b:\apminst.inf

    Obviously the b:\ is due to that is where my floppy.fdd mapped itself that contained the apminst.inf. The secret to saving time on the scan disk part of the install is to use the /is switch on the setup. I've tried it and it works like a champ.

    Thanks again for everyone's help.
    TB
     
  11. davidlones365

    davidlones365

    Messages:
    5
    Scrambled Startup???

    The first thing I get when I start up my VM, after the Windows boot screen, is the image shown below, and occasionally I'll loose control of the curser (it just stops responding) and I have to manually shut down/restart the virtual machine using either the keyboard or the Parallels shortcut from the host. How do I fix this????
    [​IMG]



    (Also, is there a way to set up folder sharing between the VM and the host?)
     
  12. ronaande

    ronaande

    Messages:
    33
    Hi David:

    The scrambled screen you posted also appears on my VM. It goes away after 10 seconds or so however. I assume yours just hangs indefinitely?

    Also, since Parallels tools are not available for these legacy OSs, I don't believe you will be able to set up a folder share in the way you suggest. You can, however, mount the HDD while the VM is off and copy files to it.
     
  13. davidlones365

    davidlones365

    Messages:
    5
    Ron,
    Yes, it disappears after a few seconds for me too, but coupled with the "loosing control of the curser" issue I also have, it just worries me. I've only recently switched to Parallels, Windows 98 worked relatively perfectly (after a few adjustments) on VMware Fusion. If fact, I'm currently using Parallels strictly for newer OS's and VMware for legacy OS's.

    Also, I can't figure out how to get the WIN98 virtual disk to mount to the Mac. The only way I can transfer data to and from the VM is to use a million virtual floppies!
    (Something else VMware seems to do better: I can just drag and drop stuff back and forth at will, even in Windows 98!! Sorry to sound like I'm advertising, but legacy OS's have become sort of a hobby for me and I would prefer using only one virtualization client!)


    Edit:
    VMware Fusion also does not seem to allow for folder sharing in Windows 98, but, as said, they do allow for drag-and-drop. The lack of folder sharing is likely just simply not possible with older OS's. Most everything else is, however. Even the "auto-sync VM resolution with the window size and when in full-screen mode" feature, works in VMware! The only thing I really had to add manually was sound. :|

    Of course, other advanced "ascetic features" like "coherence" also aren't supported in VMware for older OS's. ...I personally wouldn't use "coherence" with a legacy OS anyway, but skipping out on basic expected functionality for a supposed "supported" OS feels almost like false advertising!!! Even VMware Fusion's actual "support" for their "supported" OS's stops at Windows 98!

    (...my little rant is over. We can return to my original issue involving the scrambled startup and the curser. Sorry.)

    Edit:
    ...also, occasionally when I attempt to shut down, it just hangs on a black screen (I've let it go on for hours just to see if it would continue with the shut down on its own, it never does) and I have to manually stop the VM, resulting with a disk check at the next boot. (Oddly enough, when the VM has to run a disk check at startup, I never get the scrambled image like shown before. ???)
     
    Last edited: Nov 18, 2011
  14. CasmirV

    CasmirV

    Messages:
    2
    Hi. I am trying to get Windows 98 SE to work to run some old DOS games without using DOSBox because I hate putting in the code to run each game.

    In Phase 1, step 2, however, the link to get apminst.inf from the Lenovo URL you linked is no longer possible since that URL just leads you to the Lenovo support homepage.

    Any help? Anywhere else I could find this file?

    Thanks for the great guide, btw. You really shouldn't have to do this... Parallels support is god awful.

    Also, if I ever do get the file, how do I turn it into a bootable, floppy disc file?
     
    Last edited: Dec 23, 2011
  15. Runefox

    Runefox

    Messages:
    1
    This is a bit of a thread necro, but I've got some new info for anyone who might be looking to get a Win9x VM up and running like I was recently.

    First off, the steps described in this thread all work fine with Parallels 7.

    Secondly, When using both the printer (LPT port - Remove the printer device from the VM if not needed) and network simultaneously, you'll normally find that they conflict with one another, and you lose network access. All that needs to be done to get around this is to add a second network controller to the VM's config. The first one will continue to conflict with the LPT port (which works), but the second will be on a separate address and happily provide you with network access. This way, I get my Mac OS X printer and internet access, which when combined with everything else in this thread equals a fully functional Windows 98 VM!

    Finally, the apminst.inf file can currently be obtained at http://support.lenovo.com/en_US/detail.page?LegacyDocID=MIGR-4K4PWX
     
    Last edited: May 23, 2012
  16. lotw

    lotw Product Expert

    Messages:
    158
    I got everything working but sound without most of those steps you talk about. Installation and Video worked, but got the black screen of death at shutdown but thanks for that fix. Remove the LPT Printer port before installing and it will save you a bunch of problems.

    Here are the steps I used to get a decent working copy of Windows 98SE running under Parallels 7.

    1. Create a new virtual machine, edit settings before running to remove LPT port (or no network access).
    2. Install Windows 98SE as normal.
    3. Download the unofficial Service Pack (current version is 2.1a) http://www.softpedia.com/get/System/OS-Enhancements/Unofficial-Windows-SE-Service-Pack.shtml
    4. Download the USB patch that was mentioned. http://www.technical-assistance.co.uk/kb/win98se-usb-mass-storage-drivers.php
    5. Create a Windows ISO CD-ROM of those two files using any Disc burning software for your Mac or Windows.
    6. Boot Virtual Machine, copy both those files and your Parallels tools to HD and re-mount your Win98 or insert CD.
    7. Install the Unofficial Service Pack, follow instructions. (Will reboot)
    8. Install USB fix
    9. Right click on My Computer, properties. Select device manager, display adaptors and update driver, select other locations and tell it where you put the Parallels tools, drivers, video.
    10. Do the Black screen of death patch, creating that batch file as he described.

    You now have everything but sound working as good as it can until Parallels fixes or makes it not work at all.

    I will try getting sound to work easier.
     
  17. Craig&

    Craig& Bit Poster

    Messages:
    1
    Just wanted extend thanks to Ron. Had a need to install 98 on PD7 and this guide worked - incl. sound and USB support.
     
  18. RobbertB

    RobbertB

    Messages:
    8
    Hi guys, I just wanted to ask, do you know where I can find a dutch version of nusb33? I have the dutch Windows 98, and really want to keep that because it's my native language and I FINALLY got sound working.
     
  19. stscswimguy

    stscswimguy Bit Poster

    Messages:
    1
    Win98FE Sound

    Hello all. This post looks to be spectacular; thanks for all your hard work. Unfortunately, I neither have Windows ME to get the requisite system data or Windows 98SE (using first edition) to take advantage of the sound patches/installers that everyone mentioned. Any advice?
     
    Last edited: Dec 28, 2012
  20. mr_q

    mr_q

    Messages:
    26
    Some one simply needs to post a working PVM for Win98

    I have been trying for three hours to get this running. I hit wall after wall with it. I've followed the instructions TO THE LETTER. Maybe it's because, now, it's years later from when this post was made, and things have changed.

    I am running OSX Lion, P9, so things don't work as described.

    I WAS able to get Win98 up and running and get the video working using the help provided by Parallels. But my network card is still in IRQ hell and USB and Sound are hopeless. I nearly got sound working following this guide but ran in to the wall of getting the needed files IN TO the WIN98 install. With no network support I had to rely on image files. I tried FDDs, IMGs, CDRs, all the various ways to get files in to the Win98 install and for reasons unknown the files wouldn't show up or Parallels would think the FDD I made was bogus.

    Again, WALL AFTER WALL.

    SOLUTION:

    Some who has a working Win98.pvm with all these hacks in place needs to upload it. MS no longer supports Win98, Parallels doesn't support it, the users need to step up. BELIEVE ME...if I had one I'd post it. HAPPILY to spare others from this hell.
     
    Last edited: Oct 6, 2013

Share This Page