Shared Folder \\.PSF\.Mac is not accessible

Discussion in 'Parallels Desktop for Mac' started by astraldoculous, Apr 3, 2007.

  1. astraldoculous


    I'm running Parallels build 3188 on OS X 10.4.9, and am getting the above error when attempting to view my Parallels Shared Folders on an XP SP2 virtual machine. This happens after showing me the connected shares:


    If I bring up the Parallels Shared Folders window, then double-click on .Mac, I get the following error:
    \\.PSF\.Mac is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

    The filename, directory name, or volume label syntax is incorrect.

    I've uninstalled Parallels Tools, rebooted, reinstalled the tools, then rebooted again. Still the same issue persists. For what it's worth, Coherence mode works fine. Just the shared folders and drag and drop to the desktop both are not working.

    Can anyone think of where to begin looking? Thanks.
    Last edited: Apr 3, 2007
  2. dkp


    Sharing is disabled by default in version 2.5 of Parallels (build 3186, 3188). Even if it was enabled prior, it will be disabled after an upgrade. That's probably my fault, but I'm ok with it. Before starting your VM you will need to enable sharing in the Parallels configuration editor. If you've already done that then suspect your Parallels Tools installation.
  3. astraldoculous


    Both shares are configured with Global and Local drag-and-drop options. I'm logging in to the VM as a local admin and domain administrator, neither seems to make a difference.

    If the issue is with the parallels tools, where would I look to begin troubleshooting? I've tried reinstalling the tools once. Is there any additional logging that can be enabled?
  4. alexg

    alexg Parallels Developers

    To fix the problem do the following:

    1. Uninstall Parallels Tools using Add/Remove Programs control panel.
    2. Reboot Windows.
    3. Open Windows/System32/drivers and remove prlfs.sys driver if present.
    4. Install Parallels Tools using Install Paralllels Tools... menu item in the Action menu of the Paralels Desktop application.
    5. Reboot Windows.

    Best regards,
  5. astraldoculous


    After uninstalling the tools, I do see prlfs.sys in \windows\system32\drivers. I've removed this file, then rebooted, then installed parallels tools fresh (actions -> install parallels tools). I'm still getting the folder not accessible error.

    Do the shared folders use a network connection to the host, and is there something I can check (aside from the Shared folders configuration), to confirm that the host working properly?
  6. wgdixon


    Just chiming in so Parallels support knows there's others out here...I tried the exact same sequence for the exact same problem...does not work. I have another VM of WinXP where sharing does indeed work. Yet another Parallels flake?
  7. Hugh Watkins

    Hugh Watkins

    you should know more than me Alexander

    BUT when any support on any site (especially AOL) says reinstall and reboot twice
    I suspect someone is missing the obvious

    first try

    PD >> Menu >> Devices >> Shared Folders >> Add

    it worked for me

    go in via user name and to the mac desktop

    also each USB / fireware HD in turn
    From WInXP sp2 it works well

    going in from the file menu of any application and browsing

    please post the results here

    Hugh W
  8. astraldoculous


    My shared folders are created with the following paths, and they're connected, as I can see them in the Parallels Shared Folders window in the VM:
    /Users/name (home, read-only)
    /Users/name/Documents/Shared (home-shared, read-write)

    My drag-and-drop settings are configured as follows:
    Global (enabled)
    Local (enabled)

    I can't browse \\.PSF\.Mac from the XP VM: the share is not accessible, and I have the same problem reaching the 2 configured shares. In addition, drag-and-drop isn't working between the VM and the OS X host.

    Not sure what else to do, I'm hoping someone can give a pointer or two as to how Parallels communicates with the host, and whether there are any steps I can take to enable logging and test. At this point there seems to be nothing I can do besides reinstall the VM, which unfortunately, isn't an option for me currently.
  9. dkp


    Is the /Users/name folder the same user as you are running Parallels as?

    Sidebar discussion: Just a suggestion, but were it me I'd be sharing a subdirectory of /Users/name rather than the user's entire home directory. If you ever get a Windows virus it can raise hell in that share in ways that are both interesting and unbelievable. But then I'd also shut off global sharing too as it's an even bigger exposure.
  10. astraldoculous


    The home directory is that of the user running the VM.

    Since performing the reinstall above, I'm now able to copy-and-paste to my desktop (with global mode it seems)... just still no access to the shared folders. :|

    Preferably, I'd rather just share a single subdir, not my whole home, but at this point I just want to get there.
    Last edited: Apr 6, 2007
  11. rlockhart


    Same problem with Shared Folders

    I'm having the same problem that is described below. I can see the Parallels Shared Folder when I go into Network Neighborhood and click on Entire Network, but they return the same "not accessible" error as described below.

    I've also tried reinstalling Parallels Tools and deleting prlfs.sys but still no luck. Has anyone from Parallels engineering taken a look at this and tried to figure it out? My Host OS is 10.4.9 and I'm running 3188. Other than this one problem, everything seems to be working just great.


    Ron Lockhart
  12. Hugh Watkins

    Hugh Watkins

    have you guys tried

    PD >> Menu >> Devices >> Shared Folders >> Add

    it worked for me

    this is file on a copy the mac desktop on the firewre external drive


    tis is the orignal copy

    PD >> Menu >> Devices >> Shared Folders >> Add
    gave me total sharing as I wished to have it

    Hugh W
  13. astraldoculous


    Hugh- This is exactly how I created my 2 shared folders initially. To test this further, I performed the above steps for /Volumes and /Users/name (again). While both of these attempts resulted in 2 additional shares (4 total) being visible in the Parallels Shared Folder, I still can't access any of them. When I try, I get the Windows alert, "share is inaccessible," advising to check my file permissions, etc.

    For what it's worth, I'm also not able to use the local drag-and-drop feature (related?). Only the Global drag-and-drop feature works..
  14. Hugh Watkins

    Hugh Watkins

    when you get the error
    what route are you using into the shared folders ?

    from WinXp sp2 desktop by double clicking Parellels Shared Folders
    short cut to \\.psf

    \\.PSF\all\Desktop is the mac desktop not including the macintosh HD and external mounted volumes

    \\.PSF\Macintosh HD is the HD
    gooing deeper
    \\.PSF\Macintosh HD\Users\hughw36\Documents\Family History\Bennett

    windows explorer
    my computer
    file menu of which application (s)?

    I remember seeing the error message you describe about two betas back and getting rather frustrated until I discovered how to use

    Mac Menu >> PD >> Devices >> Add

    sorry I can't help more

    Hugh W
  15. astraldoculous


    Well, I have a case of inexplicable success. When attempting to access the share \\.Mac\name, I'd see that the share is inaccessible. At the same time, I'm noticing the following failure event in my security log:

    Event Type: Failure Audit
    Event Source: Security
    Event Category: (2)
    Event ID: 537
    Date: 4/11/2007
    Time: 7:18:57 PM
    Computer: NAME-WXP
    The description for Event ID ( 537 ) in Source ( Security ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: name, COMPANY, 3, Pª, NTLM, NAME-WXP, 0xC000006D, 0x100010.

    While this happens every time I bring up the shares, things are working overall.

    Prior to this working, when I'd attempt to browse \\.Mac\all\Desktop, instead of the inaccessible share, I'd get receive an authentication prompt. No matter what username/password I'd enter, I couldn't get authenticated to this share.

    Today, I've upgraded my JRE from version 1.4.2_03 to 1.4.2_05, and also installed PGP Desktop v8.1. Lastly, I changed my domain password and rebooted the VM. When it came back up, I was suddenly able to access all of the Parallels Shared Folders (including \\.psf\.Mac).

    I'm still seeing the failure entries in my security log, one new entry appears each time I open the shared folders, however, overall, the PSF seem to be working now.

    Still, I should not be seeing authentication failures in the security log. Why does Parallels cause this?

Share This Page