Shared Folders won't work in Build 1884

Discussion in 'Parallels Desktop for Mac' started by joelwnelson, Sep 7, 2006.

  1. joelwnelson

    joelwnelson Junior Member

    I just upgraded to the newly-released Build 1884 and am now having trouble using shared folders. Once I connect to a shared folder from XP SP2 in Parallels, I have about 15 seconds to finish up what I am doing before I lose access. I have to reboot XP to have another 15 seconds of access. It worked fine in 1862.
  2. rjbailey

    rjbailey Member

    Did you reinstall Parallels Tools? Before I do the upgrade I'd like to know if that fixes your problem.
  3. nertzy

    nertzy Bit poster

    I am having the same experience. I am otherwise able to use the bridged network connection. I can browse any external website, and get at servers internal to my office network.
  4. dmacd

    dmacd Junior Member


    I also noticed that shared folders seem to fail. I did re-install Parallel Tools when installing 1884. All my data is on a shared folder so I have gone back to 1862.. They started working again in 1862.
  5. j-active

    j-active Member

    I am seeing this also. When I click on Parallels Shared Folders, I see the shared folder where my docs live. Clicking on the shared folder results in "The System cannot open the file." I can't access my data at all. :eek:

    Where can I find a previous version of the tools?
    :dead in the water until I can access my data:
    Last edited: Sep 7, 2006
  6. nertzy

    nertzy Bit poster

    I was unable to install the Parallels tools at first. The disk image for the tools installer failed to load.

    So I downgraded back to 1862.2 which I had installed before (the version that was released just here on the forums). I was able to reinstall the tools there, where I realized that I had 2.2.1848 of the tools installed. That brought it up to 2.2.1862.

    I then reinstalled Parallels Desktop 1884 and was able to upgrade the Parallels Tools to 2.2.1884, but the problem still persists as described. I'm using bridged connection to my en0 wired port on my Mac Book Pro 17"
  7. rangr

    rangr Member

    i get the message "folder is not accessible. You might not have permission to use this network resource...etc... The system cannot open the file"

    tried deleting the old folder in the VM settings, and recreating a new folder name, but same message...

    can we have access to the older build? i need to get this up and running again ASAP.
  8. PubGuy

    PubGuy Hunter

    Well, my Shared Folders is working.

    I installed the beta, then rebooted the Mac.
    I then loaded PW.
    Loaded my previous image.
    Installed the new tools.
    Shutdown the image.
    Then restarted the image.

    Wow -- it boots a whole lot faster !!!

    My shared folders work. I can make copies of files.

    Problem: I can no longer work on the file from the shared folder. I have to copy the file to the image first, work on it, then copy it back (just like with Virtual PC). I hope this is just a bug that needs fixing, cause I sure liked being able to work directly in the shared folders.

    PS: Just found this out. If you MAP the network drive to the Shared Folder, everything works flawlessly. I've a TEMP directory on the Mac shared as Mac_Temp. When I mapped this to Drive "T" on Windows, the files worked exactly as expected. Perfect !

    Build 1884 -- MacBook Pro -- 1 G -- 10.4.7 -- Win XP SP2
    Last edited: Sep 7, 2006
  9. unused_user_name

    unused_user_name Pro

    I second this opinion, even though this could cause strange file integrity issues if used improperly.

    Parallels people: I understand why you changed this, but can we have the old functionality as an option (under a scary looking "advanced" tab perhaps) ?
  10. j-active

    j-active Member

    Shared folders is now working.

    Let's see what did I change...

    I was going to uninstall the latest build of Parallels Tools and reinstall a previous build. I noticed my CD wasn't connected, so I shutdown the guest OS (WinXP) and changed the settings to attach to the iso of the current tools in my Library.

    Rebooted and decided to check one last time before I uninstalled. works.

    I guess threatening to uninstall with the CD image loaded was enough to scare it?

    Shrug. :cool:
  11. rangr

    rangr Member

    tried mapping the folder as a drive, but it has the same problem. works for a few seconds then decides that the files are no longer accessible.
  12. PubGuy

    PubGuy Hunter

    Try this:

    1) Shutdown Windows (Start Menu -- Turn Off Computer)
    2) Quit Parallels.
    3) Reboot the Mac.
    4) Start Parallels.
    5) Start Windows.
    6) Install the Tools.
    7) Restart Windows.

    Now try the Shared Folders. If it still gives you trouble, try deleting the shared folders and re-mapping them.

    As I said, seems to be working fine for me.
  13. rangr

    rangr Member

    Have tried exactly what you say.

    I get the shared folder to work (whether directly or via Map) only for a few seconds. They then become inaccessable.

    have also tried reinstalling the parallels RC update, uninstalling tools, restart VM, reinstalling tools, but same problem.

    parallels, any chance you can post a link to the beta 1 update ? while this gets sorted out, i really need to get back to work!

    PS I've found a way around it. Mapped a network drive using the \\server\\name address provided by system preferences in OS X, when "enable windows sharing" is turned on in the "sharing" control panel. works just fine.
    Last edited: Sep 7, 2006
  14. rjbailey

    rjbailey Member

    Just installed new release, and no problems as documented above.
    1. Shutdown VM
    2. Uninstalled existing Parallels
    3. Installed new RC
    4. Booted VM, installed Parallels tools
    5. Restarted VM

    MBP, 2GB
  15. joelwnelson

    joelwnelson Junior Member

    Yes, I reinstalled Parallels Tools after the upgrade.

    That is the same problem I am having.

    I finally found a workaround... burn a CD-RW with the shared folders on it and import them into the VM. Not the way I want to keep doing things, as I have a bunch of websites saved in ~/Sites on OS X but access them from Dreamweaver on the PC side, as Dreamweaver 8 works better in Parallels than in Rosetta.

    Also, I have noticed that MSIE 7 will open .html files on Parallels Shared Folders but not on mounted network drives. Don't know if that's normal or not, but it seems weird. That is not a new problem.
  16. mqandil

    mqandil Member

    I have the same problem, and I have tried all suggestions mentioned, and yet I am not having any luck. Can we get a link to previous build. This one needs to be fixed.

  17. BenInBlack

    BenInBlack Pro

    Brute Force Shared Folder Reset

    Ok,I know you said you tried them all, but im going to give you steps i did when beta 1862 came out

    1. start VM (Windows Presumably)
    2. goto control panel and under add/remove programs remove parallel tools
    3. after removal shut down Windows back to Guest Configuration screen.
    4. click on edit
    5. click on Shared Folders
    6. click on all shared folder definitions and click the - (minus) to delete them
    Note. this only deletes the definition in parallels, the contents of the folders on Mac are still there.
    7. Click Ok
    8. Click Save
    9. Close Parallels (click on X)
    10. Restart Parallels, when Guest Config screen show up, click on edit button
    11. click on Shared Folders
    12. click on + and add new shared definision, but this time change the name slightly from what you had prior
    13. after your done with shard definitions click OK
    14. Power up the VM
    15. After Windows is completely started. click on top menu VM and re-install parallel tools
    16. After tools are installed you should Restart Windows
    17. Now try shared folders

    If this doesn't do it for ya, then there is some other issue.
    I have updated to 1884 and have 0 issues with Shared Folders

    I Hope this helps someone ;-)
  18. adiemask

    adiemask Junior Member

    Not at home at the moment and don't have access other than this forum. This new build is news too me as of this morning. What does it offer over the last build is usb any better, are the graphics any better?

  19. manfredell

    manfredell Hunter

    I also have BIG problems with shared folders. Upgraded to the new version and installed new Tools.
    All OK.
    But now I get errors when opening the shared folders or blue screens....

    restoring previous Parallels version and backups of disk images. All well.

    Guys!! You introtuced new bugs in this version!!! Anyone from Paralells reading this thread????

    Data is at stake here!
  20. manfredell

    manfredell Hunter

    Just got it working:
    restored old Parallels version and drive images.
    Booted into windows, removed Parallels Tools via add/remove.
    shut down windows.
    deleted the shared folders from the Paralells definition.
    Installed the new paralells version.
    started windows vm.
    installed the new parallels tools.
    shut down vm.
    add old shared folders.
    restarted vm.
    all ok.

    There's one lesson to learn here:

    Before installing a new version, keep the old one so can downgrade and MAKE A BACKUP of the Parallels folder with the drive images!!!!
    Last edited: Sep 8, 2006

Share This Page