Shared Folders won't work in Build 1884

Discussion in 'Parallels Desktop for Mac' started by joelwnelson, Sep 7, 2006.

  1. rangr

    rangr Member

    BenInBlack, tried your suggestion to the letter. the shared folder worked initially, then i got the same error.

    so it's still an issue....
  2. valkraider

    valkraider Junior Member

    I am having the same problem. Shared folders broke with 1884.

    This ruins Parallels for me...

    Downgrading to 1862 fixes them. Definately something wrong with 1884...

    Until then, I will stay at 1862.
    Last edited: Sep 8, 2006
  3. rinconj

    rinconj Member


    I've gone back to 1862. The shared folders might be available on 1884 for a few seconds after a fresh start, but it doesn't last long and it's just too much trouble to deal with it.
  4. rangr

    rangr Member

    i don't have access to the previous build, but have found that running a backed up (1862) version of VM-- ie the 1862 version of parallels tools-- work just fine. no shared folder problem.

    so i guess it's just a matter of waiting for the next version of parallels tools....


    oops spoke too soo. same problem with 1862 parallels tools on next startup. i guess it has to do with the application build.
    Last edited: Sep 8, 2006
  5. rhsauer

    rhsauer Bit poster


    I also found the the latest RC1 broke my ability to use Parallels' Shared Folders, but was able to work around the problem by using a combination of (i) permitting Windows Sharing in the Mac OS, and (ii) using Bonjour under Windows, all as further described here:

    Generally, folders made available in this way are much more responsive than Parallels' Shared Folders were in the last Parallels build, but I have also read (see the link above) that this workaround opens up a security hole. If anyone has any thoughts as to how to close that security hole, I'd appreciate the education.
  6. garyaj

    garyaj Bit poster

    Was having problems with shared folders becoming unreadable. Thanks to this forum I realised I forgot to install Parallel Tools. Installed, all problems gone away. This is an excellent update. (I can even get my Sony HD Minidisc recorder to work with Sonic Stage via USB. All my outstanding issues are now solved.)
  7. joelwnelson

    joelwnelson Junior Member

    Does anyone have a download link for the previous version of Parallels Desktop?
  8. mqandil

    mqandil Member

    Hi Ben
    Thank you for the detailed response and all the help... Much appreciated. I did follow your steps exactly, but still no go. I did find a copy of the previous build in my back up, and I reloaded and everything works now. Something in this latest build is preventing the access to the shared folders, and hopefully they will fix soon. Until then we will run the 1862 build until it is fied. Again thanks for all the help, and taking the time to help me out. It seems all guys from WA state are true gentlemen!!

    Vancouver, WA
  9. BruceK

    BruceK Member

    Similar problem here. Shared folders work for an as yet undetermined amount of time and then it suddenly breaks in the middle of an operation such as a save. I can't yet determine an exact failure mode. To restore the Shared folder I have to either restart the Guest OS (Win XP) or completely shut down and restart my MacBook Pro. I don't recall ever seeing this problem under build 1862.

    Farmington NY
  10. David Miller

    David Miller Bit poster

    Yep, that's a useful workaround for this annoying 'shared folders' problem that's arisen since I installed build 1884; thanks. I can see the security problem inherent in giving Windoze network access to your hard drive; but provided you have decent firewall/virus prevention utilities installed on the Windoze partition, the problem is minimised. And of course, it only arises while Parallels is running:D
  11. BenInBlack

    BenInBlack Pro


    Ok, So the issue is, the shared folders are maintaining older definitions that are incompatible with 1884. So I think the new steps for now should be something like this

    Note: do this prior to upgrading to 1884

    1. Backup your current 1862 or prior .PVS and .HDD files
    2. Go into Window and Remove Parallel tools via Add/Remove Programs
    3. Shut Down window and back ath the Guest Configuration and remove the Shared folder definitions
    4. click on the save button to save config as is
    5. install build 1848

    Thanks manfredell
  12. manfredell

    manfredell Hunter


    Can now confirm this. I had initially suceeded in getting this to work (see my above post).

    But now I also find that it stops working out of the blue.

    reverted to previous build and backups.... :mad: :mad: :mad: :mad:
  13. scotymac

    scotymac Junior Member

    Installed the Bonjour, you were correct it is an extremely fast way of accessing the os x side. I felt good enough about it to allow the My Documents files to be moved over to the os hard drive....
    Big mistake, as now I can not access that folder, ie M;\ is not accessible.
    I would like to reinstall 1862, but alas did not keep it. Has anyone found where the old versiion can be downloaded?
  14. PubGuy

    PubGuy Hunter

    I'm not sure ... guess I'm lucky ... my shared folders seems to be working fine. :D

    Is "everybody" have problems, or just a select few? :confused:

    UPDATE: Confirmed: shared folders STOPS WORKING after about 20 minutes of use requiring a reboot of the VM. (build 1884). :mad:
    Last edited: Sep 13, 2006
  15. roadworrier

    roadworrier Junior Member


    I'm having the same problem... shared folders work for 15 seconds then fail.

    I didn't use shared folders under previous revisions, nor did I have the Parallels Tools installed under previous revision of Parallels... So they've never worked for me.

    I don't want to share by IP because I'm DHCPing into various different networks, and get a different IP each time, so I'd really like the shared folders to work.
  16. Wonni

    Wonni Bit poster


    I had the same problem, but it starts after my switch from half duplex mode to full duplex mode in the preferences of network adapter in Parallels. After I stwitched back to half duplex it works good with no problems ...

    A other way to fix it is to install the old network driver from Build 1862.

    1. Stop the VM and close Parallels
    2. Install the old 1862 Build
    3. Copy the vmtools.iso from /libary/parallels/tools to desktop for example
    4. Rename the vmtools.iso to vmtools1862.iso
    5. Install Build 1884
    6. copy the vmtools1862.iso to /libary/parallels/tools
    7. start the VM
    8. conect the vmtools1862.iso into the dvd drive
    9. go to control center - network adapter and reinstall the older network driver
    (date 08.08.2006), but the version number is the same from the new 1884 version

    That´s it
    Can someone confirm that?

  17. itsdapead

    itsdapead Hunter

    It seems to be working for me (so far so good) - I'm running on a fresh install of 1884, with a Mac Pro (baseline, plus 1 extra hard drive) and Win2k SP4.

    My network appears to be behaving itself too (fingers crossed).
  18. manfredell

    manfredell Hunter

    Can you please explain what you mean by that. I cannot find any preference in parallels relating to half/full duplex??
  19. roadworrier

    roadworrier Junior Member

    I tried the various suggestions to get things working with 1884, but went back to the official release 1848 and now everything works again. (I don't have 1862.iso to try installing that network driver)
  20. Andrew @ Parallels

    Andrew @ Parallels Parallels Team

    Thanks for reporting! We reproduced this problem and provide you with a fix soon.

Share This Page