Shared Networking not Working! No Internet

Discussion in 'Windows Guest OS Discussion' started by shawnp, Feb 7, 2010.

?

What Networking Connection are You Using

  1. Shared Networking (same as Mac)

    66.7%
  2. Bridged - Default Adaptor

    22.2%
  3. Bridged - "other" (Airpot / Ethernet)

    11.1%
  4. Host-Only (maybe with Internet Sharing)

    0 vote(s)
    0.0%
  1. shawnp

    shawnp

    Messages:
    4
    This has been painful. My internet connection on the Guest Windows side stopped working. I was using Parallels 4. I reinstalled Tools, to no avail. I rebooted tons of times, both Mac and VM. I even went back to a Snap Shot and it worked at first. Then after VM reboot, the internet stopped. I assumed it was product bug so I went so far as updating to Parallels Desktop 5. Yeah same problem remained!

    I have read all the threads and tried what I think is everything:
    * Attempted to uninstall the Network Device on Guest OS - the VM does not like this. It typically fails.
    * Re-created a network adaptor from the Parallels Configuration. Does nothing.
    * Hard coded and went with DHCP on Mac Network side for the Parallels Guest Ethernet Adaptor #0.
    * I even SAFE-MODED it and remove all network devices. When reboot it works until next boot.

    By not working I mean the Network device shows the Parallel Ethernet Adaptor. The networking control panel shows the "enabled" adaptor connector to a local area connection. The status is connected. But zero packets are move in or out. And if you click repair - it fails immediately saying no TCP/IP connection. >ipconfig /all returns nothing.

    I would not be surprised if there is something on Mac side I need to tweak, but I don't know where to start.

    I am running 10.5.8 with Parallels 5 for Windows XP.
     
  2. Elric

    Elric Parallels Developers

    Messages:
    1,655
    It may be WindowsXP problem, try to reset TCP/IP:

    To do it, please open Command Prompt in Windows (Start > Run.. > type 'cmd' > OK)

    And enter following command:

    netsh winsock reset

    Restart Windows and use next command:

    netsh int ip reset reset.log

    Restart Windows once again.
     
  3. shawnp

    shawnp

    Messages:
    4
    This worked! You are a God-send. Thank you and everyone should be aware of this.
    I spent an entire weekend day fooling with this and it was that easy.
    All Hail - the Parallels Forum / Team!

     
  4. shawnp

    shawnp

    Messages:
    4
    This worked wonderfully. Thank you so much for that advice.
     
  5. Elric

    Elric Parallels Developers

    Messages:
    1,655
    Glad to hear that issue is solved -)
     
  6. ShahryarR

    ShahryarR

    Messages:
    7
    what about certain subdomains? is that a virus or something? for certain sites, a subdomain works while another doesn't. But they all work fine on the host Mac OS X. Anyway to fix that? or do I just have to delete and make a new parallel image?
     

Share This Page