Shared Networking very slow with Windows 10 guest

Discussion in 'Windows Guest OS Discussion' started by ErikG, Nov 25, 2017.

  1. kuykendc

    kuykendc Bit Poster

    Messages:
    5
    I know I'm kind of late to the party here but didn't want to start another thread on this subject. Seeing same issues... Windows 10 Guest OS with latest updates running under macOS High Sierra 10.13.6. Seeing horrible network speeds from the Win10 VM. Host machine is connected via 1GB ethernet. Running an iPerf3 test to a local server from the macOS side of things I'm seeing 940 Mb/s speeds (screenshot 1 below). Running same test from the Windows 10 Guest OS I'm seeing 1-2 Mb/s speeds (screenshot 2 below). If anyone has any ideas/fixes for this it would be greatly appreciated as this makes running the VM under parallels almost unusable.

    Screenshot 1 (macOS Host OS):
    [​IMG]
    Screenshot 2 (Windows 10 Guest OS):
    [​IMG]
     
    Last edited: Aug 24, 2018
    DaniT likes this.
  2. DaniT

    DaniT Bit Poster

    Messages:
    6
    [QUOTE="kuykendc, post: 843070, member: 2046"
    Hi,
    Your not late, after 6 months of frustration with the lack of support from @parallels I've just given up! My Windows machines have just became useless. I won't be renewing my account. And this is from someone who has been using Parallels since it's early beta versions!!

    Shame a great company ruined by terrible support since the last year or two.
     
    Last edited: Aug 15, 2018
  3. SiaB

    SiaB

    Messages:
    1
    Network Conditioner worked for me with the same issue as described above. Since nobody added it yet, to turn this on go to Parallels/Actions/Configure/Hardware/Network then there is a checkbox for Network Conditioner.
     
  4. DaniT

    DaniT Bit Poster

    Messages:
    6
    For me and others who posted here, network conditioner only improves things for a short duration after which, network slows down again.
     
  5. Elric

    Elric Parallels Developers

    Messages:
    1,667
    Hi,
    Take a look at VM Configuration -> Options -> Optimizatioin -> Resources usage
    Networking throughoutput is strictly limited when slider is not set to "No limit"
     
  6. BradS7

    BradS7 Bit Poster

    Messages:
    1
    I was just about to reinstall VMWare when I ran across this post. The Network Conditioner fix did work for me (at least for now). However, the resource usage setting mentioned here seems to be the real fix. The medium setting is "recommended" as the best mix and not mentioned at all in the responses by Parallels support above. I wouldn't intuitively think that this would severely limit network speeds, but it sure does.
     
  7. strells

    strells Product Expert

    Messages:
    557
    Agreed. Switching to No Limit fixed this issue for me as well. I did not think that networking would be so severely affected by this setting.
     
  8. MikeE3

    MikeE3 Bit Poster

    Messages:
    1
    Just wanted to confirm that enabling Network Conditioner solved the slow Windows 10 networking problem for me. I would have expected exactly the opposite, so thanks for everyone who posted.

    Parallels Version 14.0.1 (45154); Windows 10 Pro version 1803 OS build 17134.345
    Parallels Configuration: Hardware: Network: Source: Shared Network (Recommended) [I believe this was the default when I set up the VM, but it's been several years and upgrades since then.]
    With Network Conditioner not checked (in that same configuration tab--also the default), Windows was topping out at 3 Mbps download (per Windows Task Manager, Performance tab).
    Enabling Network Conditioner immediately allowed Windows to max out my connection. Disabling it put the limit back to 3 Mbps. Etc. Guess I'll leave it enabled. (Profile is Custom, Bandwidth: unlimited, Packet Loss: 0%, Delay: 0ms for both in- and outbound.)
     
  9. JoelP1

    JoelP1 Bit Poster

    Messages:
    2
    For anyone reading this thread and wondering whether or not to turn on Network Conditioner, see if you can tell the spot where I turned it on! While some posters state it's a temporary fix and setting VM Configuration -> Options -> Optimization -> Resources usage to "No Limit" is the permanent fix, turning on Network Conditioner was sufficient for me to get through a giant batch of Windows Updates!
    upload_2019-4-16_0-23-23.png
     
  10. Andrew_Backer

    Andrew_Backer Bit Poster

    Messages:
    4
    This worked for me too! As well as the network conditioner. The settings should really reflect that one affected the other, because there is no way to know.
     

Share This Page