Shift key not working for first character when Remote Desktop connected

Discussion in 'Windows Guest OS Discussion' started by ConsultDavidW, Aug 29, 2014.

  1. WimC

    WimC Bit Poster

    Messages:
    7
    Hi Swati. Unfortunately the error remains with that setting.

    I have observed something else:
    - In a W10 Bootcamp VM this problem is not there in multi-monitor
    - In a regular W10 VM it appears in multi-monitor
    The mouse cursor also behaves differently:
    - In W10 Bootcamp it stays white all the time (or whatever you have set it to) when you move from one monitor to the other
    - In a regular W10 VM the mouse cursor changes from white (Windows) to black (macOS) when you move to another monitor and only after you click once, it becomes white again
     
  2. LeoR2

    LeoR2

    Messages:
    1
    Hi,
    registered to explain what i had experienced and what i did to resolve my issue.
    1) The issue showed up when using an APPLE keyboard within Parallels Windows VM.
    1a) keys would not function like a Windows keyboard. For example Apple key + TAB would not do the same as WinKey+TAB to display your windows Virtual desktops.
    1b) i had issues with my shift key when trying to RDP within Parralells Windows VM to another remote desktop. (same as everyone reported)
    1c) any windows based key combinations that I would try within Windows VM while using Apple keyboard would invoke Apple shortcuts, like opening spotlight or switching spaces...etc

    My solid solution:
    I connected a Windows Keyboard to my laptop and in Parallels menu selected -> Devices -> External Devices -> USB Keyboard (to be assigned to my Windows VM)

    This completely solved it for me. Only caveat is that i have to use two keyboards. One - the windows keyboard for my Windows VM, and secondly, the Apple keyboard for anything outside the VM.
    The great news is that all your Windows Special keys combinations work very well within the Windows VM like i initially had tried to do (1a above) Also, this solved my SHIFT key function issue that I was experiencing and that others have identified.

    I hope this really helps. If I'm not clear on what I had explained, just ask.

    Thanks
    Leo.
     
  3. krs1105

    krs1105 Bit Poster

    Messages:
    11
    FWIW, since upgrading to v13 I have not had the shift key problem. But from past experience it comes and goes. So holding my breath.....
     
  4. Ronald Bokleman

    Ronald Bokleman Bit Poster

    Messages:
    32
    This is utterly ridiculous. This same issue exists on v13 and it's been driving me nuts until I found this thread. I changed the keyboard to 'Game Optimized' and so far so good as the Shift-->Shift mapping did nothing for me on Windows 10 trying to RDP to a Windows Server 2016 VM.
     
  5. Chamathl

    Chamathl

    Messages:
    1
    I faced the same issue and i changed the setting to solve it. Go to the show options in the remote desktop pop up. Then Local resources tab. Then select the drop down as "on this computer".
    it worked for me and all the keys are working for me :)
     
    Maria@Parallels likes this.

Share This Page