Since upgrading to P4, can't report failures or hangs

Discussion in 'Windows Virtual Machine' started by edeslaur, Mar 19, 2009.

  1. edeslaur

    edeslaur Member


    P4 is a lot more "resistant to hangs" - but that generally manifests itself as the guest OS being hung and the spawned P4 child process (guest OS container window, not the window that lets me select an OS) not being responsive. When I Force Quit, I don't get an option to report the failure, so Parallels is not obtaining information that properly represents my user experience. It's cathartic to send a crash report, so this adds to the frustration that it hung.

    Does anyone have a recommendation?

    On another note, since upgrading to P4, my guest OS hangs every few days after being up overnight. I come in, no joy. I can shutdown the P4 guest OS container, but if I do not shutdown all processes, the new guest OS I start will hang again later in the day, reasonably consistently (or at least by the next morning).

    If I shutdown all of P4, or reboot the Mac, then the guest OS is good for another 3-6 days.

    Any suggestions for that one?
  2. edeslaur

    edeslaur Member

    Is this a "no", then?
  3. desgael

    desgael Pro

    Could you please clarify the memory settings, Mac's memory and the amount of virtual memory allocated to Parallels?
    Try to lower virtual memory for guest OS.
    Also, in Parallels Desktop -> Preferences -> Memory, is it set to allocate memory automatically?

    When Parallels hangs you can check in Finder -> Applications -> Utilities -> Activity monitor what exactly is happening with memory and CPU usage on Mac.
  4. edeslaur

    edeslaur Member

    When hung, the Activity Monitor sometimes reports the Parallels process as not responding, however I haven't seen the prl_vm process reported as hung, which is using full cpu (high 90s/99s) - but the guest OS is hung.

    If I kill the Parallels process, both windows sometimes go away (that little pick-your-OS-to-start window, and the guest OS window). If I then restart Parallels, the hung window sometimes comes right back up in its same state (displaying the same guest OS windows and all). I then need to kill the parallels process and the prl_vm (or whatever it's called) process, then I can get a "clean" restart of parallels without rebooting the Mac. At this point, however, the Mac usually would not shut down by itself anyways, I would need to force the shutdown (hold down power switch). A shutdown will just hang. I don't have this problem unless I can no longer print (new since P4, "fixed" after a reboot, I'll fire up that thread soon) or P4 has hung.

    My theory (unsubstantiated) is that the prl_vm didn't really go away - haven't checked in Activity Monitor before trying Parallels again - but I find it strange that the window disappears when I kill the parallels process but the proc wouldn't end.

    I have 2GB allocated for the guest OS, 4GB on the MacBook Pro (max for that model). And I use most of it in the guest OS, so I'm not keen on lowering it.

    Performance usually gets decent after 30m or an hour (Windows is just slow, like Outlook is cleaning up its files in the background - I'm assuming Windows is doing who-knows-what during that period), but then degrades a over time (becomes slow to respond to mouse clicks or bring recently-used windows into focus on guest OS is one key measure (I'm not perceiving the should be coming out of guest OS virtual memory since it's not using more than the amount of Physical RAM allocated, but it sometimes feels like that) ).

    When it hangs, it's always after being up overnight, not while I'm using it during the day. I've started to leave Outlook's InBox as the in-focus window and use the time the last email was received to roughly judge the hang time (last message in the inbox). Sometimes the last message displayed is time-stamped around 9PM, 3AM, 4AM, 6AM, so nothing really consistent there other than "overnight"

    All other apps on Mac work fine (mostly MS Office stuff).
  5. Birdman

    Birdman Member

    Hi! Eric,

    Is there anything to do with the Time Machine?

    I also have similar situation you mentioned, working for one or two days and hung overnight.

    I noticed that there is still some high usage of prl_vm_app (around 80 ~ 90% of CPU time) after i quit the PD4 when abnormal no response from my guest OS - WinsXP.
  6. edeslaur

    edeslaur Member

    I do have Time Machine installed, however I don't leave my external disk installed overnight (eject it) since I don't have a locking tether for it.

    Time Machine usually runs when I'm using it.
  7. edeslaur

    edeslaur Member

    XP SP2 running as guest OS
    RAM - 2048MB
    Video - 256MB (128 is displayed as recommended, can't remember why I bumped it, but it resolved that issue)
    Mac has 4GB physical RAM
    Parallels Desktop -> Preferences -> Memory, is set to allocate memory automatically (tried manually, IIRC, that tanked performance)

    OK, here's a first - my instance hung during the day. I clicked a icon group (Outlook) on the taskbar and in the middle of ghosting it in, the machine locked up. I was disconnected from the LAN at the time, running over wireless (Shared network device), no external devices (including HDD for Time Machine, which hasn't been connected in a couple of days).

    Unlike other times, prl_vm_app reporting a consistent 6.7% CPU and 32 threads. parallels desktop is reporting a shifting 1.3%/0/1.4%, etc. and 12 threads.

    1. Virtual Machine.Shutdown does not do anything
    2. Virtual Machine.Stop does stop the process

    When I Force-Quit "Parallels Desktop" (yep, prl_vm_app is still running, but the window representing my Windows OS desktop quit with the Force Quit, the the Mac taskbar lost the little bullet next to the icon showing it was running.
    2. Restart parallels from the Mac taskbar
    2a. Window comes right back up in the same state as when I killed the Parallels Desktop process (I get it.)

    More fodder for the cannon. If there's a way to determine if it's related to Parallels or the host OS, happy to know it. This one definitely seems Windows related, unlike the others.
  8. edeslaur

    edeslaur Member

    Ok, hung again during the day.

    Now I can NOT start Activity Monitor, I can't start Terminal.
    Terminal is up (dot next to the icon on the dock), but clicking it has not effect.

    Mac Word, Excel, PPT all start fine. In fact, I'm typing this in Safari right now.

    The mouse will turn to the finger icon for Chrome when I click on the XP SP2 guest OS, but it's done.

    Machine is running a bit slower, so something's cranking.

    I'm going with NOT the guest OS on this one.

    How to proceed?

    Thank you,
  9. edeslaur

    edeslaur Member

    Ok, Force Quit on Parallels, all the XP processes disappeared from the Dock. But Terminal and Activity Monitor still not coming up.

    Additional note - earlier today I started a print job to a USB printer from the XP guest OS. It printed about 1/2 the page then stopped. I stopped the print services in XP, deleted the files, restarted, then tried again - nothing.

    Disconnected and opened the file from the Mac side and printed it just fine.

    Stranger and stranger...

Share This Page