Slight keyboard lag in Windows 11 ARM?

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by Khoji, Nov 13, 2023.

  1. Khoji

    Khoji Member

    Messages:
    77
    I don't think this is really a bug, it just seems to be an unavoidable characteristic of running Windows 11 for ARM under Parallels on an Apple Silicon Mac. I'm running the latest version of Parallels 19 on a Mac Studio M1 Max with 64GB of memory. Everything works fine, the only slight annoyance is that there is a very slight keyboard lag when I am touch typing. You will probably not even notice it if you are not a fast touch typist, but if you are you will have a feeling of a very slight sluggishness. It isn't really enough to hinder work.

    The effect is mostly psychological: The only way I can describe it is that there is a subjective feeling of more "effort" while you are typing. When typing on a normal Windows machine, or directly under MacOS, typing is instantaneous. In Windows 11 for ARM under Parallels 19 I always have the feeling that there's a very slight delay after each key press

    Again, it's not really enough to slow down work in any way, but it is subjectively distracting enough to be annoying. Does anyone else experience this?
     
  2. Pramesh Boodadoo

    Pramesh Boodadoo Staff Member

    Messages:
    542
    Hello,
    Thank you for reporting this issue. We have created a case for further investigation and has requested you additional information via your mail.
    Thank you.
     
  3. AbiolaI1

    AbiolaI1 Bit poster

    Messages:
    3
    Maybe not slow enough for for you but it really hinders my productivity and the productivity of many others.

    There is an existing thread for the issue https://forum.parallels.com/threads...s-ver-17-and-18-on-windows-11-m1-chip.358862/.

    Parallels should do something about this, as someone that primarily use parallels for software development, it has been rendered useless for me. And I am wishing I never paid for Pro subscription.
     
    SLIMES likes this.
  4. Dalingrin

    Dalingrin Bit poster

    Messages:
    1
    I have the same issue. It has been annoying me for a long time now.
     
  5. DennisT11

    DennisT11 Bit poster

    Messages:
    3
    I have been using Windows 11 on an older MBP with Intel chip and a M3 Max. I can report that it seems to affect only the Apple Silicon.
    I slowed down my typing and some times, you just get duplicates letters or commas. I thought it was just me - but it doesn't happen when I type in Mac software.

    Any hope of a fix?
     
  6. DennisT11

    DennisT11 Bit poster

    Messages:
    3
    I have just asked Support and their agent has suggested:

    Regarding the permissions, please follow the below steps:
    1. Click on the Apple icon to the top left of your screen.
    2. Click on System Settings.
    3. Click on "Privacy & Security".
    4. Click on "Full Disk Access" in the list.
    5. Toggle/check if Parallel Desktop is on.
    6. Click on "Privacy & Security".
    7. Click on "Accessibility" in the list.
    8. Toggle/check if Parallel Desktop is on.
    9. Click on "Privacy & Security".
    10. Click on "Screen Recording" in the list.
    11. Toggle/check if Parallel Desktop is on.

    Another step I would suggest is to enable optimise for games for the keyboard. To do this, follow the below steps:
    1. Shut down the virtual machine.
    2. Right click on the Parallels Desktop icon in the Dock.
    3. Click on Control Center.
    4. Click on the cog-wheel/gear icon next to the MacOS virtual machine.
    5. Click on Hardware.
    6. Click on "Mouse & Keyboard" (you may need to click on the padlock to allow changes).
    7. Click on the dropdown next to Keyboard and select "Optimise for games".

    It has seemed to improve my text responses. Try it out.
     
  7. DennisT11

    DennisT11 Bit poster

    Messages:
    3
    After another week, the problem persists. Referring to Khoji, I am not a particularly fast typist, but it is not just the lag that is annoying, but the fact that every few key strokes, it will repeat the last key. Might be end of the word or a comma, or a stop. I end up having to go back to delete them - which of course takes time and naturally slows down your productivity, even if you can touch type.

    I think it is a bug. I have already updated to the latest version of Parallels
    Version 19.4.0 (54962)

    I have the same version running on an older i9 Macbook Pro and that doesn't have the same problem.

    If anyone has any ideas, that would be great.
     

Share This Page