Slow resume after reboot

Discussion in 'Installation and Configuration' started by gradkal, Jul 24, 2010.

  1. gradkal

    gradkal

    Messages:
    7
    Hi,

    I have a Win XP vm in Parallels 5. It works well and I would normally suspend and resume it. If I suspend and resume it while my MBP is still on everything is fine and it comes up again in a few seconds. But if I suspend it and shutdown the Mac or do a reboot the next resuming goes up fast to 60 % and then stucks there for a few minutes. After that time, the vm comes up. This procedure takes longer than booting new in Win XP, so for me suspend/resume is useless.

    Can anyone help me to resume the machine faster after a reboot?
     
  2. Ben Mattison

    Ben Mattison

    Messages:
    12
    Hello,

    I have the exact same problem. I am currently emailing with Parallels support about it, but they have not been helpful thus far. The most recently response said essentially that this is expected behavior. As you say, it makes suspending somewhat useless.

    My memory is that this did not happen in previous versions of Parallels. Can you (or anyone else) confirm?

    Ben
     
  3. Ben Mattison

    Ben Mattison

    Messages:
    12
    Here's the final word from Parallels:

    And my response.

     
  4. Ben Mattison

    Ben Mattison

    Messages:
    12
    Update: Parallels is now acknowledging that this is a problem. Resume after boot is apparently supposed to be slower but not that slow. My issue was kicked up to a second-level support person, who logged onto my machine remotely and didn't find any obvious reason for the problem. He is going to take it to the developers. Stay tuned.
     
  5. gradkal

    gradkal

    Messages:
    7
    Hi Ben,

    I´ve been on vacation the last weeks. I made the same experience - support says there´s nothing wrong, but fact is Parallels competitor needs 20 seconds for resuming the same machine (we tried that out on a friends Mac after converting it) and in Parallels it lasts for almost three minutes on my MBP. That did not happen in former versions of Parallels as I have a license since Parallels 3.0.

    So hopefully they fix it again in one of the next updates.

    gradkal
     
  6. Ben Mattison

    Ben Mattison

    Messages:
    12
    Here's the latest (and presumably final) word from Parallels:

    I tried reducing the size of my virtual machine to the minimum recommended, and it did speed up the resume after boot, to about 36 seconds.

    It's true that while the resume was faster in previous versions of Parallels, at least for me, it was pretty balking for a while thereafter. Now it takes a long time to resume but it works perfectly as soon as it is done resuming.

    One thing here that is somewhat maddening is that they apparently have some new idea for speeding things up -- but it won't be in a free update.
     
  7. gradkal

    gradkal

    Messages:
    7
    I also tried out to reduce the memory for the virtual machine and indeed it resumes faster with this measure. On the other hand my impression is that with the minimum memory the vm is getting terribly slow. My vm is comparatively big (35g) because a lot of business apps are still not available for Macs, so working with less memory is not the solution for me.

    Apart from this slow resuming Parallels is the best Mac virtualization software by far. So I´m hoping for improvement in Parallels 6.
     
  8. shawn feller

    shawn feller

    Messages:
    28
    I think you need to give the "other guys" a try before you make this comment.

    The slow resume is enough to jump ship IMHO. Although Ben mentioned NOT having this issue in version 4...I did and the reason I upgraded was hoping for this fix.

    My host system is 12 Gb and I've tried every combination of memory and OS (XP SP3, Server 2003 R2, Win7) and they all have this issue with resume...and it occurs more the longer the guest system is sleeping in my experience.

    Based on my comments I should have had a response from the Parallels team and free upgrades from 4 to 5 and 5 to 6 for my issues...but not...
     
  9. isee

    isee

    Messages:
    1
    I do experience the same issue. I've also tried all combination of hardware config, different memory size, different numbers of CPU cores, enable/disable Adaptive Hypervisor. All gives me more than 10 mins resume time after reboot. I'm running Win7 64bit on the previous gen i5 macbook pro with Parallel 6 with latest updates.

    This is a serious bug Parallel has. I hope they will fix this issue asap.
     
  10. Ben Mattison

    Ben Mattison

    Messages:
    12
    This issue seems to be fixed in Parallels 7 in Lion. Knock on wood.
     

Share This Page