Slow Upload Speed on Win11

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by il_6, Dec 14, 2021.

  1. MikeM44

    MikeM44 Bit Poster

    Messages:
    3
    I have the same issue. Been driving me insane.
     
    MatthiasE5 likes this.
  2. il_6

    il_6 Bit Poster

    Messages:
    6
    Well still we have no fix 6 months later, but hey at least the new version is out.
    Maybe v18 has turned this fix into a "feature" that can be had for the $70 upgrade cost.
     
    MatthiasE5 likes this.
  3. Daniel-P

    Daniel-P Bit Poster

    Messages:
    2
    I have Parallels v18 and still have the issue with slow network.
     
    MatthiasE5 likes this.
  4. LeandroP3

    LeandroP3

    Messages:
    1
    I solved this issue this time by reseting the network configurations in windows:

    in Windows go to Configurations --> Network and internet --> Advanced network configurations --> Restore network configurations

    I hope this is helpful, this problem is really annoying.
     
  5. Daniel-P

    Daniel-P Bit Poster

    Messages:
    2
    I have found the issue for me was that I kept the Optimization setting one click under "No Limit". I have run like this for years. After an update to Parallels I started having the network issues. Resetting the network card only worked for a while. I change this setting to "No Limit" and have not had the issue since. Btw, this was happening on both my work Mac (M1 Pro Max, Win11 ARM) and my personal Mac (2018, i7, Win 11 x64).
     
    MatthiasE5 and AlexanderB26 like this.
  6. MatthiasE5

    MatthiasE5 Bit Poster

    Messages:
    99
    This is absurd!
    I also kept the lever just one setting below "no limit". There are 5 speed/power settings, so I chose 4 out of 5 because that seemed like a reasonable choice to give the VM a lot of resources, but not make it draw all the CPU/HDD from MacOS in order to keep MacOS stable (I do have limited resources on my MBA M1).
    However, the 4 out of 5 setting seems to MASSIVELY curb network speed. In no way can such an massive reduction be justified for that setting. It causes an SFTP upload speed of 10 kb/s (!!!) instead of the >1250 kb/s that are available otherwise.

    This needs immediate attention by Parallels developers in my opinion. Not just do the network settings need to be adjusted - in fact the whole optimizing settings need to be changed: It makes absolutely no sense to put all three categories into one setting: hard drive, CPU, and network speed. There need to be three settings, one for each of these three categories, so users can choose max network speed, but 4/5 for RAM and 4/5 for CPU, for example.

    Please, parallels support, do reply here if this has been brought to the attention of developers.
     
    Daniel-P likes this.
  7. yung.Ocean

    yung.Ocean Bit Poster

    Messages:
    2
    I literally just registered here to share the way I found to fix the problem, since I had the same issue and Win11 was NOT USEABLE (downloading files for VS was impossible with 50KB/s !!!).
    The following Parallels-Network settings fixed my problem:
    upload_2022-10-17_14-19-34.jpeg
    Now I have my 100mb/s as it should be, good luck guys.
     
    Last edited by a moderator: Oct 18, 2022
  8. MatthiasE5

    MatthiasE5 Bit Poster

    Messages:
    99
    yung.ocean, thank you for your input-- however I CANNOT reproduce this.

    The UPLOAD speeds is ALWAYS massively reduced.

    The ONLY way to remove the UPLOAD limitation is to enable "NO LIMIT" for optimization, and DISABLE "Network Conditioner".
    It does NOT help to do user-customized network conditioner settings. (Also the preset WLAN would already be more than enough - but it still limits massively).

    this is a bug/problem.
     
  9. yung.Ocean

    yung.Ocean Bit Poster

    Messages:
    2
    Update:
    After Win11 went into sleeping mode last night, the same issue reappeared - even worse, I had no network connection at all.
    Unfortunately, my posted "workaround" doesn't help.
    @MatthiasE5 :
    I totally agree with you, it wasn't meant to be considered as "the best solution" but more as a temporary Workaround since Parallels isn't doing anything about that problem.. IMO fixing this issue should be their Prio 1 but they don't seem to pay attention.
     
  10. anchoricex

    anchoricex

    Messages:
    1
    This is a huge bug. I'm not seeing any resolution with resetting the network adapter in Windows.
     
  11. MarioT5

    MarioT5 Bit Poster

    Messages:
    3
    Still no solution from Parallels itself?
    I very politely urge you to fix this issue, or at least offer some temporary solution for everybody who is suffering by this problem!
    Thank you,
    Mario
     
  12. MatthiasE5

    MatthiasE5 Bit Poster

    Messages:
    99
    Like I said I was able to resolve the limited speed issue by enabling unlimited in parallels settings, but I am currently seeing 2505 error in even manager:
    (german) Aufgrund eines doppelten Netzwerknamens konnte zu der Transportschicht \Device\NetBT_Tcpip_{35354036-B1A9-4264-9674-C8C119ABFEED} vom Serverdienst nicht gebunden werden. Der Serverdienst konnte nicht gestartet werden.
    This MIGHT be related to me having copied the VM file, and the copying it back.
    I have restarted windows so far, and I have restarted the router. I have yet to reboot the macbook, perhaps this will resolve, I will report if so.
    My question is though, I am seing people refer to disabling the network adapter -- but when I go to device manager in windows, I cannot "disable" it, I can only uninstall it. And in Network Settings (advanced), there is a deactivate button, but when I press it, nothing happens and it remains activated. Running Win 11 Pro, NOT 22H2.
    Can anyone tell me
    a) how to disable the adapter
    b) if you were able to fix the network name error with this "fix"
    c) if the network name error causes any real issues for normal users, and if so which.

    thank you
     
  13. MatthiasE5

    MatthiasE5 Bit Poster

    Messages:
    99

Share This Page