Smart Card not being detected

Discussion in 'Windows Guest OS Discussion' started by Arnoldo, Jan 14, 2022.

  1. Arnoldo

    Arnoldo Bit Poster

    Messages:
    1
    Hello, I work for a bank, which provides me with a USB dongle to perform 2FA and a VPN connection which reroutes all traffic through their servers. For this reason, if I want to still use my MacBook while logged into the bank, a VM is the only option. Sadly, the USB dongle is not correctly recognised by Windows within Parallels.

    The configurations I tried:
    • 2016 MacBook Pro with Intel Processor + Windows 10
    • 2021 MacBook Pro with M1 Pro Processor + Windows 11 ARM
    Other details:
    • The USB dongle is called SafeNet eToken 5110
    • The software that detects the smart card certificate is called SafeNet Authentication Client
    • When I run "certutil -scinfo" from cmd, it detects the reader, but tells me to "insert smart card"
    • There are two devices without drivers within Windows: "TUSB3410 EECode Ser" and "Unknown Device"
    • The smart card gets detected in VMware Fusion and in VirtualBox, but Windows just runs too slow on these VMs
    • I tried the checkbox that enables the smart card that is configured on Mac and it gets detected, but still the certificate is not being used for 2FA
     

Share This Page