SmartStart - How to Disable? Security Concern

Discussion in 'Windows Virtual Machine' started by DerekS, Jun 8, 2007.

  1. Andrew @ Parallels

    Andrew @ Parallels Parallels Team

    Please download latest Parallels Desktop 3.0 Build 4560 update:

    It includes many bugfixes and improvements for SmartSelect feature and it is also support SmartSelect disabling option.
  2. Brian C. Stradale

    Brian C. Stradale Bit poster

    I still can't run Mac Office!!!

    What have you done to my Mac!!

    I've installed the latest... 3.0.4560.

    I disabled that stupid SmartSelect stuff.

    But I still can't run the Mac version of Office.
    Even if I click directly on them, they bounce
    once in the doc and then stop.

    This is KILLING me... I need my apps back!

    And I have to second the prior poster...

    Why on earth would you think that somebody who bought a Mac would want you to override Mac software with the Windows version of that software. That makes absolutely NO SENSE!
    This has got to be the stupidest "feature" I've heard of in a long time.

    I love the ability... but you should choose to "install the Windows app as a Mac app"... it shouldn't just override whatever was there.

    WORSE, when you turn that shite off, it should undo the changes it made to OS X... but it doesn't. Now that its turned off, I just can't invoke it at all!!!!

    So, if I uninstall Parallels, will it undo the changes that prevent me from running Mac Office apps??? Or am I going to need to wipe my OS X disk and start over??
  3. Andrew @ Parallels

    Andrew @ Parallels Parallels Team


    In build 4560 you can reset all file associations to default using menu Applications->SmartSelect->Set to Default. It should fix your problem.

    PS: If it won't help try to locate your VM folder in ~/Documents/Parallels/<VM name> and remove "Windows Applications" folder there.
  4. Brian C. Stradale

    Brian C. Stradale Bit poster

    Well, based on other threads, I tried deleting that folder. No fix.

    I went to try your suggestion... but I no longer have an Applications menu to try the "Set to Default" command. (I didn't try that before, as I assumed that meant to set it to YOUR defaults, not to the original system defaults.)

    By the way, the VM settings with 4560 do NOT stick... I keep changing the Shared Folders from my custom folder to All Mac Disks... and it soon returns to the old setting. Similar is true of the security setting... often reverts to Medium... I've set it back to Medium-High several times. The Shared Apps setting keeps coming back on. The only setting that seems to stick reliably is the Coherence setting where I checked Use multiple displays... that has yet to revert.


    Is it possible to revert to 2.5?
  5. jorge.buitrago

    jorge.buitrago Bit poster

    Andrew @ Parallels,

    I already updated my machine to build 4560, and used menu Applications->SmartSelect->Set to Default. It seems it fixed Mac OS associations problems, but I still have problems with Windows File Associations.

    I use Parallels @ work so I'm able to use Microsoft Office on Windows. My Word files associations are OK, but my Excel and Powerpoint are messed up. When I go to Windows Explorer, and I look the type column for an Excel or Powerpoint file, it appears and extension named "xls_auto_file" or "ppt_auto_file, respectively. It should appear "Microsoft Excel Document" or "Microsoft Powerpoint Document", as for my Word files which are working OK. Files do open OK on Excel and PowerPoint, but that particular characteristic, hampers my normal use of Excel and PowerPoint (e.g. moving between worksheets with keyboard shortcuts, using a Third Party software based on Excel, etc.).
    Please Help!!!! I waited all the way for build 4560, and it hasn't solved my problem so far.
    All this is getting on my nerves, is pretty frustrating. I will appreciate any aid ASAP!!!!!!
  6. wonder_mice

    wonder_mice Hunter

    Hi jorge.buitrago,
    You can try to Uninstall and then install Microsoft Office - this can help (Office must create new valid file extension descriptions)
  7. MartyMcr

    MartyMcr Hunter


    I was rather annoyed by this message Andrew - the beta test was something of a farce - you released the product when the beta had hardly started and gave virtually zero feedback. It ended just as abruptly.
  8. jorge.buitrago

    jorge.buitrago Bit poster


    I tried what you suggested (unistalling and then installing again Microsoft Office), and it didn't solve the problem (besides two hours wait to install and download again all office updates). By the way, this is the third alternative suggested by Parallels Suppor Team that hasn't worked.

    I hope that you guys, as developers of the software, reach to a succcesful solution... I'm tired of looking for solutions on the forum and writing support requirements.

    Thank you.
  9. sheathe

    sheathe Bit poster

    EXE files

    I want to be able to launch a Windows EXE in a Parallels VM from Finder... is this possible?
  10. dkp

    dkp Forum Maven

    Does that mean the connectivity layer between Windows and OS X is disabled? Currently it is possible to re-establish associations using Windows command line tools provided by Parallels - are these tools disabled in 4560? Just removing the stubs is not enough if it remains possible to recreate and execute them from within Windows.
  11. brkirch

    brkirch Pro

    The ability to execute Mac applications from Windows can be fully disabled, I've tested this by keeping a copy of the Mac application launchers that were created within Windows, disabling shared applications, and then trying to use the application launchers. The application launchers were unable to launch the Mac applications. I also don't see any way to re-enable shared applications from within Windows, so it would seem that any potential for a security breach is no longer there.
  12. Andrew @ Parallels

    Andrew @ Parallels Parallels Team

    If you have application sharing disabled in your VM configuration that means your communication channel is also disabled of course.
  13. dkp

    dkp Forum Maven

    Thanks, Andrew. I can re-install now :)
  14. stewarsh

    stewarsh Member

    Setting Default Apps

    Hi all,

    You might want to checkout It's a freeware control panel that lets you specify what program can open what file either by extension, type, or URL code. You can search by file or by program. It's quite useful for resetting a lot of the stuff that smartselect changed.
  15. D. Alan Stewart

    D. Alan Stewart Bit poster

    Another reason to disable application sharing

    It interfers with Microsoft SharePoint web sites. SharePoint has a feature that allows editing a file on the web site in place. I'm expected to be able edit certain Excel files on the company Sharepoint web site in this way. When the first version of Parallels that supported application sharing came out, I started getting an error that a SharePoint-compatible application is not available to edit the file. When I disabled application sharing and the error went away.

    Unfortunately build 5160 seems to have a bug preventing disabling application sharing. I've reinstalled Parallels Tools with this feature left out. Now Windows no longer shows Mac applications in the "Open With" dialog. However, SharePoint is still broken.

    This is a BIG issue because I'm expected to use this SharePoint site on a daily basis.
  16. alexg

    alexg Parallels Developers

    Hi Alan,

    Could you please describe the error exactly as it appears on your screen or provide us the screenshot with that error.


Share This Page