Solaris 11 64bit on Parallels Desktop 9 Mac

Discussion in 'Other Virtual machines' started by as2014, Mar 1, 2014.

  1. as2014

    as2014 Bit poster


    has anybody succeeded to install Solaris 11 64bit on Parallels Desktop 9 Mac? I am aware, that it's not a supported guest VM. But maybe there is a workaround?



    P.S. In fact I can not understand at all, why it's not supported.
  2. ZevonB

    ZevonB Bit poster

    The 7.4GB+ full DVD install .iso cannot be mounted by the Parallels environment, but you can use the 'live' Solaris 11 .iso then upgrade over the Network...
    Tedious, but works
  3. Abdul@Parallels

    Abdul@Parallels Parallels Support

  4. Specimen

    Specimen Product Expert

  5. mavidal

    mavidal Product Expert

    I installed solaris 11.1 under parallels 9 in 64 bit mode and it runs fine. You do not have none of the bells and whittles with the parallels tools, but the os runs without issues on my Mac Pro.

    To be specific, it is the x86 image that I downloaded and installed.

    Last edited: Jun 2, 2014
  6. Specimen

    Specimen Product Expert

    So it's not Solaris 11.1 64 bit (x64), it's Solaris 11.1 32 bit (x86).

    As to 64 bit mode you are referring you are talking about the Parallels app, but there is no 64 mode (as opposed to a 32 bit one), PDM 9 app is 64 bit only (not to be confuse with the ability of running 32 bit guests).
  7. mavidal

    mavidal Product Expert

    Hi Specimen:

    No, you have to download the x86 distribution, that is both for AMD64 and 32 bit, and it recognizes what kernel it has to install, either 32 or 64. From Oracles website:

    " The isainfo command output for an x86 based system that is running the 64-bit kernel is displayed as follows:

    $ isainfo
    amd64 i386

    This output means that this system can support 64–bit applications."

    That is what I am getting, additionally:

    "Use the isainfo -v command to determine if an x86 based system is capable of running a 32–bit kernel.

    $ isainfo -v
    64-bit amd64 applications
    fpu tsc cx8 cmov mmx ammx a3dnow a3dnowx fxsr sse sse2
    32-bit i386 applications
    fpu tsc cx8 cmov mmx ammx a3dnow a3dnowx fxsr sse sse2
    This output means that this system can support both 64–bit and 32–bit applications.

    Use the isainfo -b command to display the number of bits supported by native applications on the running system.

    The output from an x86 based system that is running the 32–bit Solaris Operating System is displayed as follows:

    $ isainfo -b

    The isainfo command output from an x86 based system that is running the 64–bit Solaris Operating System is displayed as follows:

    $ isainfo -b

    You can also use the isalist command to determine whether an x86 based system is running in 32–bit or 64–bit mode.

    $ isalist
    amd64 pentium_pro+mmx pentium_pro pentium+mmx pentium i486 i386 i86
    In the preceding example, amd64 indicates that the system has 64–bit Solaris capabilities enabled."

    Having entered all of the command, it shows that I am running a 64 bit version of solaris. If people are downloading the sparc version it will never work since that is a totally different processor architecture.

    Mike V.
    Last edited: Jun 5, 2014
  8. MrLisboa

    MrLisboa Bit poster


    I couldn't install Solaris 11.2 as guest VM on Paralles Desktop 9. Just to inform I'm using the live iso provided at Oracle's web site (, and of course it's the x86 Live Media. The issue I'm experiencing is with the graphical environment, because when it's starts, the installation process hangs and never displays the screen.

    Has anybody succeeded to install this guest OS?

    Marcelo Lisboa
  9. mavidal

    mavidal Product Expert

    Good question, will have to try it. I know 11.1 installs.
  10. JarosławH

    JarosławH Bit poster

    Unfortunately, I must confirm issues too:
    - when I'm trying to boot from installation DVD (downloaded from ), the boot process hangs on

    SolarisOS Release 5.11 Version 11.2 64-bit
    Copyright (c) 1983, 2014, Oracle and/or its affiliates. All rights reserved
    The CPU usage of prl_vm_app hits 100% and nothing more. I'm experiencing it on Parallels 8 and on P9 (just upgraded). I've reported it as Service Request 48748557.

    Best regards,
  11. Samuel_Younge

    Samuel_Younge Bit poster

    I have the same hanging problem with Solaris 11.2 using x86 Live Media.iso, but the text installer.iso works fine. You do not have the X environment installed by default, but the system works otherwise. I hope this is fixed soon as I really want to be able to run the Solaris GUI.
  12. RickW5


    The best way to go around is :
    - install solaris 11 with the text installer. make sure you install solaris without the gui.
    - when solaris has been installed, go on the console, and manually install the desktop environment, like so:

    root@geeklab:~# pkg info -r solaris-desktop
              Name: group/system/solaris-desktop
           Summary: Oracle Solaris Desktop
       Description: Provides an Oracle Solaris desktop environment
          Category: Meta Packages/Group Packages
             State: Not installed
         Publisher: solaris
           Version: 0.5.11
     Build Release: 5.11
    Packaging Date: September 19, 2012 06:53:17 PM
              Size: 5.46 kB
              FMRI: pkg://solaris/group/system/solaris-desktop@0.5.11,5.11-

    root@geeklab:~# pkg install solaris-desktop
               Packages to install: 369
           Create boot environment:  No
    Create backup boot environment: Yes
                Services to change:  14
    voila ! worked with me on Parallels Desktop 15 on MacOS Catalina - Solaris 11.4 standard installation DVD (USB)

    The only thing what is missing are the Parallels Tools for Solaris. Missing Coherence and so on.
    salvomic likes this.
  13. salvomic

    salvomic Hunter

    I did the same and it worked well. I agree: we need Parallels Tool. Please!
  14. EGN

    EGN Bit poster

    Solaris VMs created on Parallels Desktop can be run on Desktop Lite, but installation ISO images won't boot on Desktop Lite so new VMs cannot be created. I've also tried with OpenIndiana and OmniOS and those did not boot either.

    I already tried enabling/disabling UEFI but that did not help. Any ideas?
  15. SourVader

    SourVader Bit poster

    Ran across this thread looking for an answer as well. I tried with OpenIndiana Hipster and it did not boot. Tried disabling UEFI using vm.bios.efi=0 and that did not work either. Is there a fix for this by any chance?

    Incidentally, I downloaded VMWare Fusion and OI booted out of the box and easily installed VMWare tools (Solaris) without issue.

Share This Page