Solid green page in MS Teams

Discussion in 'Windows Virtual Machine' started by AzinS, Jun 13, 2023.

Tags:
  1. AzinS

    AzinS Member

    Messages:
    34
    using Parallels Desktop 18.3.0 on a MacBook Pro M1 Max, when I share my screen on MS Teams, users only see a solid green page. Sharing the windows works fine. Also sharing the screen on Teams Web works fine as well. I have disabled hardware acceleration on Teams setting but the issue still persist.
     
  2. AzinS

    AzinS Member

    Messages:
    34
    os: Win 11 Pro
    teams version: 1.6.0 arm
     
  3. Pramesh Boodadoo

    Pramesh Boodadoo Staff Member

    Messages:
    542
    Hello,
    For us to further investigate the technical issue, kindly provide us with the following information:
    1. Collect a technical report (right-click Parallels icon in Dock > Help > Send technical data > check "Attach screenshots..." > press Send Report) and provide us with the report's 9-digit ID in reply to this post.
    2. The Microsoft Teams build that you are using.
    Thank you!!
     
  4. AzinS

    AzinS Member

    Messages:
    34
    I noticed it only happens when the Windows VM is in the full screen mode.
    report ID: 428132014
     
  5. AzinS

    AzinS Member

    Messages:
    34
  6. RichardY2

    RichardY2 Bit poster

    Messages:
    3
    I'm having this same issue and an extreme performance slowdown when I start sharing my screen in MS Teams. I can hardly resize, open, or navigate other apps or Windows. I'm going to try with hard acceleration disabled and report back.
     
  7. Pramesh Boodadoo

    Pramesh Boodadoo Staff Member

    Messages:
    542
    Hello,
    As a possible solution, kindly follow the below steps:
    1. Shut down your Windows 11 virtual machine and quite Parallels Desktop
    2. Click on the "Apple" menu in the top-left corner of your screen and select "System Settings" from the dropdown menu.
    3. In the System Settings window, locate and click on the "Security & Privacy" icon.
    4. In the Security & Privacy settings, on the right pane.
    5. Scroll down the left sidebar and click on "Screen Recording."
    6. On the right side, you will see a list of applications that have requested screen recording access. Look for Parallels Desktop in the list.
    7. If Parallels Desktop is not already in the list, click on the lock icon in the bottom-left corner of the window and enter your administrator password to unlock the settings.
    8. Once unlocked, click the "+" button below the application list to add an application.
    9. A file browser window will open. Navigate to your Applications folder, find Parallels Desktop, and select it. Then click the "Open" button.
    10. Parallels Desktop should now appear in the list with a checkmark next to it.
    11. Close the Security & Privacy settings, and you should now have granted Parallels Desktop permission for screen recording in Ventura OS.
    12. Verify it the issue is still present.
      Thank you.
     
  8. AzinS

    AzinS Member

    Messages:
    34
    hi @Pramesh Boodadoo i have followed the steps above and the same issue still persists. The Parallels was already in the list. I removed and added it again.
     
  9. KhairulN

    KhairulN Bit poster

    Messages:
    1
    Hi,

    I am having the same issue and followed the workaround by adding Parallels "Screen Recording" in the Mac "Privacy and Security" settings. But I am still having the same issue and other participants will see a green screen when I am sharing screen using Microsoft Teams apps installed on the Windows 11 Arm guest VM.

    I have also tried disabling the "GPU/hardware acceleration" within the MS Teams but the issue persists.

    Is there any resolution or another workaround for this issue?
     
  10. AzinS

    AzinS Member

    Messages:
    34
    on my machine if I don't use the Win in full screen mode (just exit from full screen and resize the window yourself) then Teams works fine.
     

Share This Page