Solidworks 2022

Discussion in 'Windows Guest OS Discussion' started by josiah2, Feb 8, 2022.

Tags:
  1. josiah2

    josiah2 Bit Poster

    Messages:
    2
    Hi Y'all,

    I'm new to parallels (migrating from VMware) and SolidWorks is running slow as a dog. I let parallels do the default windows 10/11 installation and set it to "Configure for Design" allocated 16 gigs of ram and 8 processors for the VM. I know I haven't allocated too much because everything outside the VM is plenty peppy, and I'd assume these values should work because they are what I used for my VMware setup.
    My system specs: 2.4 Ghz 8-core i9, 32 GB 2400 MHz DDR4, Radeon Pro 560X 4GB

    Anyways, I'm fairly certain this is a graphics card related issue. I noticed this exists (https://kb.parallels.com/en/122790) but it doesn't appear to have a reg file for SW 2022. I tried the 2021 version in the off chance it would still work and I still wasn't able to uncheck the 'enable software openGL', so I'm fairly confident that using the 2021 registry values for 2022 isn't going to cut it.

    Is there a timeline on when these files are going to be released? Does anyone have any alternative suggestions?

    Thanks!
     
  2. PrometheusT

    PrometheusT Bit Poster

    Messages:
    2
  3. MatthewH18

    MatthewH18 Bit Poster

    Messages:
    13
    Also wanting to run SW 2022 SP2 on my M1. Any help appreciated
     
  4. MatthewH18

    MatthewH18 Bit Poster

    Messages:
    13
    I just got this working. running M1 Pro, loaded, windows 11 arm, parallels 17.1 Regular install of Solidworks 2022 SP2 works with some caveats.

    Turn off file sharing with the mac, otherwise you won't be ale to save files from Solidworks (with sharing on, the pathname starts with \\mac\..." rather than"C:\...") Solidworks refuses to save unless it sees a full path back to the physical device. Open "windows 11" configuration screen from Parallels. Select "options", "sharing", "configure". Uncheck the 6 folders.

    I also had trouble with the center mouse button not enabling rotation. Under the configuration for windows 11, select "hardware", "mouse and keyboard". set mouse and keyboard to "don't optimize for games". That seemed to do it.

    Rendering seems slow with 6 cpus, but have not jumped into that yet...
     
  5. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    1,148
    Hello, great to hear your issue has been fixed. And thank you for sharing the details.
     
  6. cem1

    cem1 Bit Poster

    Messages:
    3
    Hi Josiah

    I have same problem in m1 max .. did you find any solution about SolidWorks ? Its working so slow as you say . I checked ram & Cpu .. its not use too much . But in GPU side I didn't see any movement .
     
  7. josiah2

    josiah2 Bit Poster

    Messages:
    2
    Yeah well no thanks to these a-holes that charge us for "support" and then ignore our messages...

    but if you follow the link in my original post, they now have a registry file for SW 2022. Essentially, make sure you apply the appropriate registry mod for the version of SolidWorks that you're running and then you go (in solidworks) Tools > options [system options] > Performance. You want to make sure "Use Software OpenGL" isn't checked (if it is, it won't use your graphics card). I have no idea if the registry edit from the link will actually work for you since you have an M1 but here's to hoping.
     

Share This Page