Solved: Instructions for installing Parallels Tools on Ubuntu server

Discussion in 'Linux Guest OS Discussion' started by sam452, Dec 17, 2018.

  1. sam452

    sam452 Bit Poster

    Messages:
    25
    I've installed a few Debian, Ubuntu from ISO into Parallels but have YET to figure out how to install Parallels Tools. The latest attempt is with a Ubuntu Live Server 18.04. After it installs there is a message to "Please remove the installation medium". Checking the Parallels Menu > CD/DVD menu shows the Disconnect item checked.

    I have rebooted this Guest OS and examine the /media and the /dev/cdrom and find no devices at all.
    sudo mount -o exec returns that the mount was executed incorrectly.
    I have searched multiple times over the year to determine how to get this installed, but in my view the instructions are not clear as I follow and do not get these tools installed.
    Clicking the Parallels alert icon/Install Parallel Tools returns:
    "Click Continue to connect the Parallels Tools" with instructions to go to the CD/DVD directory. Perhaps for Ubuntu there's another directory?
    Clicking "Continue" returns "The CD/DVD disk is mounted inside the guest operating system" If I disconnect this disc now, the guest OS all not recognize its absence.
    ls /media returns nothing
    ls /dev/cdrom returns '/dev/cdrom' with no file in it. It appears to be a link to /dev/sr0 which itself is not where any files are loaded.
    I've also tried to mount the pro-tools-lin.iso from the Parallels 14 application folder. What am I doing wrong?
     
  2. sam452

    sam452 Bit Poster

    Messages:
    25
    Kept looking online for results, and it turns out there is an answer. https://kb.parallels.com/en/121370
    What I had to do in the new Ubuntu Server Guest,
    sudo mkdir /mount/cdrom
    then go through the Parallels interface to ensure that the prl-tools-lin.iso was mounted in the CD/DVD menu item. Usually clicking the yellow alert icon in the Guest OS window will work.
    THEN I could follow the instructions to install from the command line and then restart. That is a key part that s/b in the docs.
     
  3. sam452

    sam452 Bit Poster

    Messages:
    25
    A follow up: In my Ubuntu 18 guest, the OS did not recognize the cdrom as mounted.
    After ensuring that the correct image is understood as mounted in the Parallels interface, these steps worked as sudo
    mkdir /media/cdrom
    mount -o exec /dev/sr0 /media/cdrom #this seems to set an arbitrary /dev and associate it with this new directory.
    cd /media/cdrom #this now works because Ubuntu "sees" the cdrom image and has mounted it.
    ./install #because you should now be viewing the contents of the mounted .iso
     
    RAnthony likes this.

Share This Page