[SOLVED] Parallels Tools Fail to Install in Oracle Linux VM

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by StefanH28, Jan 9, 2024.

  1. StefanH28

    StefanH28 Bit poster

    Messages:
    2
    Hello, I'm on a Mac Mini M2 Pro, trying out Parallels. I have an Ubuntu 22.04.2 ARM64 VM which works fine; installing Parallels Tools was just a click.
    On the other VM, Oracle Linux 8, I can't get it to work. The installation log (see attached screenshot; sorry for not pasting the text, because I can't copy it from the VM due to the lack of Parallels Tools :() seems to indicate that the Parallels Tools installer uses the Red Hat compiler, while the kernel was compiled with GCC. The Red Hat compiler (CC) seems to choke on a couple of command-line options.
    What to do to overcome that issue?
     

    Attached Files:

  2. Mitch2

    Mitch2 Bit poster

    Messages:
    1
    Here's what I did after much frustration:

    Install gcc-12 and some of its parts:
    yum install gcc-aarch64-linux-gnu.aarch64 gcc-c++-aarch64-linux-gnu.aarch64 gcc-toolset-12.aarch64 gcc-toolset-12-runtime.aarch64 gcc-toolset-12-gcc-c++.aarch64

    Then went into /usr/bin and temporarily renamed the gcc binary to gcc-8. The gcc-12 install didn't replace the gcc binaries in /usr/bin. Symlinked the new gcc to /usr bin/gcc:

    mv gcc gcc-8
    ln -s /opt/rh/gcc-toolset-12/root/usr/bin/gcc gcc

    ran the tools installer and it completed. Then nuked the symlink and put the old gcc binary back.

    It appears to be working. This is on OEL8.9

    Hope this helps?
     
  3. StefanH28

    StefanH28 Bit poster

    Messages:
    2
    Thanks much, Mitch2! Amazingly, this actually worked, and has saved me a lot of the frustration you had!
     
    Mitch2 likes this.

Share This Page