Something went wrong. Please try again later - Getting error on Chromebook

Discussion in 'Parallels Client for Google Chrome' started by KrunalP, Mar 9, 2021.

  1. KrunalP

    KrunalP Bit Poster

    Messages:
    1
    Something went wrong. Please try again later - Getting error on Chromebook
    Downloaded Windows 10 image, after download completed when I open Parallels, I am getting error
    'Couldn't open Parallels.
    Something went wrong, please try again later"
    upload_2021-3-10_0-48-31.png
     

    Attached Files:

  2. NeilC12

    NeilC12 Bit Poster

    Messages:
    1
    This might be a known issue. I first encountered this issue back in November 2020 when Parallels first announced the product. It was working fine on a couple of devices that I have within our org....specifically the Pixelbook Go, Acer Spin 13, and Lenovo Flex 5. In December, something broke....my guess is a Chrom OS update. The ONLY device that I'm able to get Parallels to run on is the Lenovo Flex 5. EVERY other device that I've tried....including the new Samsung Galaxy 2 Chromebook gets the same error. I can download the image, but when launching Parallels....I encounter the same thing as you. Perhaps reach out to support and get another issue in their queue. I've not heard an update from them since January 19th, 2021. I've been occasionally searching reddit and google for any recent posts.....yours is the first one I've ever encountered with any resemblance of the issue that I've been having. :)
     
  3. MikhailU@Parallels

    MikhailU@Parallels Parallels Support

    Messages:
    20
    Hello Neil and Krunal,
    A possible reason for this behaviour might be the fact the virtual machine was in a suspended state when it had been exported. Please try updating the exported image to the one when the virtual machine is in the shutdown state and check if it works.
     

Share This Page