Spinning screen in games in mouse-look

Discussion in 'Windows Guest OS Discussion' started by RyanT, Oct 11, 2009.

  1. RyanT

    RyanT

    Messages:
    2
    I've run into a bit of a problem when trying to use the mouse to look around in FPS-style games in my Windows XP virtual machine on a MacBook Pro. While the W-A-S-D/arrow keys work fine for movement, and I can click, right click and even click and drag correctly, entering into mouse-look causes the view to spin rapidly any time the mouse is moved.

    This spinning persists regardless of what view setting I have the VM using. I've experimented with using the Devices menu to lock the keyboard and mouse to the VM, and that fixes the spinning, but since the host Mac isn't receiving the input, the mouse cursor stops visibly moving on screen, which makes doing anything pretty much impossible. I've attempted to uninstall Parallels Tools so that the mouse locks to the VM and needs to be toggled back to the host Mac with ctrl+alt, but the games I'm attempting to run won't launch without the Tools installed.

    I've run into a similar issue using Synergy, a network-based KVM switch. When using the mouse and keyboard of another machine, the view in FPS-style games would spin endlessly in mouse-look unless I locked the input to the machine running the program. If I could somehow do this with Parallels/Parallels Tools it might work.

    Is there an option to specifically disable the mouse/keyboard sharing feature within Parallels Tools but keeps the others intact? I think this would solve my problem, but I can't seem to find any documentation for doing such a thing.

    Thanks!
     
  2. PatrickJ

    PatrickJ Bit Poster

    Messages:
    90
    Has anyone figured out a way to fix this? I have this same problem in a couple of 3d creation programs (Unity for windows, Blender (depending on mode) and Source's Hammer (map editor for Half Life games).

    Any tips would be appreciated! Other than this, I'm completely loving Parallels 5.
     
  3. marctraiderm

    marctraiderm Bit Poster

    Messages:
    6
    Sync

    Hello.

    I am also aware of this problem, and believe me, this problem has been around for ages since I've first worked with Virtual Machines. And this doesnt matter whether its Vmware workstation on windows, vmware fusion on mac, remote control with VNC, or Parallels. It all doesnt matter.

    And I do not really believe this problem is actually a problem with a remote program. or any virtual machine at all.
    I rather think this is some kind of limitation between native mouse control -> "remote program/virtual program" -> Virtual/remote machine.

    Although there MUST be a way to finally fix the problem with these kind of problems once and for all. There must be some workaround.


    Before you read on, I dont have a clean nor approved solution, but it might help you. And the explanation is of what I understand of the whole mouse business. It might contain untrue statements.
    I've been experimenting with both VMware and Parallels and it seems to be related (as for the VM programs) to the Mouse synchronization service. Now as I understand, the mouse synchronization service or driver has been created for the following purpose (By the way in Parallels it is called smartmouse, and vmware has another name for it);

    1. First of all the mouse sync driver is primarily designed for you to being able to move your mouse from your host system to the guest system window without having to manually grab the window. It actually 'detects' whether the host mouse cursor is moving on the VM's screen. This is giving the mouse spinning problems because here comes the second part:

    2. This mouse is actually not the real mouse cursor, but its actually processed by the host system virtual machine to make mouse movement smoother. The sync driver/service just passed the movements to the real vm, but the real vm cursor is actually not there. (Do I make any sense here?) This is basically what I understand of the whole picture, being experimenting with it and all...

    To prove this, and let you guys feel the difference with Mouse synchronization on or off, you know what I mean:
    Disabling the Mouse synchronization either on the virtual machine settings (smartmouse) or in the guest OS you will notice the sudden sluggishness of the mouse movement. You can actually say that it is using the real mouse now.
    This method might solve your problems, but the mouse doesnt feel quite right anymore.

    You can also notice the different 'tracking speed' and 'mouse acceleration, curve'. This is because the synchronization driver also passed the movement settings of your host mouse to the guest machine. Now it is using Windows's normal movement speed and acceleration curve as it should in native Windows. And last but not least; You have to grab and ungrab the Guest Window evertime you want to switch.

    What methods are there for you?
    I told you explicitly that you could disable mouse synchronization either by Host or by guest. Or both. Is there a difference? Actually YES! What do I mean by this?

    Well, you can disable the host synchronization by altering the virtual machine settings. This will disable both Host and Guest Sync. But I have a method which disables the synchronization on the guest side, and leaving synchronization (smartmouse) on the host enabled.

    What use might this be? Well, this actually means that you can still move your mouse from the host to the guest without having the grab the window. But still let the guest handle the mouse movement. This should prevent the mouse spinning.

    Bad news, I've only successfully tested this on VMware fusion.
    But I will tell you the quite simply explanation; Leave Smartmouse on in virtual machine preferences.
    In the guest OS, go to device manager and search for the Mouse synchronization driver. Go to preferences and update the driver to the Standard PS/2 Mouse.

    Ok thats that! No more spinning and still having smartmouse on!
    I have not yet tried this on Parallels, but in the coming days I will try and get this to work on parallels as well.

    See you then ;)
     
  4. marctraiderm

    marctraiderm Bit Poster

    Messages:
    6
    hello

    Got some news. I've successfully tried the procedure on parallels as well.

    Instead of updating the sync driver(s) to standard PS/2 mouse, I had to update it to the HID compliant mouse (Not HID compliant device)

    This seems to work!

    Again, all this will keep the 'smartmouse' function enabled. The only side affect again is that the mouse still feels sluggish. And there might be some milliseconds of weirdness when dragging the mouse from the host over the guest window, but I've only observed this in Vmware fusion.


    I hope that both vmware and parallels implements a new mouse handling feature or fixes this long-term problem because this obviously doesnt work for many people.
    There is an extra smartmouse option besides on or off, auto. But this only applies to fullscreen applications (mainly) and not other 3D applications or CAD programs where you need to navigate the 3D image with your mouse. And this is the most common problem all these years.

    Im currently using Valve Hammer editor which requires that you move in the 3D view with your mouse. This is no permanent solution but it does work.
     
    Last edited: Nov 12, 2010
  5. KJMarket

    KJMarket

    Messages:
    5
    Could you exlaion how to do this in Parallels? I mean how to update it to HID instead of PS/2?
     
  6. Denis V. Lunev

    Denis V. Lunev Parallels Developers

    Messages:
    122
    Ryan,

    could you please name the game you are experiencing troubles with. It would also be a great help if you'll make a problem report and post its number here.

    Sorry for inconvenience and thank you in advance for cooperation.
     
  7. marctraiderm

    marctraiderm Bit Poster

    Messages:
    6
    Ryan.

    I wish parallels finally fix the mouse problem we all have with certain applications. Not only with games but also windowed programs like CAD where you have a small window where you need to move the camera. The mouse just spins like crazy and the only solution is to disable 'smartmouse'. or mouse synchronization.

    But the problem here is: If we do that we dont have the ability to move over the screen anymore, and the mouse becomes jerky.

    Could parallels implement some smarter mouse than smartmouse? because it does not only apply to fullscreen games but mouse spinning also happens in windowed 3d modes were you need your mouse to navigate.

    Im particulary having problems in Valve Hammer Editor.
     
  8. andar_b

    andar_b

    Messages:
    4
    I'm definitely having this issue in Runes of Magic, working on a fix of some sort. I was utterly surprised, the last time I tried to run RoM in a VM, the mouse would respond normally, but the cursor was absent.
     
  9. PatrickJ

    PatrickJ Bit Poster

    Messages:
    90
    Small world.. I'm also trying to use Hammer. I got excited about the 990 update as it mentioned mouse fixes -

    "- Address a mouse handling issue that causes incorrect transitions between SmartMouse modes in 3D applications and games."

    Blender works now (used to have the same spinning issue in camera view). I'm reinstalling Unity to see how that works.
     
  10. PatrickJ

    PatrickJ Bit Poster

    Messages:
    90
    Unity also works great.. I hope this can get sorted out w/ Hammer!

    TY Parallel Devs!
     
  11. AaronT2

    AaronT2 Bit Poster

    Messages:
    1
    Reviving an old issue, but I have this problem with the Vampire: Bloodline install from GOG on Windows 7 running in Parallels on a new Retina MBP. Changing the mouse optimization for games doesn't seem to do much, but the Windows Mouse setting of "Enhance pointer precision" seems to help just a little. It's still extremely difficult to control, though. This is with Parallels 11.2.0 (latest as of this writing).
     
  12. TiereW

    TiereW Bit Poster

    Messages:
    1
    I am also dealing with the same issue but this knights of the old republic.
     

Share This Page