SQL Server on Windows 11 - M1 MACS

Discussion in 'Parallels Desktop for M Series Mac' started by Karthikeyan1, Nov 6, 2021.

  1. MalikA2

    MalikA2 Bit Poster

    Messages:
    1
    try sql server 2014 x86 it worked for me
     
  2. JasonK26

    JasonK26 Bit Poster

    Messages:
    1
    Hi Lukas, I am very new to this and I have to download 2019 SQL Server Developer for one of my classes. I have parallels and whenever I try opening the file for SQL it shows that it cannot mount. I was wondering if you had a contact that I would be able to message for help on running SQL Server Developer.
     
  3. RobertM66

    RobertM66 Bit Poster

    Messages:
    2
    Hi @LukasV2, I am very impressed and grateful that you have solved a problem that many (including techs at Parallels and Microsoft) said couldn't be solved. I'm quite new to all this. I admittedly know very little about SQL server, and came to your work having tried unsuccessfully to transition from a Windows 10 VM on an Apple Intel based machine, where I used a program that used (and automatically installed) SQLExpress 2012 to manage its databases. That program fails when it tries to install SQLEXPRESS 2012 on Win 11 VM on the M2 Apple machine. I was able to run your Install2019Express .bat and script on my Macbook Air with M2 under most recent Parallels 18 on a Win 11 Pro VM, and I believe it successfully installed the default instance. However, what I needed was to be able to specify particular parameters including 1) the SQL Instance Name, 2) the Login ID (User Name?, eg. "sa"), 3) the Password that the particular program I use requires in its use of SQL to manage its databases, and 4) the directory where the database files will be stored. Do you have a way to do this? Is there a way I might reach you for more information about how to do this (eg. do I need to uninstall the installation of the default prior to doing whatever is needed to install a particular Instance specifying the above info)?
     
  4. TomW21

    TomW21 Bit Poster

    Messages:
    1
  5. RobertM66

    RobertM66 Bit Poster

    Messages:
    2
    @LukasV2, Thanks again so much for your remarkable solution. I apologize for the naivete and lack of sophistication of my previous comment/question. I was able to successfully modify your script to install MS SQL Server Express 2019 with a specific alternatively named instance. I found that trying to add /SECURITYMODE AND /SAPWD parameters to the argument list led to failure, but then successfully made those changes and backup directory changes post-installation, using SQL Server Management Studio. The result works successfully with the application that had been using SQL Server on an Intel-based Mac Windows VM. Cannot thank you enough.
     
  6. JamesO8

    JamesO8 Bit Poster

    Messages:
    2
    LukasV2,
    Thank you so much for providing the scripts. That was a lot of work.

    I'm afraid that my hopes of being able to come back to Windows on Parallels on my MBP 14 are going to be lost. Except for your scripts that address a specific installation case, it does not seem that SQL and its installer are supported officially on ARM hardware. I had to move all my VMs to Azure when I got my new MBP, but wish to also be able to have a fully functioning VM locally.

    I was successful in getting the downloads to run and the installer to do its thing, and I can access the DB with Studio, but am still coming up short.
    I wish to build a VM with SQL Express 2019 and Oracle Primavera P6.

    1. Is there a way to just run the installer wizard instead? I need to set particular parameters during the installation process. Like: SQL authentication, and instance name. I think I can change both of those from Studio, and enable SA account, etc...
    2. The biggest show stopper for me though is I am unable to enable TCP\IP. Under Network Configuration, Protocols, in the SQL Configuration Manager tool, there are no entries--it's just blank. I just need to set a default IP address.

    Out of curiosity, why would Microsoft not support / provide a SQL product that is supported on ARM hardware?

    Thanks in advance,

    Jcalchi
     
  7. iulik

    iulik

    Messages:
    1
    Hello,
    I successfully installed sql server 2022 wit the script thanks for providing.
    Unfortunately I get an when I try to enable FILESTREAM on this server my guess is that the problem again is related to the ARM processor. Has anyone installed the server with the script is able to enable FILESTREAM and do you have any ideas for a workaround ?
     
  8. RobertoA7

    RobertoA7 Bit Poster

    Messages:
    4
    @JamesO8
    I was able to set those parameters via:
    Code:
    set-itemproperty -path 'HKLM:\software\microsoft\microsoft sql server\mssql15.MSSQLSERVER\mssqlserver\supersocketnetlib\tcp\ipall' -name tcpdynamicports -value '' ;
    
    set-itemproperty -path 'HKLM:\software\microsoft\microsoft sql server\mssql15.MSSQLSERVER\mssqlserver\supersocketnetlib\tcp\ipall' -name tcpport -value 1433 ;
    
    set-itemproperty -path 'HKLM:\software\microsoft\microsoft sql server\mssql15.MSSQLSERVER\mssqlserver\' -name LoginMode -value 2 ;
     
  9. MarcinP2

    MarcinP2 Bit Poster

    Messages:
    5
    To update Features :
    Go to your Install Folder of the SQL Server/x64/DEFAULTSETUP.INI

    Edit the Default Config and disable Updates
    [OPTIONS]
    PID=22222-00000-00000-00000-00000

    UpdateEnabled=False

    deinstall the needed feature
    install the needed feature

    And everything works :-D

    www.piu.de
     
  10. UncleG

    UncleG Bit Poster

    Messages:
    1
    @JamesO8 Regarding TCP/IP, you can enable it directly from the windows registry (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL15.MSSQLSERVER\MSSQLServer\SuperSocketNetLib\Tcp).
    For now, the biggest problem for me is FILESTREAM.
     

Share This Page