SSL errors using Bridged Network

Discussion in 'Windows Guest OS Discussion' started by MNG, May 3, 2021.

  1. MNG

    MNG Bit Poster

    Messages:
    4
    I can't recall when this started happening but it was probably after a Mac OS Big Sur update many moons ago. I'm currently on 11.2.3 (20D91) and latest Parallels version. Basically, I was previously using Bridged Network just fine. I do web development and app development so the Windows VM serves up the web site and services my app connects to. All that was working just fine then it broke. What I noticed was that on the Windows VM I couldn't get to any websites and the ones that I could get to had content errors. When I inspected the network communications via Chrome or Edge "inspect" feature showed a bunch of SSL errors. My antivirus also couldn't download and install updates. When I switched to "Shared Network" I can use my Windows VM as expected other than being able to connect mobile devices to it, so that doesn't seem to be a feasible solution. I appreciate any help anyone can offer.
     
    HenrikN likes this.
  2. MNG

    MNG Bit Poster

    Messages:
    4
  3. ParallelsU3

    ParallelsU3 Bit Poster

    Messages:
    1
    I had exaclty the same issue - any fix is welcome!
     
  4. MNG

    MNG Bit Poster

    Messages:
    4
    Anyone?
     
  5. Elric

    Elric Parallels Developers

    Messages:
    1,713
    Hi,
    Please try the following:
    Start the /Applications/Utilities/Terminal.app and execute the following command (without wuotes). Note, it will ask for password:
    "sudo sysctl net.link.bridge.segmentation=0"
    If this helps, then it is an identified issue that is fixed in upcoming macOS Monterey
     
    DavidK35 and HenrikN like this.
  6. MNG

    MNG Bit Poster

    Messages:
    4
    Elric, thanks for the reply. That worked!
     
  7. NicoleS6

    NicoleS6 Bit Poster

    Messages:
    3
    After upgrading from Catalina to Big Sur (11.5.2), I'm seeing an issue very similar to the original poster (I'm also using Bridged Network mode - with Wifi in my case) - I have a lot of content errors and my console is full of ERR_SSL_PROTOCOL_ERROR errors on my Windows 10 vm and I have to refresh a page multiple times to get it to load correctly. I'm using the latest Parallels (17.0.1). I tried the fix noted here with no luck (and that setting is changed back to 1 after I restart my host Mac). Any other ideas?
     
  8. NicoleS6

    NicoleS6 Bit Poster

    Messages:
    3
    As an update, I was able to get my bridged network setup working by flipping the net.link.bridge.segmentation setting to 0 as mentioned by Elric AND ALSO changing my network adapter in Parallels from Intel PRO/1000 MT to Realtek. I'm not sure if there is an incompatibility with the Intel adapter or if just making the adapter change prompted Parallels to update some config that a restart of my vm did not. I'm happy to have it working but also concerned about this as a fix until Monterey is out of preview and early release.
     
  9. DoniK

    DoniK Kilo Poster

    Messages:
    118
    Wish this worked for me. PD 17.0.1, macOS 11.6. Changed net.link.bridge.segmentation=0, changed network adapter to Realtek. I get an internet connection with bridged network, but get a ton of timeouts and it's unusable. Extremely frustrating since bridged network is essential for my work, one of the main reasons I use a VM.
     
  10. DoniK

    DoniK Kilo Poster

    Messages:
    118
    @NicoleS6 does this still work for you since 11.6 update? Are you still on PD 17.0.1?
     
  11. Elric

    Elric Parallels Developers

    Messages:
    1,713
    > changed network adapter to Realtek
    No need to switch to Realtek, this doesn't affect the issue. Better switch back to virtio. Please let me know in direct message if you have problems even with virtio adapter and net.link.bridge.segmentation=0 configured, we could investigate this in direct message.
     
  12. DoniK

    DoniK Kilo Poster

    Messages:
    118
    Thanks, Elric. Switched back to Virtio and all good. Turns out I also had an IP conflict with another VM, in addition to this issue. Sorry about that, but appreciate your help!
     
    Elric likes this.

Share This Page