Starting a virtual machine crashes Mac Pro (new Intel tower)

Discussion in 'Parallels Desktop for Mac' started by faddante, Aug 9, 2006.

  1. dobbs

    dobbs Bit poster

    Same problem on a new 20" IMac

    I have this same problem on a new IMac and new version of Parallels. I'm interested in a solution, but from the looks of this thread, no progress has been made in a month. I don't think turning off processors or reducing speeds is much of a solution either. Frankly, I'm surprised the Apple store is even selling this.
  2. jbmelby

    jbmelby Member

  3. kgregc

    kgregc Member


    1884 and the new 1892.6 both work on my iMac. Download 1892.6 and post your will work.
  4. Andrew @ Parallels

    Andrew @ Parallels Parallels Team


    Internal build 1896.2 should work fine on all Mac Pro and iMac Core 2 Duo with 2G RAM or less. There are still issues with more than 2G RAM - it could work and it could not - but no more kernel panics anyway. We are working hard on supporting more than 2G RAM and will deliver solution soon. As temporarily workaround you can use maxmem 2048 boot option.

    Internal build 1896.2 can be downloaded from here - We apologise for inconvinience.
  5. ctebo

    ctebo Bit poster

    1896.2 isn't working any better for me on my Mac Pro (2.66 + 3GB of RAM).

    With 1896.2 installed, I no longer see kernel panics, but instead, after some period of use, my Mac locks up completely, requiring a power down. To install XP required 3 attempts, as this problem occured in my first 2 attempts. Once the install completed, it seems every attempt to run the VM will lock up my mac within 10 minutes, requiring powering down and rebooting.

    As my mac has > 2G RAM, i have spc ified the maxmem 2048 boot option. Any other thoughts or suggestions?
  6. Andrew @ Parallels

    Andrew @ Parallels Parallels Team


    Does it work for you with restricted memory maxmem=2048?
  7. ctebo

    ctebo Bit poster


    Sorry for not being clear about the memory settings... The problems I described above with 1896.2 are occuring when maxmem=2048 is being applied. I have not even tried without the maxmem=2048.

    Some additional info that might be helpful with this.... I've noticed that just before parallels locks my machine up, one of my cpus goes to 100% utilization in activity monitor, and stays there. It seems to sit at 100% cpu for perhaps 10 to 20 seconds prior to locking the whole machine.
  8. jbmelby

    jbmelby Member


    I'm having a similar problem. When I try to launch the VM, sometimes I get the beach ball and I can't either quit or force quit Parallels, although it doesn't always lock up my machine completely. In order to quit Parallels, I have to reboot (I've tried simply logging out and back in, but that doesn't work; it quits Parallels, all right, but if launch it and then try to start my VM, I immediately get the beach ball).

    Other than that it runs beautifully—no kernel panics, networking is OK (I'm using host-only with Internet sharing), and shared folders work.
  9. dnanian

    dnanian Member

    I'm experiencing the same thing: with maxmem=2048 I'm still not working properly, beachballing and having failed VM starts.
  10. Member

    Everything has been working great with my 2.66Ghz / 2GB RAM Mac Pro.

    XP Pro
    CentOS 4.4
    Fedora Core 5
    RHEL 5 beta 1
    Ubunto 6.06.1

    I no longer have to do the network-shuffle (jumbo packets on / off) with 1896.2. I haven't really played with VT-x support.

  11. MacProUser

    MacProUser Junior Member

    I'm still getting the spinning beach ball with 1896.2, it starts during Windows loading after it has resized the screen, with the blue Windows welcome screen, sometimes get's a little further but not much.

    I have maxmem=2047 set, I do have 6GB installed. If I set -legacy option, then it works fine.

    Edited to add:
    System Version: Mac OS X 10.4.7 (8K1079)
    Last edited: Sep 17, 2006
  12. Andrew @ Parallels

    Andrew @ Parallels Parallels Team

    Thank you valuable information! It will help with fixing.
  13. zzzachi

    zzzachi Junior Member

  14. Andrew @ Parallels

    Andrew @ Parallels Parallels Team

    Yes, exactly .
  15. tlxreed

    tlxreed Bit poster

    crash and burn

    For what it's worth, build 1884 sends my Core Duo Intel iMac 1.83 GHz system into an immediate reboot when I launch an XP virtual machine.

    Reinstalling build 1848 resolves the problem.
  16. dnewman

    dnewman Bit poster

    Just wanted to mention a related experience with Parallels Desktop for Mac (1848) and
    the Cisco VPN 3000 client....

    System is a new 2.33 GHz Intel Core 2 Duo, 2 GB 667 MHz DDR2 SDRAM,
    24" iMac running Mac OS X 10.4.7. Install of Parallels tripped a KP which
    put the system into an endless series of boot - KP - boot - KP. So, I safe booted,
    uninstalled Parallels and then looked for culprits. Decided that since the panic
    logs pointed a finger at that I should try to deinstall
    the Cisco VPN 3000 client. The Cisco supplied /usr/local/bin/vpn_uninstall
    script triggered a KP when it tried to run

    /System/Library/StartupItems/CiscoVPN/CiscoVPN stop

    so I moved the CiscoVPN directory out of /S/L/SI, rebooted, and then successfully
    ran /usr/local/bin/vpn_uninstall.

    With the Cisco VPN out of the way, 1848 of Parallels Desktop for Mac installed nicely.
    Now, to install Windows XP Pro. Guess I'll run the Cisco VPN under it until such time
    that Cisco issues a VPN client which doesn't trigger kernel panics. And, I have no reason
    to believe that Parallels was at fault here: judging by Google results, lots of folks have been
    experience KPs with the Cisco VPN client (usually when shutting down their intel Mac).

    Last edited: Sep 18, 2006
  17. Pleiades

    Pleiades Member

    It works!

    I'm pleased to say that with the new 1896.2 build, my 3GB 2.66GHz Mac Pro is successfully running my WinXP Pro virtual machine without issue, except for that outstanding Apple bug leaving VT-X turned off. Previously running with VT-X on after sleeping my Mac Pro, Parallels would kernel panic. Now that problem has gone away and I am running at full speed with max RAM.

    Great job, Parallels! Now convince Apple to fix that bug. Why did they leave VT-X off by default in the first place?

    I just noticed one weirdness. With Parallels running, my Cisco VPN won't start.

    It killed my Cisco VPN altogether. Now it won't run at all even after a reboot. I also had an oddity. I was upgrading the firmware on one of my Slingboxes within Windows when the keyboard stopped working inside Windows, though it worked fine in Mac OS. I shut down the VM and tried to launch it again. It failed with a "cannot access VM" error. Odd.

    I restarted, slept the Mac, started up. Upgraded another Slingbox and shut down. This time it started back up just fine. I wonder now whether reinstalling VPN will fix it.
    Last edited: Sep 18, 2006
  18. glberen

    glberen Bit poster

    After this latest build my Remote Desktop software doesn't work either. Something else to go along with the Cisco VPN...

    At least the build stops the kernel panics, but it just results in the spinning beachball of death everytime I try to run something.

    Mac Pro 4GB.
  19. bryanb12

    bryanb12 Bit poster

    I can confirm the bug posted above as well. Cisco VPN connects but RDP no longer works and several other networking apps will not work when Cisco VPN client is connected.

    build 1898
    MBP 17" 2GB
    XP sp2


    Edit: Uninstalling/Reinstalling the Cisco VPN client fixed my problems.
    Last edited: Sep 19, 2006
  20. Pleiades

    Pleiades Member

    Odd, I have the reverse problem. My Cisco VPN is dead. It bounces once on the dock and stops. My Remote Desktop (Microsoft version) works just fine.

Share This Page