Starting from scratch

Discussion in 'Windows Guest OS Discussion' started by Shelob, Oct 20, 2009.

  1. Shelob

    Shelob

    Messages:
    6
    Hi folks

    My Windows VM has recently become highly unstable. Internet Explorer started crashing more often than not, I began receiving warnings that certain sectors could not be accessed, which prevented McAfee from running normally, and eventually Visual Studio (my only reason for having a Windows VM) became unusable, essentially crashing every time I opened it.

    Here is what I have done thus far:

    1) Because IE was the program crashing the most, and given IE8's reputation for causing hassles, I tried to uninstall it. This failed, as my research into the IE8 issues suggested it might. When I restarted Windows all I could see was the wallpaper, and the only way to do anything was via New Task in Windows Task Manager.

    2) Reverted to an earlier Snapshot, uninstalled Service Pack 3 as suggested for resolving the IE8-won't-uninstall issue, and repeated the IE8 uninstall process. Exact same result.

    3) Reverted to the same earlier Snapshot and left IE8

    4) In order to check of the issue was some hard-drive corruption I then tried to run an error-check following the usual route (My Computer->Local Disk(C:)->Properties->Tools-> Error checking, but when the Windows VM restarted as necessary it threw up a couple of lines about the process and then said it was complete and opened Windows. It took at most 1 second, so it did nothing.

    5) Since it's a VM I thought perhaps that I needed to run the check through my host Mac, which I did using the First Aid feature of Mac's Disk Utility, which found some sectors in need of repair, and which I then repaired using the boot disc.

    Q: Will this have checked the Windows VM for corrupt sectors as well, since it exists within the Mac, and which might explain the strange behavious when running Error-Check in Windows, or will this have only scanned the Mac and left any corrupt Windows sectors undisclosed?

    6) At this point I was running Windows from an earlier Snapshot, and it worked for a couple of days (albeit with a still unstable IE and with McAfee also acting screwy) but then yesterday it shut down of its own accord, perhaps from an automatic update, and when it restarted it threw up this message "this application has failed to start because dnsapi.dll was not found" and will not boot up.

    7) I have again reverted to the same earlier Snapshot, have uninstalled McAfee since it kept crashing, and am now running Malwarebytes' Anti-Malware. I will then install AVG and run a complete scan.

    If the scans reveal nothing serious then I am faced with the task of deleting my VM and starting from scratch - not a train smash, but I want to make sure I do it right.

    Is there a best method for deleting a VM, and should I uninstall and reinstall Parallels as well?

    I'm tired of digging through a seemingly endless list of possible causes for my problem, and if starting from scratch is sure to resolve them all then I am happy to do that. I'd just like some input on how to ensure this, given that I still don't actually know what the source of my problems is.

    I am running Windows XP via Parallels 3.0 on a Mac Pro 2xDual-Core Intel.


    Thanks!
     
    Last edited: Oct 20, 2009
  2. desgael

    desgael

    Messages:
    344
    Since the errors are essentially inside the virtual machine it is easy to start from scatch - just create a new virtual machine and install Windows in it. This can also be done for testing purposes.

    You can also, if you would like to try fixing the issue, use Repair Windows installation (it is usually suggested to create a backup of a virtual machine, should be located in /Users/<username>/Documents/Parallels/<VM_name>/winxp.hdd Just copy the .hdd file to some other place.) using the following article: http://kb.parallels.com/en/5138

    And you can run a checkdisk from the recovery console. To get to the recovery console, you can follow steps 1-2-3 (skip 4) and 5 from this article.
    Once you get to the console, follow the corresponding Microsoft article (run "chkdsk drive /p /r").
     
  3. Shelob

    Shelob

    Messages:
    6
    Hi desgael

    So my .hdd file is actually in /Users/<username>/Library/Parallels/ but more importantly, it's ~100GB. This seems much larger than I recall it ever being, though it has been some time since I tinkered with this. Could the size be inflated by Snapshots, or is that kept separate (I see a Snapshot folder which is about 7GB in total, and I have a number of Snapshots currently saved).

    I am copying the .hdd to an external hard drive. If I want to maintain my Snapshots for this version, do I have to copy the Snapshots folder across as well or is the .hdd sufficient? I do not want to lose this version or the Snapshots associated with it, at least until I have a new working version up and running on my Mac.

    Also, I am using Parallels 3.0 - is this a problem? I'd prefer not to have to upgrade to 4.0 right now...

    Thanks!
     
  4. Shelob

    Shelob

    Messages:
    6
    Actually, I can't copy the .hdd across to my external because it's in FAT32 format (so I can use it with both my Windows and Mac machines) and the maximum filesize I can move is therefore 4GB...

    Suggestions?
     

Share This Page